aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libsdl/libsdl-image_1.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libsdl/libsdl-image_1.2.3.bb')
-rw-r--r--packages/libsdl/libsdl-image_1.2.3.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/packages/libsdl/libsdl-image_1.2.3.bb b/packages/libsdl/libsdl-image_1.2.3.bb
index b35aa3bf1e..1a911f9f62 100644
--- a/packages/libsdl/libsdl-image_1.2.3.bb
+++ b/packages/libsdl/libsdl-image_1.2.3.bb
@@ -3,15 +3,19 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "zlib libpng jpeg virtual/libsdl"
LICENSE = "LGPL"
+PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ "
-SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
S = "${WORKDIR}/SDL_image-${PV}"
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
inherit autotools
do_stage() {
- oe_libinstall -so libSDL_image ${STAGING_LIBDIR}
- ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
- install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
+ autotools_stage_all
}