aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp4xx/ixp4xx-csr-2.1
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ixp4xx/ixp4xx-csr-2.1')
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch14
1 files changed, 13 insertions, 1 deletions
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
index b90a3d7da4..39ec252a2e 100644
--- a/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
+++ b/packages/ixp4xx/ixp4xx-csr-2.1/Makefile.patch
@@ -24,25 +24,37 @@
################################################################
# Rules to check that macros are defined.
-@@ -1321,10 +1323,18 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
+@@ -1321,10 +1323,26 @@ ixp400.o : $(OBJ_DIR)/ixp400.o
ifndef IX_INCLUDE_MICROCODE
$(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(OSAL_MODULE)
++ rm -f $(OBJ_DIR)/ixp400.c
+ touch $(OBJ_DIR)/ixp400.c
+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
+ make -C $(OBJ_DIR)
++ rm -f $(OBJ_DIR)/ixp400.c
++ cp ixp400.c $(OBJ_DIR)/ixp400.c
$(LD) $(LDFLAGS) $^ -o $@
++ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
+ make -C $(OBJ_DIR)
else
$(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(NPE_PRODUCTION_HEADER_OBJ) $(OSAL_MODULE)
++ rm -f $(OBJ_DIR)/ixp400.c
+ touch $(OBJ_DIR)/ixp400.c
+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
+ make -C $(OBJ_DIR)
++ rm -f $(OBJ_DIR)/ixp400.c
++ cp ixp400.c $(OBJ_DIR)/ixp400.c
$(LD) $(LDFLAGS) $^ -o $@
++ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
+ make -C $(OBJ_DIR)
endif
+--- ixp400_xscale_sw/ixp400.c 1970-01-01 01:00:00.000000000 +0100
++++ ixp400_xscale_sw/ixp400.c 2005-08-24 22:33:12.000000000 +0200
+@@ -0,0 +1,1 @@
++#error this file must never be compiled
--- ixp400_xscale_sw/Makefile.kmod26 1970-01-01 01:00:00.000000000 +0100
+++ ixp400_xscale_sw/Makefile.kmod26 2005-08-24 22:33:12.000000000 +0200
@@ -0,0 +1,11 @@