aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg/ipkg-0.99.144/paths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ipkg/ipkg-0.99.144/paths.patch')
-rw-r--r--packages/ipkg/ipkg-0.99.144/paths.patch30
1 files changed, 28 insertions, 2 deletions
diff --git a/packages/ipkg/ipkg-0.99.144/paths.patch b/packages/ipkg/ipkg-0.99.144/paths.patch
index df21491cad..f40131e252 100644
--- a/packages/ipkg/ipkg-0.99.144/paths.patch
+++ b/packages/ipkg/ipkg-0.99.144/paths.patch
@@ -97,15 +97,41 @@ Index: C/Makefile.am
BUILD_CPU=@build_cpu@
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\"
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ \
-+ -DLIBDIR=\"$(libdir)\" -DIPKGDIR=\"$(ipkgdir)\"
++ -DLIBDIR=\"$(libdir)\" -DIPKGDIR=\"$(ipkgdir)\" -DSYSCONFDIR=\"$(sysconfdir)\"
bin_PROGRAMS = ipkg-cl
+Index: C/ipkg_conf.c
+===================================================================
+--- C.orig/ipkg_conf.c 2005-03-12 21:08:36.000000000 +1030
++++ C/ipkg_conf.c 2005-03-12 21:09:46.000000000 +1030
+@@ -103,7+103,7 @@
+ nv_pair_list_t tmp_dest_nv_pair_list;
+ char * lists_dir =NULL;
+ glob_t globbuf;
+- char *etc_ipkg_conf_pattern = "/etc/ipkg/*.conf";
++ char *etc_ipkg_conf_pattern = SYSCONFDIR"/ipkg/*.conf";
+ char *pending_dir =NULL;
+
+ memset(conf, 0, sizeof(ipkg_conf_t));
+Index: C/args.h
+===================================================================
+--- C.orig/args.h 2005-03-12 21:49:31.000000000 +1030
++++ C/args.h 2005-03-12 21:49:42.000000000 +1030
+@@ -43,7 +43,7 @@
+ };
+ typedef struct args args_t;
+
+-#define ARGS_DEFAULT_CONF_FILE_DIR "/etc"
++#define ARGS_DEFAULT_CONF_FILE_DIR SYSCONFDIR
+ #define ARGS_DEFAULT_CONF_FILE_NAME "ipkg.conf"
+ #define ARGS_DEFAULT_DEST NULL
+ #define ARGS_DEFAULT_FORCE_DEFAULTS 0
Index: C/ipkg.h.in
===================================================================
--- C.orig/ipkg.h.in 2005-02-25 15:27:58.000000000 -0600
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
-@@ -1,59 +0,0 @@
+@@ -1,60 +0,1 @@
-/* ipkg.h - the itsy package management system
-
- Carl D. Worth