aboutsummaryrefslogtreecommitdiffstats
path: root/packages/htb-init/htb-init_0.8.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htb-init/htb-init_0.8.5.bb')
-rw-r--r--packages/htb-init/htb-init_0.8.5.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/htb-init/htb-init_0.8.5.bb b/packages/htb-init/htb-init_0.8.5.bb
index e69de29bb2..503c8060dc 100644
--- a/packages/htb-init/htb-init_0.8.5.bb
+++ b/packages/htb-init/htb-init_0.8.5.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "HTB.init is a shell script that allows for easy setup of HTB-based traffic control on Linux."
+HOMEPAGE = "http://sourceforge.net/projects/htbinit"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPL"
+
+SRC_URI = "http://aleron.dl.sourceforge.net/sourceforge/htbinit/htb.init-v${PV} \
+ file://htb.init+ingress+predef+verbose.diff;patch=1;pnum=0 \
+ file://htb-basic-verbose.diff;patch=1;pnum=0"
+RDEPENDS = "kernel-module-sch-ingress kernel-module-cls-route kernel-module-cls-u32 kernel-module-cls-fw kernel-module-sch-sfq kernel-module-sch-htb iproute2 (>= 2.6.8-r1)"
+
+S="${WORKDIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/htb
+ install -m 755 ${S}/htb.init-v${PV} ${D}/${sysconfdir}/init.d/htb
+}