summaryrefslogtreecommitdiffstats
path: root/packages/hdparm/hdparm_6.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hdparm/hdparm_6.9.bb')
-rw-r--r--packages/hdparm/hdparm_6.9.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/packages/hdparm/hdparm_6.9.bb b/packages/hdparm/hdparm_6.9.bb
index 94d1e6e9bf..337a7e1e8b 100644
--- a/packages/hdparm/hdparm_6.9.bb
+++ b/packages/hdparm/hdparm_6.9.bb
@@ -4,11 +4,22 @@ SECTION = "console/utils"
PRIORITY = "optional"
LICENSE = "BSD"
+PR = "r1"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
file://bswap.patch;patch=1 \
file://uclibc.patch;patch=1"
do_install () {
- install -d ${D}/${sbindir} ${D}/${mandir}/man8
- oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove hdparm hdparm.${PN}
+} \ No newline at end of file