aboutsummaryrefslogtreecommitdiffstats
path: root/packages/giac/giac_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/giac/giac_0.5.0.bb')
-rw-r--r--packages/giac/giac_0.5.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/giac/giac_0.5.0.bb b/packages/giac/giac_0.5.0.bb
index e69de29bb2..642a851553 100644
--- a/packages/giac/giac_0.5.0.bb
+++ b/packages/giac/giac_0.5.0.bb
@@ -0,0 +1,39 @@
+SECTION = "console/utils"
+DESCRIPTION = "A free computer algebra system"
+HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
+PRIORITY = "optional"
+LICENSE = "GPL"
+MAINTAINER = "Rene Wagner <reenoo@gmx.de>"
+DEPENDS = "fltk gmp mpfr gsl"
+# ntl pari"
+
+SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac_unstable.tgz"
+
+inherit autotools
+
+PACKAGES += " lib${PN}"
+FILES_${PN} = "${bindir} \
+ ${datadir}/${PN}"
+FILES_lib${PN} = "${libdir}"
+
+# breaks the build...
+#EXTRA_OECONF = "--enable-debug=no"
+
+# skip autoreconf for now (fails due to improper local macros)
+do_configure() {
+ oe_runconf
+}
+
+do_install () {
+ oe_runmake prefix="${D}/${prefix}" \
+ bindir="${D}/${bindir}" \
+ libdir="${D}/${libdir}" \
+ includedir="${D}/${includedir}" \
+ install
+
+ # put the docs where they belong
+ # might need further investigation in case giac needs
+ # them in the original place
+ install -d ${D}/${docdir}
+ mv ${D}/${datadir}/${PN}/doc ${D}/${docdir}/${PN}
+}