aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gawk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gawk')
-rw-r--r--packages/gawk/gawk_3.1.4.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/packages/gawk/gawk_3.1.4.bb b/packages/gawk/gawk_3.1.4.bb
index 0ebcbce588..bf93f7e201 100644
--- a/packages/gawk/gawk_3.1.4.bb
+++ b/packages/gawk/gawk_3.1.4.bb
@@ -2,9 +2,9 @@ LICENSE = "GPL"
SECTION = "interpreters"
DESCRIPTION = "A program that you can use to select particular records in a \
file and perform operations upon them."
-PR = "r1"
+PR = "r2"
PACKAGES += "gawk-common pgawk"
-FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk ${bindir}/awk*"
+FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
FILES_gawk-common += "${datadir}/awk ${libexecdir}/awk"
FILES_pgawk = "${bindir}/pgawk*"
RDEPENDS_gawk += "gawk-common"
@@ -17,3 +17,13 @@ inherit autotools
do_configure_prepend () {
grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/awk awk gawk 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove awk gawk
+}
+