aboutsummaryrefslogtreecommitdiffstats
path: root/packages/flumotion/flumotion_0.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/flumotion/flumotion_0.4.1.bb')
-rw-r--r--packages/flumotion/flumotion_0.4.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/flumotion/flumotion_0.4.1.bb b/packages/flumotion/flumotion_0.4.1.bb
new file mode 100644
index 0000000000..aad4eb3382
--- /dev/null
+++ b/packages/flumotion/flumotion_0.4.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Fluendo Streaming Server"
+LICENSE = "GPL"
+DEPENDS = "gstreamer python-imaging python-gst twisted python-pygtk2"
+RDEPENDS = " python-resource python-pprint python-threading python-imaging python-xml python-curses python-compression python-fcntl python-pygobject python-pickle python-netclient python-datetime python-crypt python-twisted-core python-twisted-web python-lang python-zopeinterface python-textutils python-core python-gst python-misc"
+RDEPENDS_${PN}-gui = "${PN} python-pygtk2 python-pycairo "
+PR = "r7"
+
+SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
+ file://python-path.patch;patch=1 \
+ file://no-check-for-python-stuff.patch;patch=1"
+
+inherit autotools distutils-base pkgconfig
+
+export EPYDOC = "no"
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+#Yes, we know:
+#ERROR: flumotion-dbg is listed in PACKAGES mutliple times, this leads to packaging errors.
+#ERROR: Please fix the metadata/report this as bug to OE bugtracker.
+
+PACKAGES =+ "${PN}-dbg flumotion-gui"
+
+FILES_${PN}-dbg += "${libdir}/flumotion/python/flumotion/extern/*/.debug/*"
+FILES_${PN} = "${bindir} ${sbindir} ${libdir}/flumotion"
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+FILES_${PN}-gui = "${bindir}/flumotion-admin ${bindir}/flumotion-tester \
+ ${libdir}/flumotion/python/flumotion/admin/gtk \
+ ${libdir}/flumotion/python/flumotion/component/*/admin_gtk* \
+ ${libdir}/flumotion/python/flumotion/component/*/*/admin_gtk* \
+ ${libdir}/flumotion/python/flumotion/extern \
+ ${libdir}/flumotion/python/flumotion/manager \
+ ${libdir}/flumotion/python/flumotion/ui \
+ ${libdir}/flumotion/python/flumotion/wizard \
+ ${datadir}/pixmaps ${datadir}/flumotion ${datadir}/applications"