aboutsummaryrefslogtreecommitdiffstats
path: root/packages/e17/e-wm
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17/e-wm')
-rw-r--r--packages/e17/e-wm/disable-splash.patch11
-rw-r--r--packages/e17/e-wm/fix-configure.patch35
2 files changed, 25 insertions, 21 deletions
diff --git a/packages/e17/e-wm/disable-splash.patch b/packages/e17/e-wm/disable-splash.patch
new file mode 100644
index 0000000000..152a0a2895
--- /dev/null
+++ b/packages/e17/e-wm/disable-splash.patch
@@ -0,0 +1,11 @@
+--- enlightenment-0.16.999.015/src/bin/e_config.c~ 2005-09-22 20:50:16.000000000 -0700
++++ enlightenment-0.16.999.015/src/bin/e_config.c 2005-09-30 10:51:02.000000000 -0700
+@@ -377,7 +377,7 @@
+ /* DEFAULT CONFIG */
+ e_config = E_NEW(E_Config, 1);
+ e_config->config_version = E_CONFIG_FILE_VERSION;
+- e_config->show_splash = 1;
++ e_config->show_splash = 0;
+ e_config->desktop_default_background = strdup("");
+ e_config->desktop_default_name = strdup("Desktop %i, %i");
+ e_config->menus_scroll_speed = 1000.0;
diff --git a/packages/e17/e-wm/fix-configure.patch b/packages/e17/e-wm/fix-configure.patch
index d2ee47e014..02560fd7ab 100644
--- a/packages/e17/e-wm/fix-configure.patch
+++ b/packages/e17/e-wm/fix-configure.patch
@@ -1,10 +1,6 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- e/configure.in~fix-configure.patch
-+++ e/configure.in
+diff -Nur e~/configure.in e/configure.in
+--- e~/configure.in 2005-09-29 13:17:29.000000000 -0700
++++ e/configure.in 2005-09-29 13:19:35.000000000 -0700
@@ -114,9 +114,7 @@
AC_PATH_XTRA
AC_CHECK_HEADER(X11/X.h,
@@ -16,8 +12,9 @@
],[
AC_MSG_ERROR([Cannot find X headers and libraries.])
]
---- e/src/bin/Makefile.am~fix-configure.patch
-+++ e/src/bin/Makefile.am
+diff -Nur e~/src/bin/Makefile.am e/src/bin/Makefile.am
+--- e~/src/bin/Makefile.am 2005-09-29 13:17:29.000000000 -0700
++++ e/src/bin/Makefile.am 2005-09-29 13:19:35.000000000 -0700
@@ -1,6 +1,5 @@
MAINTAINERCLEANFILES = Makefile.in
-INCLUDES = -I$(includedir) \
@@ -26,18 +23,20 @@
-I$(top_srcdir)/src/bin \
-I$(top_srcdir)/src/lib \
@e_cflags@ \
---- e/src/lib/Makefile.am~fix-configure.patch
-+++ e/src/lib/Makefile.am
+diff -Nur e~/src/lib/Makefile.am e/src/lib/Makefile.am
+--- e~/src/lib/Makefile.am 2005-09-29 13:17:29.000000000 -0700
++++ e/src/lib/Makefile.am 2005-09-29 13:19:56.000000000 -0700
@@ -1,6 +1,5 @@
MAINTAINERCLEANFILES = Makefile.in
-INCLUDES = -I$(includedir) \
- -I$(top_srcdir)/src/bin \
+INCLUDES = -I$(top_srcdir)/src/bin \
- @ecore_cflags@ \
- @evas_cflags@
+ @e_cflags@
---- e/src/preload/Makefile.am~fix-configure.patch
-+++ e/src/preload/Makefile.am
+ lib_LTLIBRARIES = libe.la
+diff -Nur e~/src/preload/Makefile.am e/src/preload/Makefile.am
+--- e~/src/preload/Makefile.am 2005-09-29 13:17:29.000000000 -0700
++++ e/src/preload/Makefile.am 2005-09-29 13:19:35.000000000 -0700
@@ -2,7 +2,6 @@
INCLUDES = -I. \
@@ -46,9 +45,3 @@
-I$(top_srcdir)src/preload \
@x_cflags@
pkgdir = $(libdir)/enlightenment/preload
---- e/src/Makefile.am~fix-configure.patch
-+++ e/src/Makefile.am
-@@ -1,2 +1,2 @@
- MAINTAINERCLEANFILES = Makefile.in
--SUBDIRS = bin modules lib preload
-+SUBDIRS = bin modules preload