aboutsummaryrefslogtreecommitdiffstats
path: root/packages/db
diff options
context:
space:
mode:
Diffstat (limited to 'packages/db')
-rw-r--r--packages/db/db_4.3.27.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/db/db_4.3.27.bb b/packages/db/db_4.3.27.bb
index 3a233dcff1..216fb5714b 100644
--- a/packages/db/db_4.3.27.bb
+++ b/packages/db/db_4.3.27.bb
@@ -49,7 +49,12 @@ DB4_CONFIG ?= "--enable-o_direct --enable-smallbuild"
# the default - "POSIX/pthreads/library".
# Don't ignore the nice SWP instruction on the ARM:
EXTRA_OECONF = "${DB4_CONFIG}"
-EXTRA_OECONF_nslu2 = "${DB4_CONFIG} --with-mutex=ARM/gcc-assembly"
+# These enable the ARM assembler mutex code, this won't
+# work with thumb compilation...
+ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
+ARM_MUTEX_thumb = ""
+# NOTE: only tested on nslu2, should probably be _armeb
+EXTRA_OECONF_nslu2 = "${DB4_CONFIG} ${ARM_MUTEX}"
# Cancel the site stuff - it's set for db3 and destroys the
# configure.