aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apr/apr-util_1.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/apr/apr-util_1.2.7.bb')
-rw-r--r--packages/apr/apr-util_1.2.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/apr/apr-util_1.2.7.bb b/packages/apr/apr-util_1.2.7.bb
new file mode 100644
index 0000000000..ec1998d64b
--- /dev/null
+++ b/packages/apr/apr-util_1.2.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+# apache mirrors?
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm --with-gdbm=${STAGING_DIR}/${HOST_SYS} --with-expat=${STAGING_DIR}/${HOST_SYS}"
+
+inherit autotools lib_package binconfig
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -a -so -C .libs libaprutil-1 ${STAGING_LIBDIR}
+}