aboutsummaryrefslogtreecommitdiffstats
path: root/libetpan/libetpan-cvs/destdir.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libetpan/libetpan-cvs/destdir.patch')
-rw-r--r--libetpan/libetpan-cvs/destdir.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/libetpan/libetpan-cvs/destdir.patch b/libetpan/libetpan-cvs/destdir.patch
index e69de29bb2..c8cc60f709 100644
--- a/libetpan/libetpan-cvs/destdir.patch
+++ b/libetpan/libetpan-cvs/destdir.patch
@@ -0,0 +1,60 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/Rules.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Rules.in 2004-07-22 14:56:56.132455370 +0200
+@@ -3,6 +3,7 @@
+ # each submakefile should define SOURCES and TARGET
+ # optionnaly HEADRS and INCLUDES
+
++DESTDIR =
+ srcdir = $(top_builddir)/src
+ prefix = @prefix@
+ includedir = @includedir@/libetpan
+@@ -37,7 +38,7 @@
+ # install headers here only
+ install: $(HEADERS) install-recursive
+ for header in $(HEADERS); do \
+- $(INSTALL) -m 644 "$$header" $(includedir) ; \
++ $(INSTALL) -m 644 $$header $(DESTDIR)$(includedir)/libetpan ; \
+ done
+
+ Makefile: $(top_builddir)/Rules
+--- libetpan-0.33pre/Makefile.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Makefile.in 2004-07-22 14:59:17.321980703 +0200
+@@ -51,13 +51,13 @@
+ done && test -z "$$fail"
+
+ install: all install-dirs install-recursive
+- $(INSTALL) -m 755 libetpan-config $(bindir)
+- $(INSTALL) -m 644 libetpan-config.h $(includedir)/libetpan
++ $(INSTALL) -m 755 libetpan-config $(DESTDIR)$(bindir)
++ $(INSTALL) -m 644 libetpan-config.h $(DESTDIR)$(includedir)/libetpan
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(includedir)
+- $(INSTALL) -d -m 755 $(includedir)/libetpan
+- $(INSTALL) -d -m 755 $(bindir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/libetpan
++ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+
+ #realclean: maintainer-clean
+
+--- libetpan-0.33pre/src/Makefile.in~destdir 2004-05-02 18:16:58.000000000 +0200
++++ libetpan-0.33pre/src/Makefile.in 2004-07-22 15:04:02.581981625 +0200
+@@ -38,10 +38,10 @@
+ $(SUBLIBS): all-recursive
+
+ install: all install-dirs install-recursive
+- $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(libdir)
++ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(DESTDIR)$(libdir)
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(libdir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(libdir)
+
+ clean: clean-recursive
+ rm $(TARGET)