aboutsummaryrefslogtreecommitdiffstats
path: root/docs/usermanual/chapters/usage.xml
diff options
context:
space:
mode:
Diffstat (limited to 'docs/usermanual/chapters/usage.xml')
-rw-r--r--docs/usermanual/chapters/usage.xml28
1 files changed, 14 insertions, 14 deletions
diff --git a/docs/usermanual/chapters/usage.xml b/docs/usermanual/chapters/usage.xml
index 058fa5d869..1563dc3eac 100644
--- a/docs/usermanual/chapters/usage.xml
+++ b/docs/usermanual/chapters/usage.xml
@@ -5,7 +5,7 @@
<section id="usage_introduction" xreflabel="introduction">
<title>Introduction</title>
- <para>If your reading this manual you probably already have some idea of
+ <para>If you're reading this manual you probably already have some idea of
what OpenEmbedded is all about, which is taking a lot of software and
creating something that you can run on another device. This involves
downloading some source code, compiling it, creating packages (like .deb
@@ -13,7 +13,7 @@
device. The difficulties of cross-compiling and the variety of devices
which can be supported lead to a lot more complexity in an OpenEmbedded
based distribution than you'd find in a typical desktop distribution
- (which cross-compiling isn't needed).</para>
+ (for which cross-compiling isn't needed).</para>
<para>A major part of OpenEmbedded deals with compiling source code for
various projects. For each project this generally requires the same basic
@@ -642,10 +642,10 @@ Packaged contents of lzo-dev into /home/lenehan/devel/oe/build/titan-glibc-25/tm
NOTE: Not creating empty archive for lzo-locale-1.08-r14
NOTE: package lzo-1.08-r14: task <emphasis role="bold">do_package_write</emphasis>: completed
NOTE: package lzo-1.08: completed
-NOTE: Running task 223 of 226 (ID: 6, /home/lenehan/devel/oe/build/titan-glibc-25/recipes/lzo/lzo_1.08.bb, do_populate_staging)
+NOTE: Running task 223 of 226 (ID: 6, /home/lenehan/devel/oe/build/titan-glibc-25/recipes/lzo/lzo_1.08.bb, do_populate_sysroot)
NOTE: package lzo-1.08: started
-NOTE: package lzo-1.08-r14: task <emphasis role="bold">do_populate_staging</emphasis>: started
-NOTE: package lzo-1.08-r14: task <emphasis role="bold">do_populate_staging</emphasis>: completed
+NOTE: package lzo-1.08-r14: task <emphasis role="bold">do_populate_sysroot</emphasis>: started
+NOTE: package lzo-1.08-r14: task <emphasis role="bold">do_populate_sysroot</emphasis>: completed
NOTE: package lzo-1.08: completed
NOTE: Running task 224 of 226 (ID: 9, /home/lenehan/devel/oe/build/titan-glibc-25/recipes/lzo/lzo_1.08.bb, do_qa_staging)
NOTE: package lzo-1.08: started
@@ -734,10 +734,10 @@ NOTE: build 200705041709: completed</screen><note>
</varlistentry>
<varlistentry>
- <term>populate_staging (stage)</term>
+ <term>populate_sysroot (stage)</term>
<listitem>
- <para>The <emphasis>populate_staging</emphasis> task (stage is an
+ <para>The <emphasis>populate_sysroot</emphasis> task (stage is an
alternate, easier to type name, that can be used to refer to this
task) is responsible for making available libraries and headers (if
any) that may be required by other packages to build. For example if
@@ -745,7 +745,7 @@ NOTE: build 200705041709: completed</screen><note>
available for other applications to include and link against.</para>
<note>
- <para>This is different to the <emphasis>install</emphasis> task
+ <para>This is different from the <emphasis>install</emphasis> task
in that this is responsible for making available libraries and
headers for use during build on the development host. Therefore
it's libraries which normal have to stage things while
@@ -820,10 +820,10 @@ NOTE: build 200705041709: completed</screen><note>
<emphasis>qa_configure</emphasis> between the
<emphasis>configure</emphasis> and <emphasis>compile</emphasis> tasks and
another new task called <emphasis>qa_staging</emphasis> between
- <emphasis>populate_staging</emphasis> and <emphasis>build</emphasis>
+ <emphasis>populate_sysroot</emphasis> and <emphasis>build</emphasis>
tasks. The former validates the result of the
<emphasis>configure</emphasis> task and the late the results of the
- <emphasis>populate_staging</emphasis> task.</para>
+ <emphasis>populate_sysroot</emphasis> task.</para>
<para>To determine the full list of tasks available for a specific recipe
you can run bitbake on the recipe and asking it for the full list of
@@ -835,7 +835,7 @@ do_listtasks
do_rebuild
do_compile
do_build
-do_populate_staging
+do_populate_sysroot
do_mrproper
do_fetch
do_configure
@@ -853,7 +853,7 @@ NOTE: package perl-5.8.8-r11: task do_listtasks: completed
NOTE: package perl-5.8.8: completed
$ </screen></para>
- <para>If your being observant you'll note that
+ <para>If you're being observant you'll note that
<emphasis>listtasks</emphasis> is in fact a task itself, and that the
<emphasis role="bold">-c</emphasis> option to bitbake allows you to
explicitly run specific tasks. We'll make use of this in the next section
@@ -876,7 +876,7 @@ $ </screen></para>
the named recipe only. Note that this ignores any dependencies that are in
the recipe, so these must have already been built previously.</para>
- <para>Here's a typically example that cleans up the package (using the
+ <para>Here's a typical example that cleans up the package (using the
<emphasis>clean</emphasis> task) and the rebuilds it with debugging output
from bitbake enabled:<screen>$ <command>bitbake</command> -b &lt;bb-file&gt; -c clean
$ <command>bitbake</command> -b &lt;bb-file&gt; -D</screen></para>
@@ -1116,7 +1116,7 @@ do_mrproper
do_fetch
do_configure
do_clean
-do_populate_staging
+do_populate_sysroot
do_package
do_unpack
do_install