aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/site-conf/README
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/site-conf/README')
-rw-r--r--contrib/site-conf/README23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/site-conf/README b/contrib/site-conf/README
index 08976970d7..b28e545288 100644
--- a/contrib/site-conf/README
+++ b/contrib/site-conf/README
@@ -4,4 +4,27 @@ Unified source of autoconf tests used to generate the site results
Executing this on a new platform will generate the necessary results
to write the right site-conf.
+1.) creating a configure script
+ '''use autoreconf -I m4'''
+
+
+2.) adding a test
+ '''vim m4/yourpackage.m4'''
+ '''add the functions'''
+ '''AC_DEFUN([OE_CHECK_YOURPACKAGE],
+ [
+ CALL_YOUR_FUNCTION_ONE_BY_ONE
+ ])
+ '''
+
+ Add to
+ '''vim aclocal.m4'''
+ '''m4_include(yourpackage,m4)'''
+
+ Add to
+ '''vim configure.ac'''
+ '''OE_CHECK_YOURPACKAGE
+
+
+
Copy and paste the autoconf test to an approriate file