aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/eglibc/eglibc-2.9/make-3.82.patch27
-rw-r--r--recipes/eglibc/eglibc_2.9.bb3
2 files changed, 29 insertions, 1 deletions
diff --git a/recipes/eglibc/eglibc-2.9/make-3.82.patch b/recipes/eglibc/eglibc-2.9/make-3.82.patch
new file mode 100644
index 0000000000..2c8ad85aae
--- /dev/null
+++ b/recipes/eglibc/eglibc-2.9/make-3.82.patch
@@ -0,0 +1,27 @@
+eglibc-2.9: allow building with GNU make >= 3.82
+
+GNU make >= 3.82 does not allow mixed implicit and normal rules
+
+Because eglibc-2.9 is superseded by newer versions it makes no sense
+to submit this patch upstream.
+
+Upstream-Status: Inappropriate [other]
+
+Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
+
+diff -Nurd libc.orig//manual/Makefile libc/manual/Makefile
+--- libc.orig//manual/Makefile 2011-09-13 14:49:57.428424088 +0200
++++ libc/manual/Makefile 2011-09-13 14:50:47.009620484 +0200
+@@ -242,7 +242,11 @@
+ .PHONY: stubs
+ stubs: $(objpfx)stubs
+ endif
+-$(objpfx)stubs ../po/manual.pot $(objpfx)stamp%:
++$(objpfx)stubs ../po/manual.pot:
++ $(make-target-directory)
++ touch $@
++
++$(objpfx)stamp%:
+ $(make-target-directory)
+ touch $@
+
diff --git a/recipes/eglibc/eglibc_2.9.bb b/recipes/eglibc/eglibc_2.9.bb
index be60ba7423..7e0fa550da 100644
--- a/recipes/eglibc/eglibc_2.9.bb
+++ b/recipes/eglibc/eglibc_2.9.bb
@@ -3,7 +3,7 @@ require eglibc.inc
DEPENDS += "gperf-native"
FILESPATHPKG =. "eglibc-svn:"
PV = "2.9"
-PR = "${INC_PR}.10"
+PR = "${INC_PR}.11"
PR_append = "+svnr${SRCPV}"
SRCREV="10153"
EGLIBC_BRANCH="eglibc-2_9"
@@ -14,6 +14,7 @@ SRC_URI = "svn://svn.eglibc.org/branches;module=${EGLIBC_BRANCH};proto=svn \
file://shorten-build-commands.patch \
file://sh4_set_fpscr.patch \
file://sh4_local-fpscr_values.patch \
+ file://make-3.82.patch \
file://etc/ld.so.conf \
file://generate-supported.mk"
S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"