aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/tasks/task-base.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index 225258fb10..fdb0fb5628 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r95"
+PR = "r96"
inherit task
@@ -63,6 +63,9 @@ DISTRO_SSH_DAEMON ?= "dropbear"
# Distro can override apm provider
DISTRO_APM ?= "apm"
+# Distro can override alsa-state provider
+DISTRO_ALSA_STATE ?= "alsa-state"
+
#
# bluetooth manager
#
@@ -219,7 +222,7 @@ RDEPENDS_task-base-alsa = "\
# alsa-states are machine related so can be missing in feed, OSS support is optional
#
RRECOMMENDS_task-base-alsa = "\
- alsa-state \
+ ${DISTRO_ALSA_STATE} \
kernel-module-snd-mixer-oss \
kernel-module-snd-pcm-oss"