aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/v4l2apps/libv4l.inc13
-rw-r--r--recipes/v4l2apps/libv4l_0.5.8.bb4
-rw-r--r--recipes/v4l2apps/libv4l_0.6.1.bb4
-rw-r--r--recipes/v4l2apps/v4l-utils_0.8.1.bb24
4 files changed, 24 insertions, 21 deletions
diff --git a/recipes/v4l2apps/libv4l.inc b/recipes/v4l2apps/libv4l.inc
deleted file mode 100644
index 644701c39c..0000000000
--- a/recipes/v4l2apps/libv4l.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-DESCRIPTION = "libv4l is a collection of libraries which adds a thin abstraction layer on top of video4linux2 devices."
-LICENSE = "LGPLv2"
-
-SRC_URI = "http://people.atrpms.net/~hdegoede/libv4l-${PV}.tar.gz;name=libv4l"
-
-inherit pkgconfig
-
-export PREFIX="${prefix}"
-
-do_install() {
- oe_runmake DESTDIR="${D}" install
-}
-
diff --git a/recipes/v4l2apps/libv4l_0.5.8.bb b/recipes/v4l2apps/libv4l_0.5.8.bb
deleted file mode 100644
index bcc401603d..0000000000
--- a/recipes/v4l2apps/libv4l_0.5.8.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require libv4l.inc
-
-SRC_URI[libv4l.md5sum] = "4f8ae9c743b215c8ac0e553eaa01e980"
-SRC_URI[libv4l.sha256sum] = "9d006377ec51ca149ed415fbea5c3298b0fe7bae4cbd3bc2f54fd25a24ed9eb2"
diff --git a/recipes/v4l2apps/libv4l_0.6.1.bb b/recipes/v4l2apps/libv4l_0.6.1.bb
deleted file mode 100644
index 7e271f12e8..0000000000
--- a/recipes/v4l2apps/libv4l_0.6.1.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require libv4l.inc
-
-SRC_URI[libv4l.md5sum] = "0d0d96d77c98871d2e5466c10cb30a0a"
-SRC_URI[libv4l.sha256sum] = "36b93e192cd0d16d764370d0c5917a5d8257eefbaada48ba379736bdd3f22bbf"
diff --git a/recipes/v4l2apps/v4l-utils_0.8.1.bb b/recipes/v4l2apps/v4l-utils_0.8.1.bb
new file mode 100644
index 0000000000..41e337c4e9
--- /dev/null
+++ b/recipes/v4l2apps/v4l-utils_0.8.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "v4l2 and IR applications"
+LICENSE = "GPLv2/LGPLv2.1"
+
+# libv4l was absorbed into this, let OE know that
+PROVIDES = "libv4l"
+
+SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git"
+SRCREV = "${P}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}"
+
+do_install() {
+ oe_runmake install
+}
+
+PACKAGES =+ "libv4l libv4l-dbg libv4l-dev"
+
+FILES_${PN} = "${bindir} ${sbindir}"
+FILES_libv4l += "${libdir}/libv4l/* ${libdir}/*.so.*"
+FILES_libv4l-dbg += "${libdir}/libv4l/.debug"
+FILES_libv4l-dev += "${libdir}/*.so ${includedir}/lib* ${libdir}/pkgconfig/lib*"
+