summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/matchbox-session/matchbox-session.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/matchbox-session/matchbox-session.bb b/recipes/matchbox-session/matchbox-session.bb
new file mode 100644
index 0000000000..c9014f9000
--- /dev/null
+++ b/recipes/matchbox-session/matchbox-session.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Matchbox session support"
+RDEPENDS = "matchbox-common"
+# they do the same in other way
+RCONFLICTS = "gpe-session-scripts"
+
+do_install() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ ln -sf ${bindir}/matchbox-session ${D}${sysconfdir}/X11/Xsession.d/90matchbox-session
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${sysconfdir}"