summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/slugos.inc3
-rw-r--r--recipes/tasks/task-slugos.bb5
2 files changed, 6 insertions, 2 deletions
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index 837e42250c..13158e1321 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -40,6 +40,7 @@ IMAGE_BASENAME = "${@['slugos${SITEINFO_ENDIANNESS}', 'ucslugc'][bb.data.getVar(
CACHE = "${TMPDIR}/cache/${LIBC}/${MACHINE}"
DEPLOY_DIR = "${TMPDIR}/deploy/${LIBC}"
+IMAGE_ROOTFS = "${TMPDIR}/rootfs/${MACHINE}-${LIBC}-${PN}"
# The following need not be set, the defaults should be adequate
#USE_NLS = "no" or "yes"
@@ -57,7 +58,7 @@ USE_NLS_glib-2.0 = "yes"
USE_NLS_glib-2.0-native = "yes"
USE_NLS_gcc-cross = "no"
-INHERIT += "package_ipk debian testlab siteinfo"
+INHERIT += "package_ipk debian testlab siteinfo devshell"
# FULL_OPTIMIZATION
# Optimization settings. Os works fine and is significantly better than O2.
diff --git a/recipes/tasks/task-slugos.bb b/recipes/tasks/task-slugos.bb
index ffaac6747b..7abdf2577f 100644
--- a/recipes/tasks/task-slugos.bb
+++ b/recipes/tasks/task-slugos.bb
@@ -6,7 +6,7 @@
DESCRIPTION = "Task packages for the SlugOS distribution"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r28"
+PR = "r29"
PACKAGE_ARCH = "${MACHINE_ARCH}"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx|sheevaplug|qemuarm)"
ALLOW_EMPTY = "1"
@@ -85,6 +85,9 @@ kernel-module-uhci-hcd \
#"
## End - MJW
+# Add kexec, for convenience for developers (remove for release)
+SLUGOS_STANDARD_RRECOMMENDS += "kexec"
+
# Add the machine-specific RRECOMMENDS_${PN} stuff -- kernel modules required for
# network support.
SLUGOS_MACHINE_RRECOMMENDS_nslu2 = "\