summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/autotools.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 45b75dfbcf..3850ae9e48 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -160,14 +160,14 @@ autotools_do_configure() {
else
CONFIGURE_AC=configure.ac
fi
- if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
- if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
+ if grep -q "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC; then
+ if grep -q "sed.*POTFILES" $CONFIGURE_AC; then
: do nothing -- we still have an old unmodified configure.ac
else
oenote Executing glib-gettextize --force --copy
echo "no" | glib-gettextize --force --copy
fi
- else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ else if grep -q "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC; then
if [ -e ${STAGING_DATADIR}/gettext/config.rpath ]; then
cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
else
@@ -181,7 +181,7 @@ autotools_do_configure() {
done
oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
- if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ if grep -q "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC; then
oenote Executing intltoolize --copy --force --automake
intltoolize --copy --force --automake
fi