aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ruby/files/gcc44.patch19
-rw-r--r--recipes/ruby/ruby-native_1.8.5.bb5
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/ruby/files/gcc44.patch b/recipes/ruby/files/gcc44.patch
new file mode 100644
index 0000000000..dc5a608381
--- /dev/null
+++ b/recipes/ruby/files/gcc44.patch
@@ -0,0 +1,19 @@
+---
+ math.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- ruby-1.8.5.orig/math.c
++++ ruby-1.8.5/math.c
+@@ -32,11 +32,11 @@ domain_check(x, msg)
+ rb_sys_fail(msg);
+ }
+ if (isnan(x)) {
+ #if defined(EDOM)
+ errno = EDOM;
+-#elif define(ERANGE)
++#elif defined(ERANGE)
+ errno = ERANGE;
+ #endif
+ continue;
+ }
+ break;
diff --git a/recipes/ruby/ruby-native_1.8.5.bb b/recipes/ruby/ruby-native_1.8.5.bb
index e4d2a3361e..f35363d273 100644
--- a/recipes/ruby/ruby-native_1.8.5.bb
+++ b/recipes/ruby/ruby-native_1.8.5.bb
@@ -1,2 +1,7 @@
require ruby.inc
inherit native
+
+PR = "r1"
+
+SRC_URI += " file://gcc44.patch;patch=1 "
+