aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/shr-autorev-unstable.inc4
-rw-r--r--recipes/shr/libphone-ui-shr_git.bb18
-rw-r--r--recipes/shr/phonefsod_git.bb31
-rw-r--r--recipes/shr/phoneuid_git.bb23
4 files changed, 76 insertions, 0 deletions
diff --git a/conf/distro/include/shr-autorev-unstable.inc b/conf/distro/include/shr-autorev-unstable.inc
index 91754ce9f7..c84e1d652b 100644
--- a/conf/distro/include/shr-autorev-unstable.inc
+++ b/conf/distro/include/shr-autorev-unstable.inc
@@ -89,6 +89,10 @@ SRCREV_pn-shr-config = "${AUTOREV}"
SRCREV_pn-alsa-scenarii-shr = "${AUTOREV}"
SRCREV_pn-libphone-utils = "${AUTOREV}"
SRCREV_pn-python-phoneutils = "${AUTOREV}"
+SRCREV_pn-phoneuid = "${AUTOREV}"
+SRCREV_pn-phonefsod = "${AUTOREV}"
+SRCREV_pn-libphone-ui = "${AUTOREV}"
+SRCREV_pn-libphone-ui-shr = "${AUTOREV}"
# E17 stuff
diff --git a/recipes/shr/libphone-ui-shr_git.bb b/recipes/shr/libphone-ui-shr_git.bb
new file mode 100644
index 0000000000..a0922e8e24
--- /dev/null
+++ b/recipes/shr/libphone-ui-shr_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "SHR default module for the Phone UI daemon"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libphone-ui etk evas ecore edje edje-native elementary"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://shr.bearstech.com/repo/libphone-ui-shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools autotools_stage
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_prepend() {
+ autopoint --force
+}
+
diff --git a/recipes/shr/phonefsod_git.bb b/recipes/shr/phonefsod_git.bb
new file mode 100644
index 0000000000..b96ed54b1e
--- /dev/null
+++ b/recipes/shr/phonefsod_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "SHR Phone FSO Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui sqlite3"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/phonefsod.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "phonefsod"
+INITSCRIPT_PARAMS = "defaults 75"
+
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -d ${D}${datadir}/ophonekitd/
+ install -d ${D}${localstatedir}/db
+ install -m 0755 ${S}/data/ophonekitd.init ${D}${sysconfdir}/init.d/ophonekitd
+ install -m 0644 ${S}/data/ophonekitd.conf ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${S}/data/etc-ophonekitd.conf ${D}${sysconfdir}/ophonekitd.conf
+ install -m 0644 ${S}/data/80phoneuid ${D}${sysconfdir}/X11/Xsession.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
diff --git a/recipes/shr/phoneuid_git.bb b/recipes/shr/phoneuid_git.bb
new file mode 100644
index 0000000000..2b4db83795
--- /dev/null
+++ b/recipes/shr/phoneuid_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "SHR Phone UI Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib libphone-ui sqlite3"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/phoneuid.git;protocol=http;branch=master"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/dbus-1/session.d/
+ install -d ${D}${datadir}/dbus-1/services/
+ install -m 0644 ${S}/data/phoneuid.conf ${D}${sysconfdir}/dbus-1/session.d/
+ install -m 0644 ${S}/data/phoneuid-*.service ${D}${datadir}/dbus-1/services/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+