aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/libtorrent/files/checks.patch22
-rw-r--r--recipes/libtorrent/rtorrent_0.8.6.bb9
2 files changed, 28 insertions, 3 deletions
diff --git a/recipes/libtorrent/files/checks.patch b/recipes/libtorrent/files/checks.patch
new file mode 100644
index 0000000000..cdb9835e11
--- /dev/null
+++ b/recipes/libtorrent/files/checks.patch
@@ -0,0 +1,22 @@
+Index: rtorrent-0.8.6/scripts/checks.m4
+===================================================================
+--- rtorrent-0.8.6.orig/scripts/checks.m4
++++ rtorrent-0.8.6/scripts/checks.m4
+@@ -379,16 +379,7 @@ AC_DEFUN([TORRENT_WITH_XMLRPC_C], [
+ CXXFLAGS="$CXXFLAGS `$xmlrpc_cc_prg --cflags server-util`"
+ LIBS="$LIBS `$xmlrpc_cc_prg server-util --libs`"
+
+- AC_TRY_LINK(
+- [ #include <xmlrpc-c/server.h>
+- ],[ xmlrpc_registry_new(NULL); ],
+- [
+- AC_MSG_RESULT(ok)
+- ], [
+- AC_MSG_RESULT(failed)
+- AC_MSG_ERROR(Could not compile XMLRPC-C test.)
+- ])
+-
++ AC_MSG_RESULT(ok)
+ AC_DEFINE(HAVE_XMLRPC_C, 1, Support for XMLRPC-C.)
+
+ else
diff --git a/recipes/libtorrent/rtorrent_0.8.6.bb b/recipes/libtorrent/rtorrent_0.8.6.bb
index d2a4750632..ae9af4bb31 100644
--- a/recipes/libtorrent/rtorrent_0.8.6.bb
+++ b/recipes/libtorrent/rtorrent_0.8.6.bb
@@ -2,12 +2,15 @@ DESCRIPTION = "Console bittorrent client using libtorrent"
HOMEPAGE = "http://libtorrent.rakshasa.no"
SECTION = "libs/network"
LICENSE = "GPL"
-DEPENDS = "libtorrent curl ncurses gnutls libgpg-error"
+DEPENDS = "libtorrent curl ncurses gnutls libgpg-error xmlrpc-c"
SRC_URI = "http://libtorrent.rakshasa.no/downloads/rtorrent-${PV}.tar.gz \
- file://autoconf-cross-fix.patch"
+ file://autoconf-cross-fix.patch \
+ file://checks.patch"
-PR = "r1"
+EXTRA_OECONF = " --with-xmlrpc-c"
+
+PR = "r2"
inherit autotools