aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/perl/perl_5.8.8.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 4f4c468a78..f09360facf 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -104,7 +104,8 @@ do_configure() {
}
do_compile() {
if test "${MACHINE}" != "native"; then
- sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
+ sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' \
+ -e 's|$Config{cppflags}||' ext/Errno/Errno_pm.PL
fi
cd Cross
oe_runmake perl LD="${TARGET_SYS}-gcc"