aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--packages/qi/qi.inc7
2 files changed, 6 insertions, 3 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index d24ef4dcf8..83a3e224e9 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -211,7 +211,7 @@ SRCREV_pn-tslib ?= "53"
SRCREV_pn-qemu-native ?= "${QEMUSRCREV}"
SRCREV_pn-qemu-sdk ?= "${QEMUSRCREV}"
SRCREV_pn-qemu ?= "${QEMUSRCREV}"
-SRCREV_pn-qi ?= "1fc83905fe99da92ff18e6ba671ee339477b1b9e"
+SRCREV_pn-qi ?= "4a0243f758a38cff23f379f5a195a608e6663b8f"
SRCREV_pn-remoko ?= "121"
SRCREV_pn-remoko-server ?= "121"
SRCREV_pn-s3c24xx-gpio ?= "4130"
diff --git a/packages/qi/qi.inc b/packages/qi/qi.inc
index 3de44ded0b..6d6e0dc8f2 100644
--- a/packages/qi/qi.inc
+++ b/packages/qi/qi.inc
@@ -3,7 +3,7 @@ LICENSE = "GPL"
SECTION = "bootloader"
PROVIDES = "virtual/bootloader"
LOCALVERSION = "gitr${SRCREV}"
-PV = "1.0.0+${LOCALVERSION}"
+PV = "1.0.1+${LOCALVERSION}"
EXTRA_OEMAKE = ""
PARALLEL_MAKE = ""
@@ -11,13 +11,16 @@ PARALLEL_MAKE = ""
do_configure() {
echo >config.mk
# uncomment to debug
-# sed -i s,@,, Makefile
+ sed -i s,@,, Makefile
cat >config.mk <<EOF
BUILD_HOST=\$(shell hostname)
BUILD_VERSION=${PV}
BUILD_DATE=\$(shell date)
+# NOTE: The following depends on the fact that only one version of the cross-compiler
+# has been built. If it bails out with something like: "| arm-linux-ld: 4.3.3: No such file or directory"
+# then you need to remove all previously built toolchain directories out of the cross library path.
GCCV="`${CC} -dumpversion`"
COMPILER_LIB_PATH_PRE=${CROSS_DIR}/lib/gcc/${TARGET_SYS}/$(GCCV)
COMPILER_LIB_PATH=\$(COMPILER_LIB_PATH_PRE)/\$(shell ls \$(COMPILER_LIB_PATH_PRE))