aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/freesmartphone/libmsmcomm_git.bb8
-rw-r--r--recipes/freesmartphone/msmcomm.inc11
-rw-r--r--recipes/freesmartphone/msmcommd-specs_git.bb17
-rw-r--r--recipes/freesmartphone/msmcommd_git.bb32
-rw-r--r--recipes/palmpre/palmpre-system-deps-native_git.bb12
5 files changed, 64 insertions, 16 deletions
diff --git a/recipes/freesmartphone/libmsmcomm_git.bb b/recipes/freesmartphone/libmsmcomm_git.bb
new file mode 100644
index 0000000000..b9e22a030c
--- /dev/null
+++ b/recipes/freesmartphone/libmsmcomm_git.bb
@@ -0,0 +1,8 @@
+require msmcomm.inc
+
+PR = "${INC_PR}.0"
+PV = "0.5.0+gitr${SRCPV}"
+
+S = "${WORKDIR}/git/libmsmcomm"
+
+inherit autotools
diff --git a/recipes/freesmartphone/msmcomm.inc b/recipes/freesmartphone/msmcomm.inc
new file mode 100644
index 0000000000..bf01a12fe8
--- /dev/null
+++ b/recipes/freesmartphone/msmcomm.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Low level protocol implementation for binary protocol spoken by some Qualcomm modems"
+HOMEPAGE = "http://www.freesmartphone.org"
+AUTHOR = "Simon Busch <morphis@gravedo.de>"
+SECTION = "console/network"
+LICENSE = "GPL"
+INC_PR = "r4"
+PV = "Please override!"
+
+SRC_REV = "d631d009c791085faf0ebaac4601da905bc5c0ed"
+SRC_URI = "${FREESMARTPHONE_GIT}/msmcomm.git;protocol=git;branch=master"
+
diff --git a/recipes/freesmartphone/msmcommd-specs_git.bb b/recipes/freesmartphone/msmcommd-specs_git.bb
new file mode 100644
index 0000000000..f756312b64
--- /dev/null
+++ b/recipes/freesmartphone/msmcommd-specs_git.bb
@@ -0,0 +1,17 @@
+require msmcomm.inc
+
+PR = "${INC_PR}.0"
+PV = "0.5.0+gitr${SRCPV}"
+PE = "1"
+
+DEPENDS = " \
+ vala-native \
+ glib-2.0 \
+ dbus \
+ dbus-glib \
+"
+
+S = "${WORKDIR}/git/msmcommd-specs"
+
+inherit autotools vala
+
diff --git a/recipes/freesmartphone/msmcommd_git.bb b/recipes/freesmartphone/msmcommd_git.bb
index bd74dc0f04..e8f3887c3a 100644
--- a/recipes/freesmartphone/msmcommd_git.bb
+++ b/recipes/freesmartphone/msmcommd_git.bb
@@ -1,20 +1,20 @@
-DESCRIPTION = "Low level protocol implementation for binary protocol spoken by some Qualcomm modems"
-HOMEPAGE = "http://www.freesmartphone.org"
-AUTHOR = "Simon Busch <morphis@gravedo.de>"
-SECTION = "console/network"
-LICENSE = "GPL"
-DEPENDS = "libgee libfsotransport gtk+"
-SRCREV = "91ea329fd3be68d031c61a587c6c0036b94cf2cd"
-PV = "0.1.0+gitr${SRCPV}"
-PR = "r2"
-PE = "1"
+require msmcomm.inc
-SRC_URI = "${FREESMARTPHONE_GIT}/msmcomm.git;protocol=git;branch=master"
-S = "${WORKDIR}/git"
+PR = "${INC_PR}.0"
+PV = "0.5.0+gitr${SRCPV}"
-inherit autotools vala
+DEPENDS = " \
+ vala-native \
+ glib-2.0 \
+ dbus \
+ dbus-glib \
+ libfso-glib \
+ libgee \
+ libmsmcomm \
+ msmcommd-specs \
+"
+
+S = "${WORKDIR}/git/msmcommd"
-PACKAGES =+ "${PN}-lib ${PN}-term"
-FILES_${PN}-lib = "${libdir}/lib*.so.*"
-FILES_${PN}-term = "${sbindir}/msmvterm"
+inherit autotools vala
diff --git a/recipes/palmpre/palmpre-system-deps-native_git.bb b/recipes/palmpre/palmpre-system-deps-native_git.bb
new file mode 100644
index 0000000000..1f907c9a59
--- /dev/null
+++ b/recipes/palmpre/palmpre-system-deps-native_git.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Important header and vapi files for some programs running on the palmpre machine"
+HOMEPAGE = "http://www.freesmartphone.org"
+AUTHOR = "Simon Busch <morphis@gravedo.de>
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r0"
+
+SRCREV = "93a640dafa8ebebdb1a03f051cb1b566629b227c"
+SRC_URI = "${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/palmpre/palmpre-system-deps"
+
+inherit autotools native pkgconfig