aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/ecj/libecj-bootstrap.inc4
-rw-r--r--recipes/ecj/libecj-bootstrap_3.6.1.bb2
-rw-r--r--recipes/ecj/libecj-bootstrap_3.6.bb2
3 files changed, 5 insertions, 3 deletions
diff --git a/recipes/ecj/libecj-bootstrap.inc b/recipes/ecj/libecj-bootstrap.inc
index 1adce625ec..bece3f0c24 100644
--- a/recipes/ecj/libecj-bootstrap.inc
+++ b/recipes/ecj/libecj-bootstrap.inc
@@ -6,6 +6,8 @@ LICENSE = "EPL"
DEPENDS = "fastjar-native jikes-initial virtual/java-initial"
+INC_PR = "r1"
+
inherit native java
S = "${WORKDIR}"
@@ -48,7 +50,7 @@ do_unpackpost() {
addtask unpackpost after do_unpack before do_patch
do_compile() {
- find source -name '*.java' > sourcefiles
+ find source -name '*.java' | LC_ALL=C sort > sourcefiles
split -l 25 sourcefiles ecj-sources.
# Compiling in place is done because the sources contain
diff --git a/recipes/ecj/libecj-bootstrap_3.6.1.bb b/recipes/ecj/libecj-bootstrap_3.6.1.bb
index 66e3fc14c7..d5da24ecd8 100644
--- a/recipes/ecj/libecj-bootstrap_3.6.1.bb
+++ b/recipes/ecj/libecj-bootstrap_3.6.1.bb
@@ -1,6 +1,6 @@
require libecj-bootstrap.inc
-PR = "r0"
+PR = "${INC_PR}.0"
SRC_URI = " \
http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.6.1-201009090800/ecjsrc-${PV}.zip \
diff --git a/recipes/ecj/libecj-bootstrap_3.6.bb b/recipes/ecj/libecj-bootstrap_3.6.bb
index faece53453..a4a8b70104 100644
--- a/recipes/ecj/libecj-bootstrap_3.6.bb
+++ b/recipes/ecj/libecj-bootstrap_3.6.bb
@@ -1,6 +1,6 @@
require libecj-bootstrap.inc
-PR = "r0"
+PR = "${INC_PR}.0"
SRC_URI = " \
http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.6-201006080911/ecjsrc-${PV}.zip \