aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/nslu2_flashimg.bbclass15
-rw-r--r--conf/distro/switchbox.conf17
-rw-r--r--conf/distro/unslung.conf9
-rw-r--r--packages/busybox/switchbox-1.00/defconfig358
-rw-r--r--packages/busybox/switchbox-1.00/linuxrc206
-rw-r--r--packages/busybox/switchbox-1.00/telnetd-autologin.patch0
-rw-r--r--packages/busybox/switchbox_1.00.bb50
-rw-r--r--packages/meta/openslug-image.bb4
-rw-r--r--packages/meta/switchbox-image.bb18
-rw-r--r--packages/nslu2-binary-only/nslu2-switchbox-firmware.bb21
-rw-r--r--packages/nslu2-binary-only/unslung-rootfs-2.3r25/linuxrc12
-rw-r--r--packages/nslu2-binary-only/unslung-switchbox-payload_2.3r25.bb0
-rw-r--r--packages/openslug-init/openslug-init-0.10/linuxrc (renamed from packages/busybox/switchbox-1.00/switchbox.patch)0
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb7
-rw-r--r--packages/slugimage/slugimage.bb4
15 files changed, 12 insertions, 709 deletions
diff --git a/classes/nslu2_flashimg.bbclass b/classes/nslu2_flashimg.bbclass
index ddb9b5e8cf..56ad0f0659 100644
--- a/classes/nslu2_flashimg.bbclass
+++ b/classes/nslu2_flashimg.bbclass
@@ -5,25 +5,14 @@ nslu2_pack_image () {
install -m 0644 ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
${STAGING_LIBDIR}/nslu2-binaries/Trailer \
${STAGING_LIBDIR}/nslu2-binaries/SysConf \
- ${STAGING_LIBDIR}/nslu2-binaries/switchbox.ext2.gz \
${DEPLOY_DIR_IMAGE}/slug/
install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-${IMAGE_BASENAME} ${DEPLOY_DIR_IMAGE}/slug/vmlinuz
- if [ -f ${DEPLOY_DIR_IMAGE}/payload.tar.gz ] ; then
- install -m 0644 ${DEPLOY_DIR_IMAGE}/payload.tar.gz ${DEPLOY_DIR_IMAGE}/slug/payload.tar.gz
- fi
- if [ "${NSLU2_BUILD_RAMDISK_FIRMWARE}" == "1" ] ; then
- install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext2.gz ${DEPLOY_DIR_IMAGE}/slug/ramdisk.ext2.gz
- fi
install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${DEPLOY_DIR_IMAGE}/slug/flashdisk.jffs2
cd ${DEPLOY_DIR_IMAGE}/slug
- if [ "${NSLU2_BUILD_RAMDISK_FIRMWARE}" == "1" ] ; then
- slugimage -p -b RedBoot -s SysConf -r Ramdisk:ramdisk.ext2.gz -t Trailer \
- -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.ramdisk.img ${NSLU2_SLUGIMAGE_ARGS}
- fi
- slugimage -p -b RedBoot -s SysConf -r Ramdisk:switchbox.ext2.gz,Flashdisk:flashdisk.jffs2 -t Trailer \
+ slugimage -p -b RedBoot -s SysConf -r Ramdisk:1,Flashdisk:flashdisk.jffs2 -t Trailer \
-o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.flashdisk.img ${NSLU2_SLUGIMAGE_ARGS}
rm -rf ${DEPLOY_DIR_IMAGE}/slug
}
-EXTRA_IMAGEDEPENDS += 'slugimage-native nslu2-linksys-firmware nslu2-switchbox-firmware'
+EXTRA_IMAGEDEPENDS += 'slugimage-native nslu2-linksys-firmware'
IMAGE_POSTPROCESS_COMMAND += "nslu2_pack_image; "
diff --git a/conf/distro/switchbox.conf b/conf/distro/switchbox.conf
deleted file mode 100644
index 6cde69946b..0000000000
--- a/conf/distro/switchbox.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-#@TYPE: Distribution
-#@NAME: SwitchBox
-#@DESCRIPTION: SwitchBox Linux Distribution for the NSLU2
-
-TARGET_FPU = "soft"
-TARGET_OS = "linux-uclibc"
-
-INHERIT += " package_ipk debian"
-
-IMAGE_FSTYPE = "ext2.gz"
-IMAGE_ROOTFS_SIZE_ext2 = "1024"
-IMAGE_ROOTFS_SIZE_ext2.gz = "1024"
-
-SWITCHBOX_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-unslung.txt')}"
-EXTRA_IMAGECMD_ext2.gz = "-r 0 -i 512 -D ${SWITCHBOX_DEVICE_TABLE}"
-
-USE_NLS = "no"
diff --git a/conf/distro/unslung.conf b/conf/distro/unslung.conf
index 31e781bb0f..f947f97589 100644
--- a/conf/distro/unslung.conf
+++ b/conf/distro/unslung.conf
@@ -7,7 +7,7 @@ FEED_URIS += "native##http://ipkg.nslu2-linux.org/feeds/unslung/native"
FEED_URIS += "oe##http://ipkg.nslu2-linux.org/feeds/unslung/oe"
DISTRO_NAME = "Unslung"
-DISTRO_VERSION = "4.13-alpha"
+DISTRO_VERSION = "4.18-alpha"
DISTRO_TYPE = "beta"
TARGET_FPU = "soft"
@@ -19,13 +19,6 @@ IMAGE_FSTYPE = "jffs2"
UNSLUNG_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-unslung.txt')}"
EXTRA_IMAGECMD_jffs2 = "--pad --big-endian --eraseblock=0x20000 -D ${UNSLUNG_DEVICE_TABLE}"
-# NSLU2_BUILD_RAMDISK_FIRMWARE = 1
-# IMAGE_FSTYPES = "ext2.gz jffs2"
-# EXTRA_IMAGECMD_ext2.gz = "-f ${UNSLUNG_DEVICE_TABLE}"
-
-EXTRA_IMAGEDEPENDS += 'unslung-switchbox-payload'
-NSLU2_SLUGIMAGE_ARGS = -l payload.tar.gz
-
UNSLUNG_EXTRA_DEPENDS ?= ""
UNSLUNG_EXTRA_RDEPENDS ?= "\
kernel-module-usbnet \
diff --git a/packages/busybox/switchbox-1.00/defconfig b/packages/busybox/switchbox-1.00/defconfig
deleted file mode 100644
index ad94247847..0000000000
--- a/packages/busybox/switchbox-1.00/defconfig
+++ /dev/null
@@ -1,358 +0,0 @@
-#
-# Automatically generated make config: don't edit
-#
-HAVE_DOT_CONFIG=y
-
-#
-# General Configuration
-#
-# CONFIG_FEATURE_BUFFERS_USE_MALLOC is not set
-CONFIG_FEATURE_BUFFERS_GO_ON_STACK=y
-# CONFIG_FEATURE_BUFFERS_GO_IN_BSS is not set
-# CONFIG_FEATURE_VERBOSE_USAGE is not set
-# CONFIG_FEATURE_INSTALLER is not set
-# CONFIG_LOCALE_SUPPORT is not set
-# CONFIG_FEATURE_DEVFS is not set
-# CONFIG_FEATURE_DEVPTS is not set
-# CONFIG_FEATURE_CLEAN_UP is not set
-# CONFIG_FEATURE_SUID is not set
-# CONFIG_FEATURE_SUID_CONFIG is not set
-# CONFIG_SELINUX is not set
-
-#
-# Build Options
-#
-CONFIG_STATIC=y
-CONFIG_LFS=y
-USING_CROSS_COMPILER=y
-CROSS_COMPILER_PREFIX="armv5b-softfloat-linux-"
-EXTRA_CFLAGS_OPTIONS=""
-
-#
-# Installation Options
-#
-# CONFIG_INSTALL_NO_USR is not set
-PREFIX="/"
-
-#
-# Archival Utilities
-#
-# CONFIG_AR is not set
-# CONFIG_BUNZIP2 is not set
-# CONFIG_CPIO is not set
-# CONFIG_DPKG is not set
-# CONFIG_DPKG_DEB is not set
-# CONFIG_GUNZIP is not set
-# CONFIG_GZIP is not set
-# CONFIG_RPM2CPIO is not set
-# CONFIG_RPM is not set
-CONFIG_TAR=y
-CONFIG_FEATURE_TAR_GZIP=y
-# CONFIG_UNCOMPRESS is not set
-# CONFIG_UNZIP is not set
-
-#
-# Coreutils
-#
-# CONFIG_BASENAME is not set
-# CONFIG_CAL is not set
-CONFIG_CAT=y
-# CONFIG_CHGRP is not set
-# CONFIG_CHMOD is not set
-# CONFIG_CHOWN is not set
-CONFIG_CHROOT=y
-# CONFIG_CMP is not set
-CONFIG_CP=y
-CONFIG_CUT=y
-# CONFIG_DATE is not set
-CONFIG_DD=y
-CONFIG_DF=y
-# CONFIG_DIRNAME is not set
-# CONFIG_DOS2UNIX is not set
-# CONFIG_DU is not set
-CONFIG_ECHO=y
-# CONFIG_ENV is not set
-# CONFIG_EXPR is not set
-# CONFIG_FALSE is not set
-# CONFIG_FOLD is not set
-# CONFIG_HEAD is not set
-# CONFIG_HOSTID is not set
-# CONFIG_ID is not set
-# CONFIG_INSTALL is not set
-# CONFIG_LENGTH is not set
-CONFIG_LN=y
-# CONFIG_LOGNAME is not set
-CONFIG_LS=y
-CONFIG_FEATURE_LS_FILETYPES=y
-CONFIG_FEATURE_LS_FOLLOWLINKS=y
-CONFIG_FEATURE_LS_RECURSIVE=y
-CONFIG_FEATURE_LS_SORTFILES=y
-CONFIG_FEATURE_LS_TIMESTAMPS=y
-CONFIG_FEATURE_LS_USERNAME=y
-CONFIG_FEATURE_LS_COLOR=y
-CONFIG_FEATURE_AUTOWIDTH=y
-CONFIG_MD5SUM=y
-CONFIG_MKDIR=y
-# CONFIG_MKFIFO is not set
-# CONFIG_MKNOD is not set
-CONFIG_MV=y
-# CONFIG_OD is not set
-# CONFIG_PRINTF is not set
-CONFIG_PWD=y
-# CONFIG_REALPATH is not set
-CONFIG_RM=y
-CONFIG_RMDIR=y
-# CONFIG_SEQ is not set
-# CONFIG_SHA1SUM is not set
-CONFIG_SLEEP=y
-# CONFIG_SORT is not set
-# CONFIG_STTY is not set
-CONFIG_SYNC=y
-# CONFIG_TAIL is not set
-# CONFIG_TEE is not set
-CONFIG_TEST=y
-
-#
-# test (forced enabled for use with shell)
-#
-# CONFIG_FEATURE_TEST_64 is not set
-# CONFIG_TOUCH is not set
-# CONFIG_TR is not set
-# CONFIG_TRUE is not set
-# CONFIG_TTY is not set
-# CONFIG_UNAME is not set
-# CONFIG_UNIQ is not set
-# CONFIG_USLEEP is not set
-# CONFIG_UUDECODE is not set
-# CONFIG_UUENCODE is not set
-# CONFIG_WATCH is not set
-# CONFIG_WC is not set
-# CONFIG_WHO is not set
-# CONFIG_WHOAMI is not set
-# CONFIG_YES is not set
-
-#
-# Console Utilities
-#
-# CONFIG_CHVT is not set
-# CONFIG_CLEAR is not set
-# CONFIG_DEALLOCVT is not set
-# CONFIG_DUMPKMAP is not set
-# CONFIG_LOADFONT is not set
-# CONFIG_LOADKMAP is not set
-# CONFIG_OPENVT is not set
-# CONFIG_RESET is not set
-# CONFIG_SETKEYCODES is not set
-
-#
-# Debian Utilities
-#
-# CONFIG_MKTEMP is not set
-# CONFIG_PIPE_PROGRESS is not set
-# CONFIG_READLINK is not set
-# CONFIG_RUN_PARTS is not set
-# CONFIG_START_STOP_DAEMON is not set
-# CONFIG_WHICH is not set
-
-#
-# Editors
-#
-# CONFIG_AWK is not set
-# CONFIG_PATCH is not set
-CONFIG_SED=y
-CONFIG_VI=y
-CONFIG_FEATURE_VI_COLON=y
-CONFIG_FEATURE_VI_YANKMARK=y
-
-#
-# Finding Utilities
-#
-# CONFIG_FIND is not set
-CONFIG_GREP=y
-# CONFIG_XARGS is not set
-
-#
-# Init Utilities
-#
-# CONFIG_INIT is not set
-# CONFIG_FEATURE_USE_INITTAB is not set
-# CONFIG_FEATURE_INITRD is not set
-# CONFIG_FEATURE_INIT_COREDUMPS is not set
-# CONFIG_FEATURE_EXTRA_QUIET is not set
-# CONFIG_HALT is not set
-# CONFIG_POWEROFF is not set
-CONFIG_REBOOT=y
-# CONFIG_MESG is not set
-
-#
-# Login/Password Management Utilities
-#
-# CONFIG_USE_BB_PWD_GRP is not set
-# CONFIG_ADDGROUP is not set
-# CONFIG_DELGROUP is not set
-# CONFIG_ADDUSER is not set
-# CONFIG_DELUSER is not set
-# CONFIG_GETTY is not set
-# CONFIG_LOGIN is not set
-# CONFIG_PASSWD is not set
-# CONFIG_SU is not set
-# CONFIG_SULOGIN is not set
-# CONFIG_VLOCK is not set
-
-#
-# Miscellaneous Utilities
-#
-# CONFIG_ADJTIMEX is not set
-# CONFIG_CROND is not set
-# CONFIG_CRONTAB is not set
-# CONFIG_DC is not set
-# CONFIG_DEVFSD is not set
-# CONFIG_LAST is not set
-# CONFIG_HDPARM is not set
-# CONFIG_MAKEDEVS is not set
-# CONFIG_MT is not set
-CONFIG_RX=y
-# CONFIG_STRINGS is not set
-# CONFIG_TIME is not set
-# CONFIG_WATCHDOG is not set
-
-#
-# Linux Module Utilities
-#
-CONFIG_INSMOD=y
-CONFIG_FEATURE_2_4_MODULES=y
-CONFIG_FEATURE_2_6_MODULES=y
-# CONFIG_LSMOD is not set
-# CONFIG_MODPROBE is not set
-CONFIG_RMMOD=y
-
-#
-# Networking Utilities
-#
-# CONFIG_FEATURE_IPV6 is not set
-# CONFIG_ARPING is not set
-# CONFIG_FTPGET is not set
-# CONFIG_FTPPUT is not set
-# CONFIG_HOSTNAME is not set
-# CONFIG_HTTPD is not set
-CONFIG_IFCONFIG=y
-CONFIG_FEATURE_IFCONFIG_STATUS=y
-CONFIG_FEATURE_IFCONFIG_HW=y
-# CONFIG_IFUPDOWN is not set
-# CONFIG_INETD is not set
-# CONFIG_IP is not set
-# CONFIG_IPCALC is not set
-# CONFIG_IPADDR is not set
-# CONFIG_IPLINK is not set
-# CONFIG_IPROUTE is not set
-# CONFIG_IPTUNNEL is not set
-# CONFIG_NAMEIF is not set
-# CONFIG_NC is not set
-# CONFIG_NETSTAT is not set
-# CONFIG_NSLOOKUP is not set
-CONFIG_PING=y
-CONFIG_ROUTE=y
-# CONFIG_TELNET is not set
-CONFIG_TELNETD=y
-CONFIG_TFTP=y
-CONFIG_FEATURE_TFTP_GET=y
-# CONFIG_TRACEROUTE is not set
-# CONFIG_VCONFIG is not set
-CONFIG_WGET=y
-CONFIG_FEATURE_WGET_STATUSBAR=y
-
-#
-# udhcp Server/Client
-#
-# CONFIG_UDHCPD is not set
-# CONFIG_UDHCPC is not set
-
-#
-# Process Utilities
-#
-CONFIG_FREE=y
-CONFIG_KILL=y
-CONFIG_KILLALL=y
-# CONFIG_PIDOF is not set
-CONFIG_PS=y
-# CONFIG_RENICE is not set
-# CONFIG_TOP is not set
-# CONFIG_UPTIME is not set
-# CONFIG_SYSCTL is not set
-
-#
-# Another Bourne-like Shell
-#
-CONFIG_FEATURE_SH_IS_ASH=y
-# CONFIG_FEATURE_SH_IS_HUSH is not set
-# CONFIG_FEATURE_SH_IS_LASH is not set
-# CONFIG_FEATURE_SH_IS_MSH is not set
-# CONFIG_FEATURE_SH_IS_NONE is not set
-CONFIG_ASH=y
-
-#
-# Ash Shell Options
-#
-# CONFIG_ASH_JOB_CONTROL is not set
-# CONFIG_ASH_ALIAS is not set
-# CONFIG_ASH_MATH_SUPPORT is not set
-# CONFIG_ASH_GETOPTS is not set
-# CONFIG_ASH_CMDCMD is not set
-# CONFIG_ASH_MAIL is not set
-CONFIG_ASH_OPTIMIZE_FOR_SIZE=y
-# CONFIG_ASH_RANDOM_SUPPORT is not set
-# CONFIG_HUSH is not set
-# CONFIG_LASH is not set
-# CONFIG_MSH is not set
-
-#
-# Bourne Shell Options
-#
-# CONFIG_FEATURE_SH_EXTRA_QUIET is not set
-# CONFIG_FEATURE_SH_STANDALONE_SHELL is not set
-CONFIG_FEATURE_COMMAND_EDITING=y
-CONFIG_FEATURE_COMMAND_HISTORY=63
-CONFIG_FEATURE_COMMAND_TAB_COMPLETION=y
-
-#
-# System Logging Utilities
-#
-# CONFIG_SYSLOGD is not set
-# CONFIG_LOGGER is not set
-
-#
-# Linux System Utilities
-#
-# CONFIG_DMESG is not set
-# CONFIG_FBSET is not set
-# CONFIG_FDFLUSH is not set
-# CONFIG_FDFORMAT is not set
-# CONFIG_FDISK is not set
-# FDISK_SUPPORT_LARGE_DISKS is not set
-CONFIG_FREERAMDISK=y
-# CONFIG_FSCK_MINIX is not set
-# CONFIG_MKFS_MINIX is not set
-# CONFIG_GETOPT is not set
-CONFIG_HEXDUMP=y
-# CONFIG_HWCLOCK is not set
-# CONFIG_LOSETUP is not set
-# CONFIG_MKSWAP is not set
-# CONFIG_MORE is not set
-CONFIG_PIVOT_ROOT=y
-# CONFIG_RDATE is not set
-# CONFIG_SWAPONOFF is not set
-CONFIG_MOUNT=y
-CONFIG_NFSMOUNT=y
-CONFIG_UMOUNT=y
-# CONFIG_FEATURE_MOUNT_FORCE is not set
-
-#
-# Common options for mount/umount
-#
-# CONFIG_FEATURE_MOUNT_LOOP is not set
-# CONFIG_FEATURE_MTAB_SUPPORT is not set
-
-#
-# Debugging Options
-#
-# CONFIG_DEBUG is not set
diff --git a/packages/busybox/switchbox-1.00/linuxrc b/packages/busybox/switchbox-1.00/linuxrc
deleted file mode 100644
index 355a05b568..0000000000
--- a/packages/busybox/switchbox-1.00/linuxrc
+++ /dev/null
@@ -1,206 +0,0 @@
-#!/bin/sh
-
-mounted=
-prefroot=
-runboot=
-
-/bin/mount -t proc proc /proc
-
-sysconflen=`/bin/dd if=/dev/mtd1 bs=4 count=1 2>/dev/null | /usr/bin/hexdump -n 6 -e '"%02d"'`
-ipaddr=`/bin/dd if=/dev/mtd1 bs=1 count=$sysconflen skip=4 2>/dev/null | grep ip_addr | sed -e s/ip_addr=//`
-netmask=`/bin/dd if=/dev/mtd1 bs=1 count=$sysconflen skip=4 2>/dev/null | grep netmask | sed -e s/netmask=//`
-gateway=`/bin/dd if=/dev/mtd1 bs=1 count=$sysconflen skip=4 2>/dev/null | grep gateway | sed -e s/gateway=//`
-device=/dev/`/bin/sed -n -e 's/^\(mtd[0-9]*\): .* "FIS directory"/\1/p' /proc/mtd`
-length=`/bin/dd if=$device bs=2 skip=2048 2>/dev/null | /usr/bin/hexdump -n 4 -e '4/1 "%02X"' $device`
-
-# Determine desired rootfs
-if [ -z "$mounted" ] && /bin/mount -rt jffs2 /dev/mtdblock4 /mnt/jffs2 ; then
- if [ -f /mnt/jffs2/.recovery ] ; then
- /bin/echo "Preferred root device is /dev/ram0 (recovery)"
- mounted=
- prefroot=
- elif [ -f /mnt/jffs2/.ramdisk ] ; then
- /bin/echo "Preferred root device is /dev/ram1 (maintenence)"
- mounted=/mnt/newroot
- prefroot=maintenence
- elif [ -f /mnt/jffs2/.sda1root ] ; then
- /bin/echo "Preferred root device is /dev/sda1 (disk 1)"
- mounted=/mnt/newroot
- prefroot=sda1
- elif [ -f /mnt/jffs2/.sda2root ] ; then
- /bin/echo "Preferred root device is /dev/sda2 (disk 1)"
- mounted=/mnt/newroot
- prefroot=sda2
- elif [ -f /mnt/jffs2/.sdb1root ] ; then
- /bin/echo "Preferred root device is /dev/sdb1 (disk 2)"
- mounted=/mnt/newroot
- prefroot=sdb1
- elif [ -f /mnt/jffs2/.sdb2root ] ; then
- /bin/echo "Preferred root device is /dev/sdb2 (disk 2)"
- mounted=/mnt/newroot
- prefroot=sdb2
- elif [ -f /mnt/jffs2/.altroot ] ; then
- /bin/echo "Preferred root device is a user defined blockdevice"
- mounted=/mnt/newroot
- prefroot=altroot
- elif [ -f /mnt/jffs2/.nfsroot ] ; then
- /bin/echo "Preferred root device is through NFS"
- mounted=/mnt/newroot
- prefroot=nfsroot
- else
- /bin/echo "Preferred root device is jffs2"
- mounted=/mnt/jffs2
- prefroot=jffs2
- fi
-fi
-
-# perform prepatory tasks
-if [ -n "$prefroot" ] ; then
-
- if [ $prefroot = "sda1" -o $prefroot = "sda2" -o $prefroot = "sdb1" -o $prefroot = "sdb2" ] ; then
- /bin/echo "Sleeping 10sec while waiting for disk..."
- sleep 10
- /bin/mount -rt ext3 /dev/$prefroot /mnt/newroot
- if [ -L /mnt/newroot/sbin/init -o -x /mnt/newroot/sbin/init -o \
- -L /mnt/newroot/bin/init -o -x /mnt/newroot/bin/init ] ; then
- /bin/echo "Root filesystem will be mounted from /dev/$prefroot ..."
- else
- /bin/umount /mnt/newroot
- /bin/echo "Cant find valid rootfs on /dev/$prefroot, using jffs2 ..."
- mounted=/mnt/jffs2
- prefroot=jffs2
- fi
-
- fi
-
- if [ $prefroot = "maintenence" ] ; then
- /bin/dd if=/dev/zero of=/dev/ram1 bs=1k count=12k 2>/dev/null
- /bin/mkdir /lib
- /bin/ln -s /mnt/jffs2/lib/* /lib
- /bin/mkdir -p /usr/bin
- /bin/ln -s /mnt/jffs2/usr/bin/mke2fs /usr/bin
- /bin/ln -s /mnt/jffs2/usr/bin/find /usr/bin
- /bin/ln -s /mnt/jffs2/usr/bin/cpio /usr/bin
- /usr/bin/mke2fs -m 0 /dev/ram1 12288
- /bin/mount -t ext2 /dev/ram1 /mnt/newroot
- ( cd /mnt/jffs2 ; /usr/bin/find . -print0 -mount | /usr/bin/cpio -p -0 -d -m -u /mnt/newroot )
- if [ -r /mnt/newroot/.unslung ] ; then
- /bin/cp /mnt/newroot/home/httpd/html/Management/upgrade.cgi /mnt/newroot/home/httpd/html/Management/upgrade-real.cgi
- /bin/echo "#!/bin/sh" > /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo >> /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/mount -t ramfs none /upload -o size=8196 2>/dev/null" \
- >> /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/dd if=/dev/zero of=/upload/free-ram bs=1k count=8k 2>/dev/null" \
- >> /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/umount /upload 2>/dev/null" \
- >> /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo "exec /home/httpd/html/Management/upgrade-real.cgi" \
- >> /mnt/newroot/home/httpd/html/Management/upgrade.cgi
- /bin/echo "Root filesystem will be mounted from /dev/ram1 (a copy of /dev/mtdblock4) ..."
- elif [ -r /mnt/newroot/.openslug ] ; then
- /bin/echo "Root filesystem will be mounted from /dev/ram1 (a copy of /dev/mtdblock4) ..."
- else
- /bin/umount /mnt/newroot
- /bin/echo "Cant find valid rootfs on /dev/ram1, using recovery ..."
- mounted=
- prefroot=
- fi
-
- fi
-
- if [ $prefroot = "altroot" ] ; then
- # The altrootloc and altrootopts vars MUST be chosen here.
- # ie: $altrootopts="-rt ext3" and $altrootloc=/dev/md0
- # Also modules can be loaded here.
- # also if you have a really slow starting disk, you can put a large sleep value here.
- . /mnt/jffs2/.altroot
-
- /bin/mount $altrootopts $altrootloc /mnt/newroot
- if [ -L /mnt/newroot/sbin/init -o -x /mnt/newroot/sbin/init -o \
- -L /mnt/newroot/bin/init -o -x /mnt/newroot/bin/init ] ; then
- /bin/echo "Root filesystem will be mounted from a user defined rootfs (altroot) ..."
- else
- /bin/umount /mnt/newroot
- /bin/echo "Cant find valid rootfs on user defined rootfs (altroot), using jffs2 ..."
- mounted=/mnt/jffs2
- prefroot=jffs2
- fi
- fi
-
- if [ $prefroot = "nfsroot" ] ; then
-
- /sbin/insmod ixp400
- /sbin/insmod ixp425_eth
- /sbin/ifconfig ixp0 up $ipaddr netmask $netmask
- /sbin/route add default gw $gateway
-
- /sbin/ifconfig lo up 127.0.0.1
-
- # The nfsrootloc and nfsrootopts vars can be overridden here.
- . /mnt/jffs2/.nfsroot
-
- /bin/mount $nfsrootopts $nfsrootloc /mnt/newroot
-
- if [ -L /mnt/newroot/sbin/init -o -x /mnt/newroot/sbin/init -o \
- -L /mnt/newroot/bin/init -o -x /mnt/newroot/bin/init ] ; then
- /bin/echo "Root filesystem will be mounted from an NFS root ..."
- mounted=/mnt/newroot
- else
- /bin/umount /mnt/newroot
- /bin/echo "Cant find valid NFS rootfs, using jffs2 ..."
- mounted=/mnt/jffs2
- prefroot=jffs2
- fi
-
- fi
-
- if [ $prefroot = "jffs2" ] ; then
- if [ -L /mnt/jffs2/sbin/init -o -x /mnt/jffs2/sbin/init -o \
- -L /mnt/jffs2/bin/init -o -x /mnt/jffs2/bin/init ] ; then
- /bin/echo "Root filesystem will be mounted from /dev/mtdblock4 ..."
- mounted=/mnt/jffs2
- else
- /bin/echo "Cant find valid rootfs on jffs2, using recovery ..."
- mounted=
- fi
- fi
-fi
-
-# Pivot
-if [ -n "$mounted" ] ; then
- if [ $mounted != "/mnt/jffs2" ] ; then
- sleep 1
- /bin/umount /mnt/jffs2
- fi
- /bin/umount /proc
- cd $mounted
- if [ -x ./linuxrc -o -L ./linuxrc ] ; then
- runboot=/linuxrc
- elif [ -x ./sbin/init -o -L ./sbin/init ] ; then
- runboot=/sbin/init
- elif [ -x ./bin/init -o -L ./bin/init ] ; then
- runboot=/bin/init
- else
- runboot=/bin/sh
- fi
- /sbin/pivot_root . initrd
- exec /usr/sbin/chroot . $runboot < /dev/console 1> /dev/console 2> /dev/console
-fi
-
-if [ -z "$mounted" ] ; then
- /bin/echo "Root filesystem cannot be found - dropping into shell ..."
-
- if ( [ -x /sbin/telnetd -a "$length" != "FFFFFFFF" ] ); then
- /bin/dd if=$device bs=2 skip=2056 2>/dev/null | /bin/tar zxvf -
- /sbin/insmod ixp400
- /sbin/insmod ixp425_eth
- /sbin/ifconfig ixp0 up $ipaddr netmask $netmask
- /sbin/telnetd
- fi
-
- exec /bin/sh
-fi
-
-/bin/umount /proc
-
-exit 0
diff --git a/packages/busybox/switchbox-1.00/telnetd-autologin.patch b/packages/busybox/switchbox-1.00/telnetd-autologin.patch
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/busybox/switchbox-1.00/telnetd-autologin.patch
+++ /dev/null
diff --git a/packages/busybox/switchbox_1.00.bb b/packages/busybox/switchbox_1.00.bb
deleted file mode 100644
index d1ad177ffa..0000000000
--- a/packages/busybox/switchbox_1.00.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-DESCRIPTION = "SwitchBox is a minimal version of BusyBox with just enough functionality \
-to switch between different root filesystem options on an Unslung NSLU2 device."
-HOMEPAGE = "http://www.busybox.net"
-LICENSE = "GPL"
-SECTION = "base"
-PRIORITY = "required"
-PR = "r11"
-
-SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
- file://defconfig \
- file://linuxrc \
- file://switchbox.patch;patch=1 \
- file://telnetd-autologin.patch;patch=1"
-
-S = "${WORKDIR}/busybox-${PV}"
-
-python () {
- # Don't build switchbox unless we're targeting an nslu2
- if bb.data.getVar("MACHINE", d, 1) != "nslu2":
- raise bb.parse.SkipPackage("switchbox only builds for the Linksys NSLU2")
-}
-
-LDFLAGS =+ "-static"
-
-export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/"
-FILES_${PN}-doc = ""
-FILES_${PN}-dev = ""
-FILES_${PN}-locale = ""
-
-inherit cml1
-
-do_configure () {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- cml1_do_configure
-}
-
-do_compile () {
- unset CFLAGS
- base_do_compile
-}
-
-do_install () {
- oe_runmake 'PREFIX=${D}' install
- install -m 0755 ${WORKDIR}/linuxrc ${D}/
- mkdir -p ${D}/proc ${D}/mnt/jffs2 ${D}/mnt/repair ${D}/mnt/newroot
-}
diff --git a/packages/meta/openslug-image.bb b/packages/meta/openslug-image.bb
index e3dd483341..5dc3fc4327 100644
--- a/packages/meta/openslug-image.bb
+++ b/packages/meta/openslug-image.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
IMAGE_BASENAME = "openslug"
@@ -6,7 +6,7 @@ IMAGE_LINGUAS = ""
USE_DEVFS = "1"
OPENSLUG_HIDDEN_PACKAGES = "ipkg-native ipkg-utils-native fakeroot-native ${PATCH_DEPENDS} virtual/armeb-linux-uclibc-gcc \
- virtual/libc makedevs-native mtd-utils-native slugimage-native nslu2-linksys-firmware nslu2-switchbox-firmware "
+ virtual/libc makedevs-native mtd-utils-native slugimage-native nslu2-linksys-firmware "
DEPENDS = "virtual/kernel base-files base-passwd \
busybox dropbear hotplug-ng initscripts netbase \
diff --git a/packages/meta/switchbox-image.bb b/packages/meta/switchbox-image.bb
deleted file mode 100644
index 60e403e1c2..0000000000
--- a/packages/meta/switchbox-image.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-PR = "r2"
-
-IMAGE_LINGUAS = ""
-USE_DEVFS = "1"
-
-SWITCHBOX_BASE_DEPENDS = "switchbox"
-SWITCHBOX_BASE_PACKAGES = "switchbox"
-
-IMAGE_VARIANT = "switchbox"
-
-IMAGE_BASENAME = "${IMAGE_VARIANT}"
-
-IPKG_INSTALL = "${SWITCHBOX_BASE_PACKAGES}"
-
-DEPENDS = "${SWITCHBOX_BASE_DEPENDS}"
-
-inherit image_ipk
-LICENSE = MIT
diff --git a/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb b/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
deleted file mode 100644
index 6c3739a718..0000000000
--- a/packages/nslu2-binary-only/nslu2-switchbox-firmware.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SECTION = "base"
-DEPENDS = ""
-PACKAGES = ""
-LICENSE = "BSD"
-INHIBIT_DEFAULT_DEPS = "1"
-PR = "r19"
-
-SRC_URI = "http://nslu.sf.net/downloads/switchbox-4.11.tar.gz"
-S = "${WORKDIR}"
-
-python () {
- # Don't build switchbox firmware unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'nslu2':
- raise bb.parse.SkipPackage("Switchbox is only relevant for the Linksys NSLU2")
-}
-
-do_compile () {
- install -d ${STAGING_LIBDIR}/nslu2-binaries
- install -m 0755 switchbox.ext2.gz ${STAGING_LIBDIR}/nslu2-binaries/switchbox.ext2.gz
-}
diff --git a/packages/nslu2-binary-only/unslung-rootfs-2.3r25/linuxrc b/packages/nslu2-binary-only/unslung-rootfs-2.3r25/linuxrc
index 486e679249..3ae0b25412 100644
--- a/packages/nslu2-binary-only/unslung-rootfs-2.3r25/linuxrc
+++ b/packages/nslu2-binary-only/unslung-rootfs-2.3r25/linuxrc
@@ -62,18 +62,6 @@ if [ $prefroot = "maintenence" ] ; then
/bin/mount -t ext2 /dev/ram0 /mnt/tmpmnt
( /usr/bin/find . -print0 -mount | /usr/bin/cpio -p -0 -d -m -u /mnt/tmpmnt )
/bin/rm -f /mnt/tmpmnt/linuxrc
- /bin/cp /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi /mnt/tmpmnt/home/httpd/html/Management/upgrade-real.cgi
- /bin/echo "#!/bin/sh" > /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo >> /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/mount -t ramfs none /upload -o size=8196 2>/dev/null" \
- >> /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/dd if=/dev/zero of=/upload/free-ram bs=1k count=8k 2>/dev/null" \
- >> /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo "/bin/umount /upload 2>/dev/null" \
- >> /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo "exec /home/httpd/html/Management/upgrade-real.cgi" \
- >> /mnt/tmpmnt/home/httpd/html/Management/upgrade.cgi
- /bin/echo "Root filesystem will be mounted from /dev/ram0 (a copy of /dev/mtdblock4) ..."
fi
if [ $prefroot = "nfsroot" ] ; then
diff --git a/packages/nslu2-binary-only/unslung-switchbox-payload_2.3r25.bb b/packages/nslu2-binary-only/unslung-switchbox-payload_2.3r25.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/nslu2-binary-only/unslung-switchbox-payload_2.3r25.bb
+++ /dev/null
diff --git a/packages/busybox/switchbox-1.00/switchbox.patch b/packages/openslug-init/openslug-init-0.10/linuxrc
index e69de29bb2..e69de29bb2 100644
--- a/packages/busybox/switchbox-1.00/switchbox.patch
+++ b/packages/openslug-init/openslug-init-0.10/linuxrc
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index 3b749f0a9b..fe1f9d7135 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -2,9 +2,10 @@ DESCRIPTION = "Openslug initial network config via sysconf"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files"
-PR = "r18"
+PR = "r19"
-SRC_URI = "file://sysconfsetup \
+SRC_URI = "file://linuxrc \
+ file://sysconfsetup \
file://turnup \
file://modutils.txt \
file://modprobe.conf \
@@ -30,6 +31,8 @@ do_install() {
${D}/${sysconfdir}/rcS.d \
${D}/${sbindir}
+ install -m 0755 ${D}/../linuxrc ${D}/linuxrc
+
install -d ${D}/initrd
install -m 0755 ${D}/../kern_header ${D}${sbindir}/kern_header
diff --git a/packages/slugimage/slugimage.bb b/packages/slugimage/slugimage.bb
index 64860d1377..9b4e651369 100644
--- a/packages/slugimage/slugimage.bb
+++ b/packages/slugimage/slugimage.bb
@@ -3,11 +3,11 @@ LICENSE = "BSD"
DESCRIPTION = "Slugimage is a small app to disassemble and reassemble \
flash images for the Linksys NSLU2 device. It also has jffs2 support"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-PR = "r2"
+PR = "r3"
RDEPENDS = "perl-native"
-SRC_URI = "cvs://anonymous:@cvs.sourceforge.net/cvsroot/nslu;module=slugimage;tag=SLUGIMAGE_3_1"
+SRC_URI = "cvs://anonymous:@cvs.sourceforge.net/cvsroot/nslu;module=slugimage;tag=SLUGIMAGE_3_2"
S = "${WORKDIR}"