aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libsdl/libsdl-image.inc3
-rw-r--r--recipes/libsdl/libsdl-image_1.2.10.bb16
-rw-r--r--recipes/libsdl/libsdl-image_1.2.3.bb2
-rw-r--r--recipes/libsdl/libsdl-image_1.2.6.bb3
5 files changed, 25 insertions, 3 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index db4beee5e8..4945d6d630 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1138,6 +1138,10 @@ sha256=6a3ef9f5556a3d75832b2b9138bdf3551dc59994d2849307f88a9dcd9732d16c
md5=a7ab98ad530fdc59a23f7dff502db8d3
sha256=d08d8477ff1c6639bc7193b76a415f996c98604600e9fa4e718fd4e9283f83f4
+[http://www.libsdl.org/projects/SDL_image/release/SDL_image-1.2.10.tar.gz]
+md5=6c06584b31559e2b59f2b982d0d1f628
+sha256=75e05d1e95f6277b44797157d9e25a908ba8d08a393216ffb019b0d74de11876
+
[http://www.libsdl.org/projects/SDL_image/release/SDL_image-1.2.3.tar.gz]
md5=d55826ffbd2bdc48b09cc64a9ed9e59e
sha256=2f710b94f547ec7e39844f7872e1fe8d6fe2a434c896cc8a54b5540854bb5a69
diff --git a/recipes/libsdl/libsdl-image.inc b/recipes/libsdl/libsdl-image.inc
index b52db71511..014dca4382 100644
--- a/recipes/libsdl/libsdl-image.inc
+++ b/recipes/libsdl/libsdl-image.inc
@@ -4,6 +4,8 @@ PRIORITY = "optional"
DEPENDS = "zlib libpng jpeg virtual/libsdl"
LICENSE = "LGPL"
+INC_PR = "r4"
+
SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
S = "${WORKDIR}/SDL_image-${PV}"
@@ -17,4 +19,3 @@ do_stage() {
ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
}
-
diff --git a/recipes/libsdl/libsdl-image_1.2.10.bb b/recipes/libsdl/libsdl-image_1.2.10.bb
new file mode 100644
index 0000000000..bda06456b3
--- /dev/null
+++ b/recipes/libsdl/libsdl-image_1.2.10.bb
@@ -0,0 +1,16 @@
+require libsdl-image.inc
+
+PR = "${INC_PR}.1"
+
+DEPENDS += "tiff"
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_unpackpost() {
+ # Removing this file fixes a libtool version mismatch.
+ rm acinclude/libtool.m4
+ rm acinclude/sdl.m4
+}
+
+addtask unpackpost after do_unpack before do_patch
diff --git a/recipes/libsdl/libsdl-image_1.2.3.bb b/recipes/libsdl/libsdl-image_1.2.3.bb
index 2da8fce1b6..ea3e72c94f 100644
--- a/recipes/libsdl/libsdl-image_1.2.3.bb
+++ b/recipes/libsdl/libsdl-image_1.2.3.bb
@@ -1,6 +1,6 @@
require libsdl-image.inc
-PR = "r2"
+PR = "${INC_PR}.2"
SRC_URI += "\
file://autotools.patch;patch=1 \
diff --git a/recipes/libsdl/libsdl-image_1.2.6.bb b/recipes/libsdl/libsdl-image_1.2.6.bb
index 99fd98f508..9657ba611a 100644
--- a/recipes/libsdl/libsdl-image_1.2.6.bb
+++ b/recipes/libsdl/libsdl-image_1.2.6.bb
@@ -1,5 +1,6 @@
require libsdl-image.inc
-PR = "r1"
+
+PR = "${INC_PR}.1"
DEPENDS += "tiff"