aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/u-boot/u-boot-omap3pandora_git.bb28
-rw-r--r--recipes/x-load/x-load-omap3pandora_git.bb21
-rw-r--r--recipes/x-load/x-load_git.bb1
3 files changed, 50 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-omap3pandora_git.bb b/recipes/u-boot/u-boot-omap3pandora_git.bb
new file mode 100644
index 0000000000..db68f9eadf
--- /dev/null
+++ b/recipes/u-boot/u-boot-omap3pandora_git.bb
@@ -0,0 +1,28 @@
+require u-boot.inc
+
+COMPATIBLE_MACHINE = "omap3-pandora"
+
+# Latest SRCREV for the final shipping boards.
+SRCREV = "0ffcce5dad2153f5f3094f9114b1ae50aef2f5ad"
+
+# Latest SRCREV for the rev2 < boards.
+#SRCREV = "f1cc097b8a8c3c5e1bb6fbec906cfedd939c5be3"
+
+PROVIDES = "u-boot"
+
+PV = "pandora+${PR}+gitr${SRCREV}"
+PR ="r2"
+PE = "1"
+
+SRC_URI = "git://git.openpandora.org/pandora-u-boot.git;branch=master;protocol=git \
+"
+
+# Rev 2 tree
+#SRC_URI = "git://git.openpandora.org/pandora-u-boot.git;branch=rev3;protocol=git \
+#"
+
+UBOOT_MACHINE_omap3_pandora = "omap3_pandora_config"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes/x-load/x-load-omap3pandora_git.bb b/recipes/x-load/x-load-omap3pandora_git.bb
new file mode 100644
index 0000000000..c19b719592
--- /dev/null
+++ b/recipes/x-load/x-load-omap3pandora_git.bb
@@ -0,0 +1,21 @@
+require x-load.inc
+
+COMPATIBLE_MACHINE = "omap3-pandora"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-${MACHINE}/${MACHINE}"
+
+SRCREV = "ea866e76420f629614ae3fc828f1525a77e051e8"
+
+PROVIDES = "x-load"
+
+PV = "1.42+${PR}+gitr${SRCREV}"
+PR ="r1"
+PE = "1"
+
+SRC_URI = "git://git.openpandora.org/pandora-x-loader.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XLOAD_MACHINE = "pandora_config"
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index a369f4e3c9..3368fce52f 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -1,6 +1,7 @@
require x-load.inc
DEFAULT_PREFERENCE_omap3517-evm = "-1"
+DEFAULT_PREFERENCE_omap3-pandora = "-1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/x-load-git/${MACHINE}"