aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini12
-rw-r--r--recipes/gnome/libproxy_0.2.3.bb20
2 files changed, 32 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 5afb025312..18e4279d9c 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -13598,6 +13598,10 @@ sha256=cafe6431f9e6d561fb7b396bf94ff73a9cd0f4279f3eea2fc714ab90e345eee6
md5=00cea4539bea4bd34cbf8b82ff9589cd
sha256=9bec729a1e77d8bbc5800b14aa81f09290aa18daa40f344103f2c0d1d681531b
+[http://libproxy.googlecode.com/files/libproxy-0.2.3.tar.gz]
+md5=86b635e1eb2d665cfbef4c6134fe6604
+sha256=59ded160b3547d29e37cc9d06359f7f37d94112214e4532430cd65e704c1339a
+
[http://xcb.freedesktop.org/dist/libpthread-stubs-0.1.tar.bz2]
md5=774eabaf33440d534efe108ef9130a7d
sha256=004dae11e11598584939d66d26a5ab9b48d08a00ca2d00ae8d38ee3ac7a15d65
@@ -13802,6 +13806,10 @@ sha256=d98203f017c6e1de7dca2037c533000705fc86b12f29694ddb4db17854e5498a
md5=118967f097a7e1e9d5023f1f06e0b65a
sha256=30055988d990f0f4db4dcffd5088115f1065a6fd7c22b555686449628375376b
+[http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.26/libsoup-2.26.0.tar.bz2]
+md5=9df9d2b3304213641d3214a774d75ee1
+sha256=47b749b20717df24393c83adcce9a3a10f0690517c18da8d0a1ddcb410a0ac1d
+
[http://ftp.gnome.org/pub/GNOME/sources/libsoup-2.4/2.4/libsoup-2.4.1.tar.bz2]
md5=d0fc91ccb9da401e9e40d2f4612bdac9
sha256=774094746748fb0c8985210de0994accdc7095c222fba42c5623e2137443b6cd
@@ -15790,6 +15798,10 @@ sha256=7861535eef2c0804dbdc6993db76574b4a812164bed7545a3697a3b97e36d2dd
md5=5169ead6783f374cedf3f89bf399bd75
sha256=a966641cf1b6e18e4f58aa3585a9a63905ed50252883804c006a3263674a32ec
+[http://goodies.xfce.org/releases/midori/midori-0.1.4.tar.bz2]
+md5=a9b21027ba894fed3055d7074c5f073d
+sha256=4a84422c270625162f6e9e1e4e8151d9546457d64c61c2b3c896cbf43fb54ce5
+
[http://git.xfce.org/kalikiana/midori/snapshot/midori-f30dff433056e239ca775d16f343bdb249f1a338.tar.bz2]
md5=24f6c176246300b66c036de65fed0565
sha256=6151809d337ea8d07769618acd4ac470c5ccd310790e40805b93cf8781904048
diff --git a/recipes/gnome/libproxy_0.2.3.bb b/recipes/gnome/libproxy_0.2.3.bb
new file mode 100644
index 0000000000..2a2ee51cd7
--- /dev/null
+++ b/recipes/gnome/libproxy_0.2.3.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A library handling all the details of proxy configuration"
+LICENSE = "LGPL"
+DEPENDS = "gconf virtual/libx11"
+
+SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz"
+
+inherit autotools_stage
+
+# Disable plugins that are *up* in the depchain, they need libproxy to build
+# Don't we just love circular deps?
+EXTRA_OECONF = " --with-file \
+ --with-gnome \
+ --without-kde \
+ --without-webkit \
+ --without-mozjs \
+ --without-networkmanager \
+ "
+
+FILES_${PN}-dbg += "${libdir}/libproxy/*/plugins/.debug"
+