aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/u-boot/u-boot-bug_svn.bb37
2 files changed, 38 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 64781ebfeb..d924070315 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -239,6 +239,7 @@ SRCREV_pn-table ?= "2191"
SRCREV_pn-tichy ?= "ab68d849502009cf3214df48ffa8075a10cc2177"
SRCREV_pn-tmut ?= "60"
SRCREV_pn-toscoterm ?= "f02add76f365a2fecd2dbefc230ceaab20244f96"
+SRCREV_pn-u-boot-bug ?= "8674"
SRCREV_pn-u-boot-openmoko ?= "650149a53dbdd48bf6dfef90930c8ab182adb512"
SRCREV_pn-u-boot-openmoko-devel ?= "ba029a1426bfca169572bf80d50a8b190a6b0e19"
SRCREV_pn-uclibc ?= "25712"
diff --git a/recipes/u-boot/u-boot-bug_svn.bb b/recipes/u-boot/u-boot-bug_svn.bb
new file mode 100644
index 0000000000..c1930f4889
--- /dev/null
+++ b/recipes/u-boot/u-boot-bug_svn.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "U-boot bootloader w/ BUG support"
+LICENSE = "GPL"
+SECTION = "bootloader"
+PRIORITY = "optional"
+PV = "1.3.2+svnr${SRCREV}"
+SRCREV = "${AUTOREV}"
+PR = "r6"
+
+SRC_URI = "\
+ svn://svn.buglabs.net/bug/branches/R1.4/qa;module=u-boot;proto=svn \
+"
+S = "${WORKDIR}/u-boot"
+
+COMPATIBLE_MACHINE = "bug"
+PACKAGE_ARCH = "${MACHINE}"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ oe_runmake mx31_bug2_config
+ oe_runmake clean
+ oe_runmake all
+}
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
+}
+
+do_stage() {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_package after do_install