aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/kernel.bbclass3
-rw-r--r--packages/btsco/.mtn2git_empty0
-rw-r--r--packages/btsco/btsco-module-0.41/.mtn2git_empty0
-rw-r--r--packages/btsco/btsco-module-0.41/makefile.patch16
-rw-r--r--packages/btsco/btsco-module_0.41.bb19
-rw-r--r--packages/btsco/btsco_0.41.bb11
-rw-r--r--packages/gpe-clock/gpe-clock_0.23.bb9
-rw-r--r--packages/gpe-mini-browser/gpe-mini-browser_0.19.bb51
-rw-r--r--packages/gpe-timesheet/gpe-timesheet_0.21.bb9
-rw-r--r--packages/libgpewidget/libgpewidget_0.107.bb20
-rw-r--r--packages/meta/slugos-image.bb1
-rw-r--r--packages/meta/slugos-imagename.bb33
-rw-r--r--packages/pkgconfig/pkgconfig-0.15.0/pkg.m4156
-rw-r--r--packages/pkgconfig/pkgconfig_0.15.0.bb4
14 files changed, 330 insertions, 2 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 2e54d06b28..af2d35fc76 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -101,6 +101,9 @@ kernel_do_stage() {
mkdir -p ${STAGING_KERNEL_DIR}/include/pcmcia
cp -fR include/pcmcia/* ${STAGING_KERNEL_DIR}/include/pcmcia/
+ mkdir -p ${STAGING_KERNEL_DIR}/include/sound
+ cp -fR include/sound/* ${STAGING_KERNEL_DIR}/include/sound/
+
if [ -d drivers/sound ]; then
# 2.4 alsa needs some headers from this directory
mkdir -p ${STAGING_KERNEL_DIR}/include/drivers/sound
diff --git a/packages/btsco/.mtn2git_empty b/packages/btsco/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/btsco/.mtn2git_empty
diff --git a/packages/btsco/btsco-module-0.41/.mtn2git_empty b/packages/btsco/btsco-module-0.41/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/btsco/btsco-module-0.41/.mtn2git_empty
diff --git a/packages/btsco/btsco-module-0.41/makefile.patch b/packages/btsco/btsco-module-0.41/makefile.patch
new file mode 100644
index 0000000000..cf57b59475
--- /dev/null
+++ b/packages/btsco/btsco-module-0.41/makefile.patch
@@ -0,0 +1,16 @@
+--- btsco-0.41/kernel/Makefile.orig 2006-01-13 00:32:58.000000000 +0100
++++ btsco-0.41/kernel/Makefile 2006-01-13 00:33:35.000000000 +0100
+@@ -10,10 +10,10 @@
+
+
+ default:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
+
+ install:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules_install
+
+ clean:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` clean
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` clean
diff --git a/packages/btsco/btsco-module_0.41.bb b/packages/btsco/btsco-module_0.41.bb
new file mode 100644
index 0000000000..c4997cf5bd
--- /dev/null
+++ b/packages/btsco/btsco-module_0.41.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+ install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
diff --git a/packages/btsco/btsco_0.41.bb b/packages/btsco/btsco_0.41.bb
new file mode 100644
index 0000000000..dae5877483
--- /dev/null
+++ b/packages/btsco/btsco_0.41.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Bluetooth-alsa headset tool"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+MAINTAINER = "Robert Woerle <robert@linuxdevelopment.de>"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"
diff --git a/packages/gpe-clock/gpe-clock_0.23.bb b/packages/gpe-clock/gpe-clock_0.23.bb
new file mode 100644
index 0000000000..51b001208b
--- /dev/null
+++ b/packages/gpe-clock/gpe-clock_0.23.bb
@@ -0,0 +1,9 @@
+inherit gpe
+
+DESCRIPTION = "GPE panel clock"
+DEPENDS = "gtk+ libschedule libgpewidget gpe-announce atd libgpelaunch"
+RDEPENDS = "gpe-announce atd"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
diff --git a/packages/gpe-mini-browser/gpe-mini-browser_0.19.bb b/packages/gpe-mini-browser/gpe-mini-browser_0.19.bb
new file mode 100644
index 0000000000..4a09fb827d
--- /dev/null
+++ b/packages/gpe-mini-browser/gpe-mini-browser_0.19.bb
@@ -0,0 +1,51 @@
+SRC_URI = "ftp://ftp.handhelds.org/projects/gpe/source/gpe-mini-browser-${PV}.tar.gz"
+DESCRIPTION = "A lightweight webbrowser for the GPE platform"
+LICENSE = "GPL"
+DEPENDS = "osb-nrcit sqlite libgpewidget"
+RRECOMMENDS = "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
+
+
+S = "${WORKDIR}/gpe-mini-browser-${PV}"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/usr/share/applications
+ install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
+ install -d ${D}/usr/share/pixmaps
+ install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
+ autotools_do_install
+}
+
+pkg_postinst_${PN}-doc () {
+ #!/bin/sh
+ if [ "x$D" != "x" ]; then
+ if [ -e /etc/gpe/gpe-help.conf ]; then
+ echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
+ else
+ echo [Help] >> /etc/gpe/gpe-help.conf
+ echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
+ fi
+ if [ -x /usr/bin/gpe-helpindex ]; then
+ echo generating help-index
+ gpe-helpindex
+ else
+ echo not generating index for gpe-mini-browser
+ fi
+ fi
+}
+
+pkg_postrm_${PN}-doc () {
+ #!/bin/sh
+ if [ -e /etc/gpe/gpe-help.conf ]; then
+ sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
+ mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
+ fi
+ if [ -x /usr/bin/gpe-helpindex ]; then
+ echo generating help-index
+ gpe-helpindex
+ else
+ echo not generating index for gpe-mini-browser
+ fi
+}
+
diff --git a/packages/gpe-timesheet/gpe-timesheet_0.21.bb b/packages/gpe-timesheet/gpe-timesheet_0.21.bb
new file mode 100644
index 0000000000..0cd8b539f0
--- /dev/null
+++ b/packages/gpe-timesheet/gpe-timesheet_0.21.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPL"
+inherit gpe
+
+DESCRIPTION = "GPE time tracker"
+DEPENDS = "libgpewidget gtk+ sqlite"
+SECTION = "gpe"
+RDEPENDS = "gpe-icons"
+
+SRC_URI = "${GPE_MIRROR}/gpe-timesheet-${PV}.tar.gz"
diff --git a/packages/libgpewidget/libgpewidget_0.107.bb b/packages/libgpewidget/libgpewidget_0.107.bb
new file mode 100644
index 0000000000..3bd2996e67
--- /dev/null
+++ b/packages/libgpewidget/libgpewidget_0.107.bb
@@ -0,0 +1,20 @@
+LICENSE = "LGPL"
+DESCRIPTION = "libgpewidget contains a collection of widgets and other common code shared by many GPE applications."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "gtk+ cairo libxrender gtk-doc intltool-native"
+
+PACKAGES =+ "libgpewidget-bin"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
+inherit pkgconfig autotools
+
+FILES_libgpewidget-bin = "${bindir}"
+
+EXTRA_OECONF = "--enable-cairo"
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/packages/meta/slugos-image.bb b/packages/meta/slugos-image.bb
index c01ab6c487..1fa67bb9d3 100644
--- a/packages/meta/slugos-image.bb
+++ b/packages/meta/slugos-image.bb
@@ -5,7 +5,6 @@
#
LICENSE = "MIT"
PR = "r19"
-PROVIDES += "${SLUGOS_IMAGENAME}-image"
# SLUGOS_IMAGENAME defines the name of the image to be build, if it
# is not set this package will be skipped!
diff --git a/packages/meta/slugos-imagename.bb b/packages/meta/slugos-imagename.bb
new file mode 100644
index 0000000000..dfca396c7c
--- /dev/null
+++ b/packages/meta/slugos-imagename.bb
@@ -0,0 +1,33 @@
+# This is an inglorious hack to provide a package to match
+# ${SLUGOS_IMAGENAME}-image
+MAINTAINER = "John Bowler <jbowler@acm.org>
+PN = "${SLUGOS_IMAGENAME}-image"
+PV = "0"
+PR = "r0"
+DEPENDS = "slugos-image"
+PACKAGES = ""
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_fetch() {
+}
+do_unpack() {
+}
+do_patch() {
+}
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+do_stage() {
+}
+do_build() {
+}
+
+python () {
+ # Don't build slugos images unless the configuration is set up
+ # for an image build!
+ if bb.data.getVar("SLUGOS_IMAGENAME", d, 1) == '':
+ raise bb.parse.SkipPackage("absent SlugOS configuration")
+}
diff --git a/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4 b/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4
new file mode 100644
index 0000000000..cbb46dbf83
--- /dev/null
+++ b/packages/pkgconfig/pkgconfig-0.15.0/pkg.m4
@@ -0,0 +1,156 @@
+# pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
+#
+# Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+# As a special exception to the GNU General Public License, if you
+# distribute this file as part of a program that contains a
+# configuration script generated by Autoconf, you may include it under
+# the same distribution terms that you use for the rest of that program.
+
+# PKG_PROG_PKG_CONFIG([MIN-VERSION])
+# ----------------------------------
+AC_DEFUN([PKG_PROG_PKG_CONFIG],
+[m4_pattern_forbid([^_?PKG_[A-Z_]+$])
+m4_pattern_allow([^PKG_CONFIG(_PATH)?$])
+AC_ARG_VAR([PKG_CONFIG], [path to pkg-config utility])dnl
+if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+fi
+if test -n "$PKG_CONFIG"; then
+ _pkg_min_version=m4_default([$1], [0.9.0])
+ AC_MSG_CHECKING([pkg-config is at least version $_pkg_min_version])
+ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ PKG_CONFIG=""
+ fi
+
+fi[]dnl
+])# PKG_PROG_PKG_CONFIG
+
+# PKG_CHECK_EXISTS(MODULES, [ACTION-IF-FOUND], [ACTION-IF-NOT-FOUND])
+#
+# Check to see whether a particular set of modules exists. Similar
+# to PKG_CHECK_MODULES(), but does not set variables or print errors.
+#
+#
+# Similar to PKG_CHECK_MODULES, make sure that the first instance of
+# this or PKG_CHECK_MODULES is called, or make sure to call
+# PKG_CHECK_EXISTS manually
+# --------------------------------------------------------------
+AC_DEFUN([PKG_CHECK_EXISTS],
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
+if test -n "$PKG_CONFIG" && \
+ AC_RUN_LOG([$PKG_CONFIG --exists --print-errors "$1"]); then
+ m4_ifval([$2], [$2], [:])
+m4_ifvaln([$3], [else
+ $3])dnl
+fi])
+
+
+# _PKG_CONFIG([VARIABLE], [COMMAND], [MODULES])
+# ---------------------------------------------
+m4_define([_PKG_CONFIG],
+[if test -n "$PKG_CONFIG"; then
+ if test -n "$$1"; then
+ pkg_cv_[]$1="$$1"
+ else
+ PKG_CHECK_EXISTS([$3],
+ [pkg_cv_[]$1=`$PKG_CONFIG --[]$2 "$3" 2>/dev/null`],
+ [pkg_failed=yes])
+ fi
+else
+ pkg_failed=untried
+fi[]dnl
+])# _PKG_CONFIG
+
+# _PKG_SHORT_ERRORS_SUPPORTED
+# -----------------------------
+AC_DEFUN([_PKG_SHORT_ERRORS_SUPPORTED],
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+ _pkg_short_errors_supported=yes
+else
+ _pkg_short_errors_supported=no
+fi[]dnl
+])# _PKG_SHORT_ERRORS_SUPPORTED
+
+
+# PKG_CHECK_MODULES(VARIABLE-PREFIX, MODULES, [ACTION-IF-FOUND],
+# [ACTION-IF-NOT-FOUND])
+#
+#
+# Note that if there is a possibility the first call to
+# PKG_CHECK_MODULES might not happen, you should be sure to include an
+# explicit call to PKG_PROG_PKG_CONFIG in your configure.ac
+#
+#
+# --------------------------------------------------------------
+AC_DEFUN([PKG_CHECK_MODULES],
+[AC_REQUIRE([PKG_PROG_PKG_CONFIG])dnl
+AC_ARG_VAR([$1][_CFLAGS], [C compiler flags for $1, overriding pkg-config])dnl
+AC_ARG_VAR([$1][_LIBS], [linker flags for $1, overriding pkg-config])dnl
+
+pkg_failed=no
+AC_MSG_CHECKING([for $1])
+
+_PKG_CONFIG([$1][_CFLAGS], [cflags], [$2])
+_PKG_CONFIG([$1][_LIBS], [libs], [$2])
+
+m4_define([_PKG_TEXT], [Alternatively, you may set the environment variables $1[]_CFLAGS
+and $1[]_LIBS to avoid the need to call pkg-config.
+See the pkg-config man page for more details.])
+
+if test $pkg_failed = yes; then
+ _PKG_SHORT_ERRORS_SUPPORTED
+ if test $_pkg_short_errors_supported = yes; then
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$2"`
+ else
+ $1[]_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$$1[]_PKG_ERRORS" >&AS_MESSAGE_LOG_FD
+
+ ifelse([$4], , [AC_MSG_ERROR(dnl
+[Package requirements ($2) were not met:
+
+$$1_PKG_ERRORS
+
+Consider adjusting the PKG_CONFIG_PATH environment variable if you
+installed software in a non-standard prefix.
+
+_PKG_TEXT
+])],
+ [$4])
+elif test $pkg_failed = untried; then
+ ifelse([$4], , [AC_MSG_FAILURE(dnl
+[The pkg-config script could not be found or is too old. Make sure it
+is in your PATH or set the PKG_CONFIG environment variable to the full
+path to pkg-config.
+
+_PKG_TEXT
+
+To get pkg-config, see <http://www.freedesktop.org/software/pkgconfig>.])],
+ [$4])
+else
+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
+ $1[]_LIBS=$pkg_cv_[]$1[]_LIBS
+ AC_MSG_RESULT([yes])
+ ifelse([$3], , :, [$3])
+fi[]dnl
+])# PKG_CHECK_MODULES
diff --git a/packages/pkgconfig/pkgconfig_0.15.0.bb b/packages/pkgconfig/pkgconfig_0.15.0.bb
index e38e20438d..31fc7820fe 100644
--- a/packages/pkgconfig/pkgconfig_0.15.0.bb
+++ b/packages/pkgconfig/pkgconfig_0.15.0.bb
@@ -5,10 +5,11 @@ It replaces the ubiquitous *-config scripts you may have \
seen with a single tool."
HOMEPAGE = "http://www.freedesktop.org/software/pkgconfig/"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.freedesktop.org/software/pkgconfig/releases/pkgconfig-${PV}.tar.gz \
file://configure.patch;patch=1 \
+ file://pkg.m4 \
file://glibconfig-sysdefs.h"
inherit autotools
@@ -16,6 +17,7 @@ inherit autotools
acpaths = "-I ."
do_configure_prepend () {
install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
+ install -m 0644 ${WORKDIR}/pkg.m4 ${S}/
}
do_stage_append() {