aboutsummaryrefslogtreecommitdiffstats
path: root/vim
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-10-23 21:49:59 +0000
committerChris Larson <clarson@kergoth.com>2003-10-23 21:49:59 +0000
commitae17fc1d59cbbe2f92f4df8ef52dbe55a3d3d705 (patch)
tree569b51d5a7e11eda34677d480d0a730603dd5923 /vim
parent09531dd9b5f9b2fdca22e37bc1b5542bc85608dc (diff)
downloadopenembedded-ae17fc1d59cbbe2f92f4df8ef52dbe55a3d3d705.tar.gz
gpm_1.20.1.oe:
Add libc and ncurses to gpm deps. vim_6.2.oe: Add ncurses to deps for vim BKrev: 3f984d07zhiQ662eThKmwM4l2jsZGQ
Diffstat (limited to 'vim')
-rw-r--r--vim/vim_6.2.oe23
1 files changed, 23 insertions, 0 deletions
diff --git a/vim/vim_6.2.oe b/vim/vim_6.2.oe
index e69de29bb2..1eb68b8c9c 100644
--- a/vim/vim_6.2.oe
+++ b/vim/vim_6.2.oe
@@ -0,0 +1,23 @@
+DEPENDS = virtual/libc ncurses
+RDEPENDS = libc6 ncurses
+
+SRC_URI = ftp://ftp.vim.org/pub/vim/unix/vim-6.2.tar.bz2 \
+ file://${FILESDIR}/configure.patch;patch=1
+S = ${WORKDIR}/vim62/src
+
+inherit autotools
+
+EXTRA_OECONF = '--enable-gui=none --disable-gtktest \
+ --disable-xim --with-features=normal \
+ --disable-gpm --without-x --disable-netbeans \
+ --with-tlib=ncurses'
+
+do_configure () {
+ rm -f auto/*
+ touch auto/config.mk
+ aclocal
+ autoconf
+ oe_runconf
+ touch auto/configure
+ touch auto/config.mk auto/config.h
+}