aboutsummaryrefslogtreecommitdiffstats
path: root/uae
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-03-05 22:31:52 +0000
committerChris Larson <clarson@kergoth.com>2004-03-05 22:31:52 +0000
commit1be282b573822d9bc8f11d59b3b5192f4948c249 (patch)
tree8665fe91e9a41602e4f4951828b4b3a1dcc9de94 /uae
parent1434525033ade35daa6f0e8753e38dcef783ea46 (diff)
downloadopenembedded-1be282b573822d9bc8f11d59b3b5192f4948c249.tar.gz
Fix uae build. Specify location of sdl and zlib, add m4 patch so the autotools execution succeeds, fix the call out of src/tools/configure, and replace the install steps putting uaerc into /home/root/ with a rant.
BKrev: 4048ffd8pqv4U01MT9Jf6QyApYkGzw
Diffstat (limited to 'uae')
-rw-r--r--uae/uae-0.8.23-20040129/configure.patch9
-rw-r--r--uae/uae-0.8.23-20040129/m4.patch0
-rw-r--r--uae/uae_0.8.23-20040129.oe34
3 files changed, 43 insertions, 0 deletions
diff --git a/uae/uae-0.8.23-20040129/configure.patch b/uae/uae-0.8.23-20040129/configure.patch
index e69de29bb2..bd2ecce3d7 100644
--- a/uae/uae-0.8.23-20040129/configure.patch
+++ b/uae/uae-0.8.23-20040129/configure.patch
@@ -0,0 +1,9 @@
+--- tmp/base/uae-0.8.23-20040129-r0/uae-0.8.23-20040129/configure.in 2004-01-29 00:38:18.000000000 -0500
++++ uae-0.8.23-20040129/configure.in 2004-03-05 17:26:12.000000000 -0500
+@@ -1032,5 +1032,5 @@
+ export CC=$CC_FOR_BUILD
+ export CFLAGS=$CFLAGS_FOR_BUILD
+ mkdir -p src/tools
+- cd src/tools && ../../"$srcdir"/src/tools/configure --cache-file=/dev/null --host=$build --target=$host
++ cd src/tools && "$srcdir"/src/tools/configure --cache-file=/dev/null --host=$build --target=$host
+ fi
diff --git a/uae/uae-0.8.23-20040129/m4.patch b/uae/uae-0.8.23-20040129/m4.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/uae/uae-0.8.23-20040129/m4.patch
diff --git a/uae/uae_0.8.23-20040129.oe b/uae/uae_0.8.23-20040129.oe
index e69de29bb2..9415f4b5b5 100644
--- a/uae/uae_0.8.23-20040129.oe
+++ b/uae/uae_0.8.23-20040129.oe
@@ -0,0 +1,34 @@
+DESCRIPTION="Amiga Emulator based on SDL"
+SECTION="base"
+PRIORITY="optional"
+RDEPENDS="libc6 libsdl-qpe"
+DEPENDS=virtual/libc libsdl-qpe
+
+SRC_URI = http://rcdrummond.net/${PN}/${P}/${P}.tar.bz2 \
+ file://${FILESDIR}/configure.patch;patch=1 \
+ file://${FILESDIR}/m4.patch;patch=1
+
+inherit autotools libtool
+
+EXTRA_OECONF = "--with-hostcc=gcc --disable-ui --without-x \
+ --without-gtk --enable-jit --disable-natmem \
+ --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-sdl-exec-prefix=${STAGING_BINDIR}/.. \
+ --with-sdl-prefix=${STAGING_LIBDIR}/.."
+
+CFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+CXXFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
+
+do_configure_prepend () {
+ touch NEWS AUTHORS ChangeLog
+}
+
+do_install_append() {
+# Packages NEVER, ever, ever, ever touch home directories directly.
+# ever.
+# Either update a global config in /etc, install it into /etc/skel/ for
+# new users homedirs, rely on the user installing it to put it in place,
+# or dont install it at all. --CL
+# install -d ${D}/home/root
+# install ${FILESDIR}/uaerc ${D}/home/root/.uaerc
+}