aboutsummaryrefslogtreecommitdiffstats
path: root/rsync
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /rsync
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'rsync')
-rw-r--r--rsync/rsync-2.6.2/fixedwidthtypes.patch35
-rw-r--r--rsync/rsync-2.6.2/gettimeofday.patch18
2 files changed, 53 insertions, 0 deletions
diff --git a/rsync/rsync-2.6.2/fixedwidthtypes.patch b/rsync/rsync-2.6.2/fixedwidthtypes.patch
index e69de29bb2..9f7d3c804d 100644
--- a/rsync/rsync-2.6.2/fixedwidthtypes.patch
+++ b/rsync/rsync-2.6.2/fixedwidthtypes.patch
@@ -0,0 +1,35 @@
+--- rsync-2.6.2/configure.in 2004-04-30 14:02:43.000000000 -0400
++++ rsync-2.6.2/configure.in 2004-05-22 13:09:42.000000000 -0400
+@@ -307,6 +307,8 @@
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
+
+ AC_CHECK_TYPE([ino_t], [unsigned])
++AC_CHECK_TYPES([int64_t])
++AC_CHECK_TYPES([uint64_t])
+ TYPE_SOCKLEN_T
+
+ AC_CACHE_CHECK([for errno in errno.h],rsync_cv_errno, [
+--- rsync-2.6.2/rsync.h 2004-04-26 21:36:16.000000000 -0400
++++ rsync-2.6.2/rsync.h 2004-05-22 13:06:16.000000000 -0400
+@@ -298,7 +298,9 @@
+ #define STRUCT_STAT struct stat
+ #endif
+
+-#if HAVE_OFF64_T
++#if defined(HAVE_INT64_T)
++#define int64 int64_t
++#elif HAVE_OFF64_T
+ #define int64 off64_t
+ #elif (SIZEOF_LONG == 8)
+ #define int64 long
+@@ -312,7 +314,9 @@
+ #define NO_INT64
+ #endif
+
+-#if (SIZEOF_LONG == 8)
++#if defined(HAVE_UINT64_T)
++#define uint64 uint64_t
++#elif (SIZEOF_LONG == 8)
+ #define uint64 unsigned long
+ #elif (SIZEOF_INT == 8)
+ #define uint64 unsigned int
diff --git a/rsync/rsync-2.6.2/gettimeofday.patch b/rsync/rsync-2.6.2/gettimeofday.patch
index e69de29bb2..9248866c56 100644
--- a/rsync/rsync-2.6.2/gettimeofday.patch
+++ b/rsync/rsync-2.6.2/gettimeofday.patch
@@ -0,0 +1,18 @@
+--- rsync-2.6.2/configure.in 2004-07-09 14:32:16.000000000 +0200
++++ rsync-2.6.2/configure.in 2004-07-09 14:31:26.000000000 +0200
+@@ -539,11 +539,12 @@
+ fi
+
+ AC_CACHE_CHECK([if gettimeofday takes tz argument],rsync_cv_HAVE_GETTIMEOFDAY_TZ,[
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <sys/time.h>
+ #include <unistd.h>
+-main() { struct timeval tv; exit(gettimeofday(&tv, NULL));}],
+- rsync_cv_HAVE_GETTIMEOFDAY_TZ=yes,rsync_cv_HAVE_GETTIMEOFDAY_TZ=no,rsync_cv_HAVE_GETTIMEOFDAY_TZ=cross)])
++],
++[struct timeval tv; exit(gettimeofday(&tv, NULL));],
++ rsync_cv_HAVE_GETTIMEOFDAY_TZ=yes,rsync_cv_HAVE_GETTIMEOFDAY_TZ=no)])
+ if test x"$rsync_cv_HAVE_GETTIMEOFDAY_TZ" = x"yes"; then
+ AC_DEFINE(HAVE_GETTIMEOFDAY_TZ, 1, [ ])
+ fi