summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-12-08 00:15:34 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-08 00:18:58 +0100
commitfae65a5a2ca8a4b9a895001f9ab9f69d235081e1 (patch)
treeadf9f8033f187562ed8dec73015f49edf2b2f4c7 /recipes
parentd360605deb0e7254732b07336218d5d97dbfb81d (diff)
downloadopenembedded-fae65a5a2ca8a4b9a895001f9ab9f69d235081e1.tar.gz
matchbox-panel-2: fix build with newer revision for eglibc
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/matchbox2/matchbox-panel-2/rename.sync.to.sync_applet.patch33
-rw-r--r--recipes/matchbox2/matchbox-panel-2_svn.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/matchbox2/matchbox-panel-2/rename.sync.to.sync_applet.patch b/recipes/matchbox2/matchbox-panel-2/rename.sync.to.sync_applet.patch
new file mode 100644
index 0000000000..f51cc0b327
--- /dev/null
+++ b/recipes/matchbox2/matchbox-panel-2/rename.sync.to.sync_applet.patch
@@ -0,0 +1,33 @@
+sync conflicts with sync in newer eglibc
+| showdesktop.c:60:1: error: conflicting types for 'sync'
+| /OE/tmpdir-shr/sysroots/armv4t-oe-linux-gnueabi/usr/include/unistd.h:986:13: note: previous declaration of 'sync' was here
+
+--- matchbox-panel-2/applets/showdesktop/showdesktop.c 2010-12-08 00:11:26.000000000 +0100
++++ matchbox-panel-2/applets/showdesktop/showdesktop.c.new 2010-12-08 00:11:16.000000000 +0100
+@@ -57,7 +57,7 @@
+
+ /* Sync @applet with the _NET_SHOWING_DESKTOP root window property */
+ static void
+-sync (ShowDesktopApplet *applet)
++sync_applet (ShowDesktopApplet *applet)
+ {
+ GdkDisplay *display;
+ Atom type;
+@@ -103,7 +103,7 @@
+ if (xev->type == PropertyNotify) {
+ if (xev->xproperty.atom == applet->atom) {
+ /* _NET_SHOWING_DESKTOP changed */
+- sync (applet);
++ sync_applet (applet);
+ }
+ }
+
+@@ -145,7 +145,7 @@
+ applet);
+
+ /* Sync */
+- sync (applet);
++ sync_applet (applet);
+ }
+
+ /* Button clicked */
diff --git a/recipes/matchbox2/matchbox-panel-2_svn.bb b/recipes/matchbox2/matchbox-panel-2_svn.bb
index 8ca4b664c6..fcc49b296f 100644
--- a/recipes/matchbox2/matchbox-panel-2_svn.bb
+++ b/recipes/matchbox2/matchbox-panel-2_svn.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRCREV = "2098"
PV = "2.0+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
inherit autotools pkgconfig
@@ -17,6 +17,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
file://startup-invalid-access.patch;striplevel=0 \
file://startup-shown-uninitialized.patch;striplevel=0 \
file://themeable-icons.patch;striplevel=0 \
+ file://rename.sync.to.sync_applet.patch \
"
S = "${WORKDIR}/${PN}"