summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-22 12:23:03 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-22 12:23:03 +0200
commit756b69f81813b7b1a6a4c14ec7ec7e4b36f7ac37 (patch)
treeb80cec9ea5d2f4eb83281fcf9fa3d3d3f302444f /recipes
parent3812ebdea85d905d382e4288f568d8be64882ac0 (diff)
parentd0e0791eb9562fc0d3ade781cfe330f118537f84 (diff)
downloadopenembedded-756b69f81813b7b1a6a4c14ec7ec7e4b36f7ac37.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/argp-standalone/argp-standalone_1.3.bb10
-rw-r--r--recipes/eibd/eibd_0.0.4.bb62
-rwxr-xr-xrecipes/eibd/files/eibd59
-rw-r--r--recipes/freesmartphone/fso-term_git.bb4
-rw-r--r--recipes/freesmartphone/libfsotransport_git.bb3
-rw-r--r--recipes/freesmartphone/libgsm0710mux_git.bb4
-rw-r--r--recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb17
-rwxr-xr-xrecipes/initscripts/files/hipox/reboot19
-rw-r--r--recipes/initscripts/initscripts_1.0.bb7
-rw-r--r--recipes/linknx/files/configure-libcurl.patch215
-rw-r--r--recipes/linknx/linknx_0.0.1.26.bb17
-rwxr-xr-xrecipes/owfs/files/owhttpd60
-rwxr-xr-xrecipes/owfs/files/owserver59
-rw-r--r--recipes/owfs/owfs_2.7p21.bb58
-rw-r--r--recipes/pthsem/files/ldflags.patch16
-rw-r--r--recipes/pthsem/pthsem_2.0.7.bb31
16 files changed, 636 insertions, 5 deletions
diff --git a/recipes/argp-standalone/argp-standalone_1.3.bb b/recipes/argp-standalone/argp-standalone_1.3.bb
new file mode 100644
index 0000000000..6de77ef928
--- /dev/null
+++ b/recipes/argp-standalone/argp-standalone_1.3.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Argp is an interface for parsing unix-style argument vectors. This is only needed for uclibc"
+PRIORITY = "optional"
+
+SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/argp-standalone-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/eibd/eibd_0.0.4.bb b/recipes/eibd/eibd_0.0.4.bb
new file mode 100644
index 0000000000..23e2c0832c
--- /dev/null
+++ b/recipes/eibd/eibd_0.0.4.bb
@@ -0,0 +1,62 @@
+DESCRIPTION = "Eibd provides an interface to the EIB / KNX bus"
+HOMEPAGE = "http://www.auto.tuwien.ac.at/~mkoegler/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = " pthsem libxml2"
+DEPENDS_append_linux-uclibc = " argp-standalone "
+DEPENDS_append_linux-uclibcgnueabi = " argp-standalone "
+
+SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/bcusdk_${PV}.tar.gz \
+ file://eibd "
+
+S = "${WORKDIR}/bcusdk-${PV}"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = " --with-pth=yes --without-pth-test \
+ --enable-onlyeibd \
+ --enable-pei16 \
+ --enable-ft12 \
+ --enable-tpuart \
+ --enable-pei16s \
+ --enable-tpuarts \
+ --enable-usb \
+ --enable-eibnetip \
+ --enable-eibnetiptunnel \
+ --enable-eibnetipserver \
+ "
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/default/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/eibd ${D}${sysconfdir}/init.d/eibd
+}
+
+PACKAGES =+ "eibd-server eibd-clients libeibclient-dev"
+
+FILES_eibd-server = "${bindir}/eibnetsearch ${bindir}/findknxusb \
+ ${bindir}/eibd ${bindir}/bcuaddrtab \
+ ${bindir}/eibnetdescribe ${bindir}/bcuread \
+ ${sysconfdir}/init.d/eibd "
+FILES_eibd-clients = "${bindir}/*"
+FILES_libeibclient-dev = "\
+ ${includedir} \
+ ${libdir}/lib*.so \
+ ${libdir}/*.la \
+ ${libdir}/*.a \
+ ${libdir}/*.o \
+ ${libdir}/pkgconfig \
+ /lib/*.a \
+ /lib/*.o \
+ ${datadir}/aclocal"
+
+DESCRIPTION_eibd-clients = "Simple example programs to perform management tasks on a EIB system."
+DESCRIPTION_libeibclient-dev = "A client library written in C to access the EIB bus over eibd."
+DESCRIPTION_eibd-server = "eibd is a daemon which supports connection to an EIB (KNX) network over various \
+interfaces. It provides its services over TCP/IP or Unix domain sockets. \
+It can also act as an EIBnet/IP server."
+
+INITSCRIPT_PACKAGES = "eibd-server"
+INITSCRIPT_NAME = "eibd"
+INITSCRIPT_PARAMS = "defaults 20"
diff --git a/recipes/eibd/files/eibd b/recipes/eibd/files/eibd
new file mode 100755
index 0000000000..953fbb8f80
--- /dev/null
+++ b/recipes/eibd/files/eibd
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/bin
+
+DAEMON="eibd"
+
+test -f /usr/bin/${DAEMON} || exit 0
+
+if test -f /etc/default/${DAEMON} ; then
+. /etc/default/${DAEMON}
+else
+:
+fi
+
+if [ "$START_EIBD" != "yes" ]
+then
+ exit 0
+fi
+
+startdaemon(){
+ echo -n "Starting ${DAEMON}: "
+ start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+stopdaemon(){
+ echo -n "Stopping ${DAEMON}: "
+ start-stop-daemon --stop -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+
+
+case "$1" in
+ start)
+ startdaemon
+ ;;
+ stop)
+ stopdaemon
+ ;;
+ force-reload)
+ stopdaemon
+ startdaemon
+ ;;
+ restart)
+ stopdaemon
+ startdaemon
+ ;;
+ reload)
+ stopdaemon
+ startdaemon
+ ;;
+ *)
+ echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/freesmartphone/fso-term_git.bb b/recipes/freesmartphone/fso-term_git.bb
index e3f674d7cb..22e74d3795 100644
--- a/recipes/freesmartphone/fso-term_git.bb
+++ b/recipes/freesmartphone/fso-term_git.bb
@@ -1,8 +1,8 @@
-DESCRIPTION = "Term is a versatile muxer-aware terminal program"
+DESCRIPTION = "FSO Term is a versatile muxer-aware terminal program"
HOMEPAGE = "http://www.freesmartphone.org/index.php/Implementations/fso-term"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
-DEPENDS = "dbus dbus-glib readline libfsoframework"
+DEPENDS = "dbus dbus-glib readline libfsotransport"
LICENSE = "GPL"
PV = "0.0.0.0+gitr${SRCREV}"
PR = "r0"
diff --git a/recipes/freesmartphone/libfsotransport_git.bb b/recipes/freesmartphone/libfsotransport_git.bb
new file mode 100644
index 0000000000..c46721eca6
--- /dev/null
+++ b/recipes/freesmartphone/libfsotransport_git.bb
@@ -0,0 +1,3 @@
+require cornucopia.inc
+DESCRIPTION = "freesmartphone.org transport library"
+
diff --git a/recipes/freesmartphone/libgsm0710mux_git.bb b/recipes/freesmartphone/libgsm0710mux_git.bb
index 46c7204844..108c6d5672 100644
--- a/recipes/freesmartphone/libgsm0710mux_git.bb
+++ b/recipes/freesmartphone/libgsm0710mux_git.bb
@@ -3,9 +3,9 @@ HOMEPAGE = "http://www.freesmartphone.org/index.php/Implementations/libgsm0710mu
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
LICENSE = "GPL"
SECTION = "devel"
-DEPENDS = "libgsm0710 vala-native glib-2.0"
+DEPENDS = "libgsm0710 vala-native glib-2.0 libfsotransport"
PV = "0.3.4+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
${FREESMARTPHONE_GIT}/libgsm0710mux;protocol=git;branch=master \
diff --git a/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
new file mode 100644
index 0000000000..3076f9501c
--- /dev/null
+++ b/recipes/freesmartphone/vala-dbus-binding-tool-native_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Vala DBus Binding Tool"
+SECTION = "console"
+LICENSE = "GPLv2"
+DEPENDS = "vala-native"
+PV = "0.1.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/vala-dbus-binding-tool.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools native
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 src/vala-dbus-binding-tool ${STAGING_BINDIR_NATIVE}/
+}
+
diff --git a/recipes/initscripts/files/hipox/reboot b/recipes/initscripts/files/hipox/reboot
new file mode 100755
index 0000000000..af2da10d14
--- /dev/null
+++ b/recipes/initscripts/files/hipox/reboot
@@ -0,0 +1,19 @@
+#! /bin/sh
+#
+# reboot Execute the reboot command.
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+
+# Test if we should boot into the new kernel
+if test -x /usr/sbin/kexec -a -f /sys/kernel/kexec_loaded ; then
+ read loaded < /sys/kernel/kexec_loaded
+ if test "$loaded" = "1" ; then
+ echo -n "Loaded kernel image found, executing ... "
+ /usr/sbin/kexec --exec
+ echo "${warn}failed, doing normal reboot${norm}"
+ fi
+fi
+
+echo -n "Rebooting... "
+reboot -d -f -i
diff --git a/recipes/initscripts/initscripts_1.0.bb b/recipes/initscripts/initscripts_1.0.bb
index 556fbe46b7..cbcfec5e18 100644
--- a/recipes/initscripts/initscripts_1.0.bb
+++ b/recipes/initscripts/initscripts_1.0.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
DEPENDS = "makedevs"
RDEPENDS = "makedevs"
LICENSE = "GPL"
-PR = "r113"
+PR = "r114"
SRC_URI = "file://functions \
file://halt \
@@ -130,3 +130,8 @@ do_install () {
do_install_append_angstrom () {
rm ${D}${sysconfdir}/init.d/devices ${D}${sysconfdir}/rcS.d/S05devices
}
+
+# HIPOX needs /sys in reboot for kexec check
+do_install_append_hipox () {
+ ln -sf ../init.d/sysfs.sh ${D}${sysconfdir}/rc6.d/S80sysfs
+}
diff --git a/recipes/linknx/files/configure-libcurl.patch b/recipes/linknx/files/configure-libcurl.patch
new file mode 100644
index 0000000000..3f33867249
--- /dev/null
+++ b/recipes/linknx/files/configure-libcurl.patch
@@ -0,0 +1,215 @@
+Index: linknx-0.0.1.25/configure.ac
+===================================================================
+--- linknx-0.0.1.25.orig/configure.ac 2009-03-02 11:53:10.409969472 +0100
++++ linknx-0.0.1.25/configure.ac 2009-03-02 11:53:20.453754174 +0100
+@@ -12,6 +12,210 @@ AC_CHECK_PTHSEM(2.0.4,yes,yes,no)
+ AC_CHECK_HEADER(argp.h,,[AC_MSG_ERROR([argp_parse not found])])
+ AC_SEARCH_LIBS(argp_parse,argp,,[AC_MSG_ERROR([argp_parse not found])])
+
++AC_DEFUN([LIBCURL_CHECK_CONFIG],
++[
++ AH_TEMPLATE([LIBCURL_FEATURE_SSL],[Defined if libcurl supports SSL])
++ AH_TEMPLATE([LIBCURL_FEATURE_KRB4],[Defined if libcurl supports KRB4])
++ AH_TEMPLATE([LIBCURL_FEATURE_IPV6],[Defined if libcurl supports IPv6])
++ AH_TEMPLATE([LIBCURL_FEATURE_LIBZ],[Defined if libcurl supports libz])
++ AH_TEMPLATE([LIBCURL_FEATURE_ASYNCHDNS],[Defined if libcurl supports AsynchDNS])
++ AH_TEMPLATE([LIBCURL_FEATURE_IDN],[Defined if libcurl supports IDN])
++ AH_TEMPLATE([LIBCURL_FEATURE_SSPI],[Defined if libcurl supports SSPI])
++ AH_TEMPLATE([LIBCURL_FEATURE_NTLM],[Defined if libcurl supports NTLM])
++
++ AH_TEMPLATE([LIBCURL_PROTOCOL_HTTP],[Defined if libcurl supports HTTP])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_HTTPS],[Defined if libcurl supports HTTPS])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_FTP],[Defined if libcurl supports FTP])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_FTPS],[Defined if libcurl supports FTPS])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_FILE],[Defined if libcurl supports FILE])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_TELNET],[Defined if libcurl supports TELNET])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_LDAP],[Defined if libcurl supports LDAP])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_DICT],[Defined if libcurl supports DICT])
++ AH_TEMPLATE([LIBCURL_PROTOCOL_TFTP],[Defined if libcurl supports TFTP])
++
++ AC_ARG_WITH(libcurl,
++ AC_HELP_STRING([--with-libcurl=DIR],[look for the curl library in DIR]),
++ [_libcurl_with=$withval],[_libcurl_with=ifelse([$1],,[yes],[$1])])
++
++ if test "$_libcurl_with" != "no" ; then
++
++ AC_PROG_AWK
++
++ _libcurl_version_parse="eval $AWK '{split(\$NF,A,\".\"); X=256*256*A[[1]]+256*A[[2]]+A[[3]]; print X;}'"
++
++ _libcurl_try_link=yes
++
++ if test -d "$_libcurl_with" ; then
++ LIBCURL_CPPFLAGS="-I$withval/include"
++ _libcurl_ldflags="-L$withval/lib"
++ AC_PATH_PROG([_libcurl_config],["$withval/bin/curl-config"])
++ else
++ AC_PATH_PROG([_libcurl_config],[curl-config])
++ fi
++
++ if test x$_libcurl_config != "x" ; then
++ AC_CACHE_CHECK([for the version of libcurl],
++ [libcurl_cv_lib_curl_version],
++ [libcurl_cv_lib_curl_version=`$_libcurl_config --version | $AWK '{print $[]2}'`])
++
++ _libcurl_version=`echo $libcurl_cv_lib_curl_version | $_libcurl_version_parse`
++ _libcurl_wanted=`echo ifelse([$2],,[0],[$2]) | $_libcurl_version_parse`
++
++ if test $_libcurl_wanted -gt 0 ; then
++ AC_CACHE_CHECK([for libcurl >= version $2],
++ [libcurl_cv_lib_version_ok],
++ [
++ if test $_libcurl_version -ge $_libcurl_wanted ; then
++ libcurl_cv_lib_version_ok=yes
++ else
++ libcurl_cv_lib_version_ok=no
++ fi
++ ])
++ fi
++
++ if test $_libcurl_wanted -eq 0 || test x$libcurl_cv_lib_version_ok = xyes ; then
++ if test x"$LIBCURL_CPPFLAGS" = "x" ; then
++ LIBCURL_CPPFLAGS=`$_libcurl_config --cflags`
++ fi
++ if test x"$LIBCURL" = "x" ; then
++ LIBCURL=`$_libcurl_config --libs`
++
++ # This is so silly, but Apple actually has a bug in their
++ # curl-config script. Fixed in Tiger, but there are still
++ # lots of Panther installs around.
++ case "${host}" in
++ powerpc-apple-darwin7*)
++ LIBCURL=`echo $LIBCURL | sed -e 's|-arch i386||g'`
++ ;;
++ esac
++ fi
++
++ # All curl-config scripts support --feature
++ _libcurl_features=`$_libcurl_config --feature`
++
++ # Is it modern enough to have --protocols? (7.12.4)
++ if test $_libcurl_version -ge 461828 ; then
++ _libcurl_protocols=`$_libcurl_config --protocols`
++ fi
++ else
++ _libcurl_try_link=no
++ fi
++
++ unset _libcurl_wanted
++ fi
++
++ if test $_libcurl_try_link = yes ; then
++
++ # we didn't find curl-config, so let's see if the user-supplied
++ # link line (or failing that, "-lcurl") is enough.
++ LIBCURL=${LIBCURL-"$_libcurl_ldflags -lcurl"}
++
++ AC_CACHE_CHECK([whether libcurl is usable],
++ [libcurl_cv_lib_curl_usable],
++ [
++ _libcurl_save_cppflags=$CPPFLAGS
++ CPPFLAGS="$LIBCURL_CPPFLAGS $CPPFLAGS"
++ _libcurl_save_libs=$LIBS
++ LIBS="$LIBCURL $LIBS"
++
++ AC_LINK_IFELSE(AC_LANG_PROGRAM([#include <curl/curl.h>],[
++/* Try and use a few common options to force a failure if we are
++ missing symbols or can't link. */
++int x;
++curl_easy_setopt(NULL,CURLOPT_URL,NULL);
++x=CURL_ERROR_SIZE;
++x=CURLOPT_WRITEFUNCTION;
++x=CURLOPT_FILE;
++x=CURLOPT_ERRORBUFFER;
++x=CURLOPT_STDERR;
++x=CURLOPT_VERBOSE;
++]),libcurl_cv_lib_curl_usable=yes,libcurl_cv_lib_curl_usable=no)
++
++ CPPFLAGS=$_libcurl_save_cppflags
++ LIBS=$_libcurl_save_libs
++ unset _libcurl_save_cppflags
++ unset _libcurl_save_libs
++ ])
++
++ if test $libcurl_cv_lib_curl_usable = yes ; then
++
++ # Does curl_free() exist in this version of libcurl?
++ # If not, fake it with free()
++
++ _libcurl_save_cppflags=$CPPFLAGS
++ CPPFLAGS="$CPPFLAGS $LIBCURL_CPPFLAGS"
++ _libcurl_save_libs=$LIBS
++ LIBS="$LIBS $LIBCURL"
++
++ AC_CHECK_FUNC(curl_free,,
++ AC_DEFINE(curl_free,free,
++ [Define curl_free() as free() if our version of curl lacks curl_free.]))
++
++ CPPFLAGS=$_libcurl_save_cppflags
++ LIBS=$_libcurl_save_libs
++ unset _libcurl_save_cppflags
++ unset _libcurl_save_libs
++
++ AC_DEFINE(HAVE_LIBCURL,1,
++ [Define to 1 if you have a functional curl library.])
++ AC_SUBST(LIBCURL_CPPFLAGS)
++ AC_SUBST(LIBCURL)
++
++ for _libcurl_feature in $_libcurl_features ; do
++ AC_DEFINE_UNQUOTED(AS_TR_CPP(libcurl_feature_$_libcurl_feature),[1])
++ eval AS_TR_SH(libcurl_feature_$_libcurl_feature)=yes
++ done
++
++ if test "x$_libcurl_protocols" = "x" ; then
++
++ # We don't have --protocols, so just assume that all
++ # protocols are available
++ _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT"
++
++ if test x$libcurl_feature_SSL = xyes ; then
++ _libcurl_protocols="$_libcurl_protocols HTTPS"
++
++ # FTPS wasn't standards-compliant until version
++ # 7.11.0
++ if test $_libcurl_version -ge 461568; then
++ _libcurl_protocols="$_libcurl_protocols FTPS"
++ fi
++ fi
++ fi
++
++ for _libcurl_protocol in $_libcurl_protocols ; do
++ AC_DEFINE_UNQUOTED(AS_TR_CPP(libcurl_protocol_$_libcurl_protocol),[1])
++ eval AS_TR_SH(libcurl_protocol_$_libcurl_protocol)=yes
++ done
++ else
++ unset LIBCURL
++ unset LIBCURL_CPPFLAGS
++ fi
++ fi
++
++ unset _libcurl_try_link
++ unset _libcurl_version_parse
++ unset _libcurl_config
++ unset _libcurl_feature
++ unset _libcurl_features
++ unset _libcurl_protocol
++ unset _libcurl_protocols
++ unset _libcurl_version
++ unset _libcurl_ldflags
++ fi
++
++ if test x$_libcurl_with = xno || test x$libcurl_cv_lib_curl_usable != xyes ; then
++ # This is the IF-NO path
++ ifelse([$4],,:,[$4])
++ else
++ # This is the IF-YES path
++ ifelse([$3],,:,[$3])
++ fi
++
++ unset _libcurl_with
++])dnl
++
++
+ dnl Check for CPPUnit
+ ifdef([AM_PATH_CPPUNIT], [AM_PATH_CPPUNIT(1.9.6, [AM_CONDITIONAL(CPPUNIT, true)], [AM_CONDITIONAL(CPPUNIT, false)])],
+ [AM_CONDITIONAL(CPPUNIT, false)])
diff --git a/recipes/linknx/linknx_0.0.1.26.bb b/recipes/linknx/linknx_0.0.1.26.bb
new file mode 100644
index 0000000000..1afde1cfd8
--- /dev/null
+++ b/recipes/linknx/linknx_0.0.1.26.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Linknx is an automation platform providing high level functionalities to EIB/KNX installation. \
+The rules engine allows execution of actions based on complex logical conditions and timers"
+HOMEPAGE = "http://linknx.sourceforge.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = " pthsem "
+DEPENDS_append_linux-uclibc = " argp-standalone"
+DEPENDS_append_linux-uclibcgnueabi = " argp-standalone"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/linknx/linknx-${PV}.tar.gz \
+ file://configure-libcurl.patch;patch=1 "
+
+inherit autotools
+
+EXTRA_OECONF = " --with-pth=yes --without-pth-test --without-mysql --without-libcurl --without-log4cpp --without-lua"
diff --git a/recipes/owfs/files/owhttpd b/recipes/owfs/files/owhttpd
new file mode 100755
index 0000000000..5d74d13d9d
--- /dev/null
+++ b/recipes/owfs/files/owhttpd
@@ -0,0 +1,60 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/bin
+
+DAEMON="owhttpd"
+
+test -f /usr/bin/${DAEMON} || exit 0
+
+if test -f /etc/default/${DAEMON} ; then
+. /etc/default/${DAEMON}
+else
+:
+fi
+
+if [ "$START_OWHTTPD" != "yes" ]
+then
+ exit 0
+fi
+
+
+startdaemon(){
+ echo -n "Starting ${DAEMON}: "
+ start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+stopdaemon(){
+ echo -n "Stopping ${DAEMON}: "
+ start-stop-daemon --stop -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+
+
+case "$1" in
+ start)
+ startdaemon
+ ;;
+ stop)
+ stopdaemon
+ ;;
+ force-reload)
+ stopdaemon
+ startdaemon
+ ;;
+ restart)
+ stopdaemon
+ startdaemon
+ ;;
+ reload)
+ stopdaemon
+ startdaemon
+ ;;
+ *)
+ echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/owfs/files/owserver b/recipes/owfs/files/owserver
new file mode 100755
index 0000000000..b69ea53e37
--- /dev/null
+++ b/recipes/owfs/files/owserver
@@ -0,0 +1,59 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/bin
+
+DAEMON="owserver"
+
+test -f /usr/bin/${DAEMON} || exit 0
+
+if test -f /etc/default/${DAEMON} ; then
+. /etc/default/${DAEMON}
+else
+:
+fi
+
+if [ "$START_OWSERVER" != "yes" ]
+then
+ exit 0
+fi
+
+startdaemon(){
+ echo -n "Starting ${DAEMON}: "
+ start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+stopdaemon(){
+ echo -n "Stopping ${DAEMON}: "
+ start-stop-daemon --stop -p /var/run/${DAEMON}.pid
+ echo "done"
+}
+
+
+
+case "$1" in
+ start)
+ startdaemon
+ ;;
+ stop)
+ stopdaemon
+ ;;
+ force-reload)
+ stopdaemon
+ startdaemon
+ ;;
+ restart)
+ stopdaemon
+ startdaemon
+ ;;
+ reload)
+ stopdaemon
+ startdaemon
+ ;;
+ *)
+ echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/owfs/owfs_2.7p21.bb b/recipes/owfs/owfs_2.7p21.bb
new file mode 100644
index 0000000000..b195054737
--- /dev/null
+++ b/recipes/owfs/owfs_2.7p21.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "1-Wire file system"
+HOMEPAGE = "http://www.owfs.org/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS += "fuse libusb"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
+ file://owhttpd \
+ file://owserver "
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = " \
+ --enable-owhttpd \
+ --enable-cache \
+ --enable-mt \
+ "
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/default/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
+ install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
+}
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
+
+DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
+DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
+DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
+DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
+DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
+DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
+DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
+DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
+DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
+
+FILES_owftpd = "${bindir}/owftpd"
+FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
+FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
+FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
+ ${bindir}/owdir ${bindir}/owpresent \
+ ${bindir}/owget ${bindir}/owside"
+FILES_owmon = "${bindir}/owmon"
+FILES_owtap = "${bindir}/owtap"
+FILES_libowcapi = "${libdir}/libowcapi-*"
+FILES_libow = "${libdir}/libow-*"
+FILES_libownet = "${libdir}/libownet-*"
+
+INITSCRIPT_PACKAGES = "owhttpd owserver"
+INITSCRIPT_NAME_owserver = "owserver"
+INITSCRIPT_NAME_owhttpd = "owhttpd"
+INITSCRIPT_PARAMS_owserver = "defaults 20"
+INITSCRIPT_PARAMS_owhttpd = "defaults 21"
diff --git a/recipes/pthsem/files/ldflags.patch b/recipes/pthsem/files/ldflags.patch
new file mode 100644
index 0000000000..74fd60b4f8
--- /dev/null
+++ b/recipes/pthsem/files/ldflags.patch
@@ -0,0 +1,16 @@
+diff -urN pth-2.0.2.orig/Makefile.in pth-2.0.2/Makefile.in
+--- pth-2.0.2.orig/Makefile.in 2004-07-13 10:48:10.000000000 +0000
++++ pth-2.0.2/Makefile.in 2009-04-06 12:12:37.000000000 +0000
+@@ -168,10 +168,10 @@
+
+ # build the static and possibly shared libraries
+ libpthsem.la: $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthsem.la $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthsem.la $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+
+ # build the manual pages
diff --git a/recipes/pthsem/pthsem_2.0.7.bb b/recipes/pthsem/pthsem_2.0.7.bb
new file mode 100644
index 0000000000..30e2f176e0
--- /dev/null
+++ b/recipes/pthsem/pthsem_2.0.7.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads replacement with semaphore support"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "https://www.auto.tuwien.ac.at/~mkoegler/pth/pthsem-${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ "
+
+inherit autotools binconfig
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+do_install_prepend() {
+ cp ${S}/pth-config ${S}/pthsem-config
+}
+do_stage() {
+ oe_libinstall -so libpthsem ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ install -m 0644 ${S}/pth.h ${STAGING_INCDIR}/pthsem.h
+ install -d ${STAGING_BINDIR}/
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/pthsem.m4
+}
+
+BINCONFIG_GLOB = "pthsem-config"
+
+PARALLEL_MAKE = ""