aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-05 09:50:05 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-10-05 22:00:31 +0200
commitb1f98e687134b54c4c1a3d52b0aa63bd66c85a17 (patch)
tree2b010a57f0c1da867b9ea3d26fe66d1544666cdf /recipes
parentda7339bf7527de9ecc86d4924eea3c834846051f (diff)
downloadopenembedded-b1f98e687134b54c4c1a3d52b0aa63bd66c85a17.tar.gz
python-pygobject: update to 2.20.0
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python-pygobject-native_2.20.0.bb18
-rw-r--r--recipes/python/python-pygobject_2.20.0.bb38
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes/python/python-pygobject-native_2.20.0.bb b/recipes/python/python-pygobject-native_2.20.0.bb
new file mode 100644
index 0000000000..ddc71d4418
--- /dev/null
+++ b/recipes/python/python-pygobject-native_2.20.0.bb
@@ -0,0 +1,18 @@
+require python-pygobject_${PV}.bb
+
+DEPENDS = "python-native glib-2.0-native"
+PR = "r0"
+
+PARALLEL_MAKE = ""
+
+inherit native
+
+SRC_URI = "\
+ ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
+# file://python-path.patch;patch=1 \
+"
+
+do_stage_append() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 gobject/generate-constants ${STAGING_BINDIR}/gobject-generate-constants
+}
diff --git a/recipes/python/python-pygobject_2.20.0.bb b/recipes/python/python-pygobject_2.20.0.bb
new file mode 100644
index 0000000000..140ba3b2f3
--- /dev/null
+++ b/recipes/python/python-pygobject_2.20.0.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "python-pygobject-native-${PV}"
+PR = "ml0"
+
+DEFAULT_PREFERENCE = "-1"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "\
+ ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
+ file://generate-constants.patch;patch=1 \
+"
+S = "${WORKDIR}/pygobject-${PV}"
+
+FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
+
+inherit autotools distutils-base pkgconfig
+
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}/../share/pygobject/
+ cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
+ install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+ cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+}
+
+PACKAGES += "${PN}-lib"
+
+FILES_${PN} = "${libdir}/python*"
+FILES_${PN}-lib = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir} ${datadir}"
+FILES_${PN}-dbg += "${libdir}/.debug"