aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-05 09:50:06 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-10-05 22:01:01 +0200
commit74f40e3fef849c83fcb7794891c705a9182580b6 (patch)
treea03216bebe649575f20881bdd0584d3550c65ac4 /recipes
parentb1f98e687134b54c4c1a3d52b0aa63bd66c85a17 (diff)
downloadopenembedded-74f40e3fef849c83fcb7794891c705a9182580b6.tar.gz
python-pygtk: update to 2.16.0
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python-pygtk/nodocs-2.16.0.patch13
-rw-r--r--recipes/python/python-pygtk_2.16.0.bb64
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/python/python-pygtk/nodocs-2.16.0.patch b/recipes/python/python-pygtk/nodocs-2.16.0.patch
new file mode 100644
index 0000000000..b19ae445ed
--- /dev/null
+++ b/recipes/python/python-pygtk/nodocs-2.16.0.patch
@@ -0,0 +1,13 @@
+Index: pygtk-2.10.4/Makefile.am
+===================================================================
+--- pygtk-2.10.4.orig/Makefile.am
++++ pygtk-2.10.4/Makefile.am
+@@ -4,7 +4,7 @@ if BUILD_GTK
+ GTK_SUBDIR = gtk
+ endif
+
+-SUBDIRS = . $(GTK_SUBDIR) examples tests docs
++SUBDIRS = . $(GTK_SUBDIR) examples tests
+
+ PLATFORM_VERSION = 2.0
+
diff --git a/recipes/python/python-pygtk_2.16.0.bb b/recipes/python/python-pygtk_2.16.0.bb
new file mode 100644
index 0000000000..939d9bef33
--- /dev/null
+++ b/recipes/python/python-pygtk_2.16.0.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "Python GTK+ 2.10.x Bindings"
+SECTION = "devel/python"
+# needs gtk+ 2.10.x
+DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
+RDEPENDS = "python-shell python-pycairo python-pygobject"
+PROVIDES = "python-pygtk2"
+SRCNAME = "pygtk"
+LICENSE = "LGPL"
+PR = "ml0"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
+ file://fix-gtkunixprint.patch;patch=1 \
+ file://prevent_to_get_display_during_import.patch;patch=1 \
+ file://nodocs-2.16.0.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+EXTRA_OECONF = "\
+ --disable-docs \
+ --with-python-includes=${STAGING_INCDIR}/../ \
+"
+
+inherit autotools pkgconfig distutils-base
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+# dirty fix #1: remove dependency on python-pygobject-dev
+do_install_append() {
+ find ${D} -name "*.la"|xargs rm -f
+ rm -f ${D}/${bindir}/pygtk-codegen-2.0
+ rm -rf ${D}/${libdir}/pkgconfig
+}
+
+# dirty fix #2: fix build system paths leaking in
+require fix-path.inc
+
+PACKAGES =+ "${PN}-demo"
+FILES_${PN}-demo = "\
+ ${bindir}/pygtk-demo \
+ ${libdir}/pygtk \
+"
+RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
+
+# todo: revamp packaging, package demo seperatly
+FILES_${PN}-dev += "\
+ ${libdir}/pygtk/2.0 \
+ ${bindir}/pygtk-* \
+ ${datadir}/pygtk/2.0"
+
+do_stage() {
+ autotools_stage_includes
+# sed -i s:/usr/share:${STAGING_DATADIR}: codegen/pygtk-codegen-2.0
+# install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
+ # until we have a newer pygobject version, we resue pygtk's codegen
+# ln -sf ./pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/pygobject-codegen-2.0
+ install -d ${STAGING_DATADIR}/pygtk/2.0/codegen
+ install -d ${STAGING_DATADIR}/pygtk/2.0/defs/
+# cp -pPr codegen/*.py* ${STAGING_DATADIR}/pygtk/2.0/codegen/
+ cp -pPr *.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
+ cp -pPr gtk/*.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
+}