aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-05-14 14:19:55 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-05-14 14:19:55 +0400
commitd4a2ec9e83d5a0da21bde9a62f36c0b1b3879262 (patch)
tree7460a79b520f6541b71ead884ea5d709c1e85162 /recipes
parentf7ee7a19617c177760e3533f2ca93673953549c4 (diff)
parent5c5e0a1bc249a49514809462e0c921a9afce2217 (diff)
downloadopenembedded-d4a2ec9e83d5a0da21bde9a62f36c0b1b3879262.tar.gz
Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/bluez/bluez4_4.39.bb64
-rw-r--r--recipes/cacao/cacao-native_0.99.4.bb3
-rw-r--r--recipes/cacao/files/cacao-disable-stackbase-check.patch12
-rw-r--r--recipes/gcc/gcc-4.3.3.inc3
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc_4.3.3.bb2
-rw-r--r--recipes/glib-2.0/glib.inc7
-rw-r--r--recipes/images/gpe-image.bb21
-rw-r--r--recipes/llvm/llvm-native.inc2
-rw-r--r--recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb (renamed from recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb)5
-rw-r--r--recipes/llvm/llvm2.6/fix-build.patch11
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch29
-rw-r--r--recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch14
-rw-r--r--recipes/llvm/llvm2.6_2.5+svnr20090511.bb (renamed from recipes/llvm/llvm2.6_2.5+svnr20090504.bb)6
-rw-r--r--recipes/psplash/files/topas910/psplash-default2
-rw-r--r--recipes/psplash/psplash.inc2
-rw-r--r--recipes/udev/udev_141.bb38
-rw-r--r--recipes/xserver-common/xserver-common_1.24.bb16
-rw-r--r--recipes/xserver-kdrive-common/xserver-kdrive-common/98xTs_Calibrate (renamed from recipes/xserver-kdrive-common/xserver-kdrive-common/30xTs_Calibrate)0
-rw-r--r--recipes/xserver-kdrive-common/xserver-kdrive-common_0.1.bb2
21 files changed, 177 insertions, 66 deletions
diff --git a/recipes/bluez/bluez4_4.39.bb b/recipes/bluez/bluez4_4.39.bb
new file mode 100644
index 0000000000..c28f260761
--- /dev/null
+++ b/recipes/bluez/bluez4_4.39.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
+ file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"
diff --git a/recipes/cacao/cacao-native_0.99.4.bb b/recipes/cacao/cacao-native_0.99.4.bb
index 1b996ffbcc..1e09e3ddec 100644
--- a/recipes/cacao/cacao-native_0.99.4.bb
+++ b/recipes/cacao/cacao-native_0.99.4.bb
@@ -1,4 +1,5 @@
-# Do not use this on amd64 hosts yet!
+# 0.99.4 appears to be broken on amd64 and i386 :(
+DEFAULT_PREFERENCE = "-1"
require cacao-native.inc
diff --git a/recipes/cacao/files/cacao-disable-stackbase-check.patch b/recipes/cacao/files/cacao-disable-stackbase-check.patch
new file mode 100644
index 0000000000..8eb20894d4
--- /dev/null
+++ b/recipes/cacao/files/cacao-disable-stackbase-check.patch
@@ -0,0 +1,12 @@
+Index: cacao-0.99.3+hg20090109/src/mm/boehm-gc/os_dep.c
+===================================================================
+--- cacao-0.99.3+hg20090109.orig/src/mm/boehm-gc/os_dep.c 2009-02-15 16:29:15.000000000 +0100
++++ cacao-0.99.3+hg20090109/src/mm/boehm-gc/os_dep.c 2009-02-15 16:29:24.000000000 +0100
+@@ -1077,7 +1077,6 @@
+ c = stat_buf[buf_offset++];
+ }
+ close(f);
+- if (result < 0x10000000) ABORT("Absurd stack bottom value");
+ return (ptr_t)result;
+ }
+
diff --git a/recipes/gcc/gcc-4.3.3.inc b/recipes/gcc/gcc-4.3.3.inc
index 45cf3a231f..3e6c0979ce 100644
--- a/recipes/gcc/gcc-4.3.3.inc
+++ b/recipes/gcc/gcc-4.3.3.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r3"
+
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
file://fedora/gcc43-ia64-libunwind.patch;patch=1;pnum=0 \
@@ -65,6 +67,7 @@ SRC_URI_append_sh4 = " file://sh_unwind.patch;patch=1 \
"
# Language Overrides
FORTRAN = ""
+FORTRAN_linux-gnueabi = ",fortran"
JAVA = ""
EXTRA_OECONF_BASE = " --enable-cheaders=c_std --enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.3.bb b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
index 7e3a459ea8..27a7ae0a7f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross_4.3.3.bb b/recipes/gcc/gcc-cross_4.3.3.bb
index 87b3ba5381..5eb6b5fbe8 100644
--- a/recipes/gcc/gcc-cross_4.3.3.bb
+++ b/recipes/gcc/gcc-cross_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
diff --git a/recipes/gcc/gcc_4.3.3.bb b/recipes/gcc/gcc_4.3.3.bb
index 83ebff7c80..9d58858faf 100644
--- a/recipes/gcc/gcc_4.3.3.bb
+++ b/recipes/gcc/gcc_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "${INC_PR}.1"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
diff --git a/recipes/glib-2.0/glib.inc b/recipes/glib-2.0/glib.inc
index b328cfad4d..e035d20d69 100644
--- a/recipes/glib-2.0/glib.inc
+++ b/recipes/glib-2.0/glib.inc
@@ -22,9 +22,12 @@ FILES_gobject-2.0 = "${libdir}/libgobject-2.0.so.*"
FILES_gio-2.0 = "${libdir}/libgio-2.0.so.*"
FILES_gthread-2.0 = "${libdir}/libgthread-2.0.so.*"
-# Let the gthread library end up in glib package
-# for compatibility.
+# Let various glib components end up in glib package
+# for compatibility (with binary packages from Maemo).
FILES_gthread-2.0_chinook-compat = ""
+FILES_gmodule-2.0_chinook-compat = ""
+FILES_gobject-2.0_chinook-compat = ""
+FILES_gio-2.0_chinook-compat = ""
EXTRA_OECONF = "--disable-debug "
diff --git a/recipes/images/gpe-image.bb b/recipes/images/gpe-image.bb
index 8cbe8a8571..768cc6bcae 100644
--- a/recipes/images/gpe-image.bb
+++ b/recipes/images/gpe-image.bb
@@ -1,10 +1,21 @@
+LICENSE = "MIT"
+
+# Set some defaults
+
+MACHINE_TASK_PROVIDER = "task-base-extended"
+GUI_MACHINE_CLASS ?= "none"
+XSERVER ?= "xserver-kdrive-fbdev"
GPE_EXTRA_THEMES = "gpe-theme-industrial"
+# Select bootsplash
+SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
+
+# Select some useful things depending on the device capabilities
+
GPE_EXTRA_INSTALL_none = ""
GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
-GUI_MACHINE_CLASS ?= "none"
GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
#ship more stuff with devices with >16MB of flash
@@ -16,10 +27,10 @@ GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
-XSERVER ?= "xserver-kdrive-fbdev"
DEPENDS = "${MACHINE_TASK_PROVIDER} \
- task-gpe-base \
+ ${SPLASH} \
+ task-gpe-base \
task-gpe-apps \
task-gpe-pim \
task-gpe-settings \
@@ -33,8 +44,10 @@ IMAGE_INSTALL = "\
task-gpe-settings \
task-gpe-apps \
${XSERVER} \
+ ${SPLASH} \
${GPE_EXTRA_INSTALL}"
-#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "demo", "set_image_autologin; ", "",d)}'
inherit image
diff --git a/recipes/llvm/llvm-native.inc b/recipes/llvm/llvm-native.inc
index a7d7fa3830..ab1ce56000 100644
--- a/recipes/llvm/llvm-native.inc
+++ b/recipes/llvm/llvm-native.inc
@@ -1,6 +1,6 @@
require llvm.inc
-DEPENDS = "llvm-common-native"
+DEPENDS = "llvm-common-native cmake-native"
inherit native
diff --git a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb
index 86397c9920..de94d08021 100644
--- a/recipes/llvm/llvm2.6-native_2.5+svnr20090504.bb
+++ b/recipes/llvm/llvm2.6-native_2.5+svnr20090511.bb
@@ -1,15 +1,14 @@
require llvm-native.inc
-SRCREV = "70854"
+SRCREV = "71428"
-PV = "2.5+svnr${SRCREV}"
+PV = "2.5+svnr${SRCPV}"
PR = "r0"
SRC_URI = "\
svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
file://fix-build.patch;patch=1 \
- file://llvm-enable-threads-macro.patch;patch=1;pnum=0 \
file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
"
diff --git a/recipes/llvm/llvm2.6/fix-build.patch b/recipes/llvm/llvm2.6/fix-build.patch
index 553965608a..fe7a8e4a97 100644
--- a/recipes/llvm/llvm2.6/fix-build.patch
+++ b/recipes/llvm/llvm2.6/fix-build.patch
@@ -1,13 +1,24 @@
+<<<<<<< HEAD:recipes/llvm/llvm2.6/fix-build.patch
Index: tools/llvm-config/CMakeLists.txt
===================================================================
--- a/tools.orig/llvm-config/CMakeLists.txt 2009-04-09 10:45:01.000000000 +0200
+++ b/tools/llvm-config/CMakeLists.txt 2009-04-09 10:43:52.000000000 +0200
+=======
+Index: trunk/tools/llvm-config/CMakeLists.txt
+===================================================================
+--- trunk.orig/tools/llvm-config/CMakeLists.txt 2009-04-10 11:56:56.000000000 +0200
++++ trunk/tools/llvm-config/CMakeLists.txt 2009-04-10 12:21:19.000000000 +0200
+>>>>>>> New recipes by Xerxes Ranby (xerxes@zafena.se):recipes/llvm/llvm2.6/fix-build.patch
@@ -90,7 +90,7 @@
add_custom_command(OUTPUT ${LLVM_CONFIG}
COMMAND echo 's!@LLVM_CPPFLAGS@!${CPP_FLGS}!' > temp.sed
COMMAND echo 's!@LLVM_CFLAGS@!${C_FLGS}!' >> temp.sed
- COMMAND echo 's!@LLVM_CXXFLAGS@!${CXX_FLGS}!' >> temp.sed
+<<<<<<< HEAD:recipes/llvm/llvm2.6/fix-build.patch
+ COMMAND echo 's!@LLVM_CXXFLAGS@!${CXX_FLGS} -fpermissive -fvisibility-inlines-hidden!' >> temp.sed
+=======
++ COMMAND echo 's!@LLVM_CXXFLAGS@!${CXX_FLGS} -fpermissive -fvisibility-inlines-hidden -Woverloaded-virtual!' >> temp.sed
+>>>>>>> New recipes by Xerxes Ranby (xerxes@zafena.se):recipes/llvm/llvm2.6/fix-build.patch
# TODO: Use general flags for linking! not just for shared libs:
COMMAND echo 's!@LLVM_LDFLAGS@!${CMAKE_SHARED_LINKER_FLAGS}!' >> temp.sed
COMMAND echo 's!@LIBS@!!' >> temp.sed # TODO: System libs
diff --git a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch b/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
deleted file mode 100644
index f1072d9af9..0000000000
--- a/recipes/llvm/llvm2.6/llvm-fix-have_libpthread.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: trunk/include/llvm/Config/config.h.cmake
-===================================================================
---- trunk.orig/include/llvm/Config/config.h.cmake 2009-05-06 16:39:19.957841609 +0200
-+++ trunk/include/llvm/Config/config.h.cmake 2009-05-06 16:39:20.185842055 +0200
-@@ -194,7 +194,7 @@
- #cmakedefine HAVE_LIBPSAPI ${HAVE_LIBPSAPI}
-
- /* Define to 1 if you have the `pthread' library (-lpthread). */
--#undef HAVE_LIBPTHREAD
-+#cmakedefine HAVE_LIBPTHREAD ${HAVE_LIBPTHREAD}
-
- /* Define to 1 if you have the `udis86' library (-ludis86). */
- #undef HAVE_LIBUDIS86
-Index: trunk/cmake/config-ix.cmake
-===================================================================
---- trunk.orig/cmake/config-ix.cmake 2009-05-06 16:49:45.121841057 +0200
-+++ trunk/cmake/config-ix.cmake 2009-05-06 16:50:25.738552620 +0200
-@@ -98,6 +98,11 @@
- if( HAVE_PTHREAD_H OR WIN32 )
- set(ENABLE_THREADS 1)
- endif()
-+
-+# FIXME: Actually check for the library
-+ if( HAVE_PTHREAD_H )
-+ set(HAVE_LIBPTHREAD 1)
-+ endif()
- endif()
-
- if( ENABLE_THREADS )
diff --git a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch b/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
deleted file mode 100644
index 6f17b850f6..0000000000
--- a/recipes/llvm/llvm2.6/llvm-fix-pthreads_h.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: include/llvm/Config/config.h.cmake
-===================================================================
---- include/llvm/Config/config.h.cmake (Revision 71077)
-+++ include/llvm/Config/config.h.cmake (Arbeitskopie)
-@@ -276,6 +276,9 @@
- /* Define to have the %a format string */
- #undef HAVE_PRINTF_A
-
-+/* Have pthread.h */
-+#cmakedefine HAVE_PTHREAD_H ${HAVE_PTHREAD_H}
-+
- /* Have pthread_mutex_lock */
- #cmakedefine HAVE_PTHREAD_MUTEX_LOCK ${HAVE_PTHREAD_MUTEX_LOCK}
-
diff --git a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb b/recipes/llvm/llvm2.6_2.5+svnr20090511.bb
index 9ba13ceadc..58cb7c7268 100644
--- a/recipes/llvm/llvm2.6_2.5+svnr20090504.bb
+++ b/recipes/llvm/llvm2.6_2.5+svnr20090511.bb
@@ -1,8 +1,8 @@
require llvm.inc
-SRCREV = "70854"
+SRCREV = "71428"
-PV = "2.5+svnr${SRCREV}"
+PV = "2.5+svnr${SRCPV}"
PR = "r0"
@@ -12,8 +12,6 @@ SRC_URI = "\
svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
file://fix-build.patch;patch=1 \
file://llvm-debugonly-zeroormore.patch;patch=1;pnum=0 \
- file://llvm-fix-pthreads_h.patch;patch=1;pnum=0 \
- file://llvm-fix-have_libpthread.patch;patch=1 \
"
S = "${WORKDIR}/trunk"
diff --git a/recipes/psplash/files/topas910/psplash-default b/recipes/psplash/files/topas910/psplash-default
new file mode 100644
index 0000000000..2a29658f0c
--- /dev/null
+++ b/recipes/psplash/files/topas910/psplash-default
@@ -0,0 +1,2 @@
+# Parameters to pass to psplash
+PARAMS=" -a 270"
diff --git a/recipes/psplash/psplash.inc b/recipes/psplash/psplash.inc
index a038f63f1c..c1634de8c2 100644
--- a/recipes/psplash/psplash.inc
+++ b/recipes/psplash/psplash.inc
@@ -8,7 +8,7 @@ RPROVIDES_${PN} = "virtual/psplash"
RCONFLICTS_${PN} = "exquisite"
PV = "0.0+svnr${SRCREV}"
-PR = "r20"
+PR = "r21"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index 242558bbf4..2368cb9880 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -1,23 +1,45 @@
DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
/dev/, handles hotplug events and loads drivers at boot time. It replaces \
the hotplug package and requires a kernel not older than 2.6.12."
-RPROVIDES_${PN} = "hotplug"
+LICENSE = "GPL"
-# Untested, fails to creat shared libs
+# Untested, fails to create shared libs
DEFAULT_PREFERENCE = "-1"
+PR = "r1"
+
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://mount.blacklist \
file://run.rules \
"
+SRC_URI += " \
+ file://udev.rules \
+ file://devfs-udev.rules \
+ file://links.conf \
+ file://permissions.rules \
+ file://mount.sh \
+ file://network.sh \
+ file://local.rules \
+ file://init"
SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
PACKAGE_ARCH_h2200 = "h2200"
-require udev.inc
+inherit update-rc.d autotools_stage
+INITSCRIPT_NAME = "udev"
INITSCRIPT_PARAMS = "start 03 S ."
+PACKAGES =+ "udev-utils libvolume-id libvolume-id-dev"
+
+FILES_libvolume-id-dev = "${includedir}/libvolume_id.h ${libdir}/libvolume_id.a ${libdir}/libvolume_id.so ${libdir}/pkgconfig/libvolume_id.pc"
+FILES_udev-utils = "${usrbindir}/udevinfo ${sbindir}/udevadm ${usrbindir}/udevtest"
+FILES_libvolume-id = "${base_libdir}/libvolume_id.so.*"
+
+RPROVIDES_${PN} = "hotplug"
+FILES_${PN} += "${usrbindir}/* ${usrsbindir}/udevd"
+FILES_${PN}-dbg += "${usrbindir}/.debug ${usrsbindir}/.debug"
+
FILES_${PN} += "${base_libdir}/udev/*"
FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
@@ -51,3 +73,13 @@ do_install () {
do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+
+
+do_stage_append() {
+ install -m 0644 ${S}/extras/volume_id/lib/libvolume_id.h ${STAGING_INCDIR}
+ oe_libinstall -C extras/volume_id/lib -so libvolume_id ${STAGING_LIBDIR}
+}
+
+
+
+
diff --git a/recipes/xserver-common/xserver-common_1.24.bb b/recipes/xserver-common/xserver-common_1.24.bb
new file mode 100644
index 0000000000..a30a37c893
--- /dev/null
+++ b/recipes/xserver-common/xserver-common_1.24.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh "
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}
diff --git a/recipes/xserver-kdrive-common/xserver-kdrive-common/30xTs_Calibrate b/recipes/xserver-kdrive-common/xserver-kdrive-common/98xTs_Calibrate
index 70786908b6..70786908b6 100644
--- a/recipes/xserver-kdrive-common/xserver-kdrive-common/30xTs_Calibrate
+++ b/recipes/xserver-kdrive-common/xserver-kdrive-common/98xTs_Calibrate
diff --git a/recipes/xserver-kdrive-common/xserver-kdrive-common_0.1.bb b/recipes/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
index abd7191863..33c0a401e4 100644
--- a/recipes/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
+++ b/recipes/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Common X11 scripts"
LICENSE = "GPL"
SECTION = "x11"
-PR = "r37"
+PR = "r38"
SRC_URI = "\
file://Xdefaults \