aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-10-15 10:46:24 +0200
committerKoen Kooi <koen@openembedded.org>2010-10-15 10:48:08 +0200
commitc9ac99f13f603d15e9a852916cc4daa4a4d210bc (patch)
treea61c07ecdf1e00063ab80cada96f9e63c58ae941 /recipes
parentaeb537c64e8942582cce784686ae5cdd01b92199 (diff)
downloadopenembedded-c9ac99f13f603d15e9a852916cc4daa4a4d210bc.tar.gz
python-pygobject: forcefully disable introspection
It will pick up the .pc from the native sysroot and then fail to build since we don't have target introspection libs to link against
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python-pygobject_2.20.0.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes/python/python-pygobject_2.20.0.bb b/recipes/python/python-pygobject_2.20.0.bb
index 157fa9fabe..adc17e7663 100644
--- a/recipes/python/python-pygobject_2.20.0.bb
+++ b/recipes/python/python-pygobject_2.20.0.bb
@@ -4,7 +4,7 @@ LICENSE = "LGPL"
DEPENDS = "libffi python-pygobject-native-${PV}"
PE = "1"
-PR = "r1"
+PR = "r2"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
@@ -20,7 +20,10 @@ inherit autotools distutils-base pkgconfig
export BUILD_SYS
export HOST_SYS
-export GOBJECT_INTROSPECTION_CFLAGS="-pthread -I${STAGING_INCDIR}/gobject-introspection-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
+# It picks up the introspection pc for the host sysroot without a knob to disable it, so force it to false
+do_configure_prepend() {
+ sed -i 's:have_gobject_introspection=true:have_gobject_introspection=false:g' configure.ac
+}
do_install_append() {
install -d ${D}${datadir}/pygobject/