aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-17 14:11:06 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-17 14:11:06 +0200
commitb945c7446b2134bf69f42909b1e8b23e3fd8bbfe (patch)
tree31eac510b5ffe777e88c981204a83bcf5128ed22 /recipes
parent19f35a34bc1c98e684b96306b377d230e367c49f (diff)
parent35e7b34d3b5b96ed11bc7ed6b2a5d08e6183d8a3 (diff)
downloadopenembedded-b945c7446b2134bf69f42909b1e8b23e3fd8bbfe.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/base-files/base-files_3.0.14.bb4
-rw-r--r--recipes/busybox/busybox.inc6
-rw-r--r--recipes/busybox/files/simple.script72
-rw-r--r--recipes/fbprogress/fbprogress_1.1.bb19
-rw-r--r--recipes/kakasi/kakasi-native_2.3.4.bb2
-rwxr-xr-xrecipes/sysvinit/sysvinit/rcS3
-rw-r--r--recipes/sysvinit/sysvinit_2.86.bb2
-rw-r--r--recipes/udev/udev_141.bb4
-rw-r--r--recipes/uim/uim-native_1.3.1.bb2
9 files changed, 94 insertions, 20 deletions
diff --git a/recipes/base-files/base-files_3.0.14.bb b/recipes/base-files/base-files_3.0.14.bb
index c974dd9cee..5e78797e2a 100644
--- a/recipes/base-files/base-files_3.0.14.bb
+++ b/recipes/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Miscellaneous files for the base system."
SECTION = "base"
PRIORITY = "required"
-PR = "r87"
+PR = "r88"
LICENSE = "GPL"
SRC_URI = " \
@@ -46,7 +46,7 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
/media/union /media/realroot /media/hdd \
/media/mmc1"
-dirs755_micro = "/dev /proc ${sysconfdir}"
+dirs755_micro = "/dev /proc /sys ${sysconfdir}"
dirs2775_micro = ""
dirs1777_micro = "/tmp"
diff --git a/recipes/busybox/busybox.inc b/recipes/busybox/busybox.inc
index 7b9b92940f..0ff65a41bc 100644
--- a/recipes/busybox/busybox.inc
+++ b/recipes/busybox/busybox.inc
@@ -11,14 +11,14 @@ LICENSE = "GPL"
SECTION = "base"
PRIORITY = "required"
-INC_PR = "r21"
+INC_PR = "r22"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \
- file://default.script \
+ file://default.script file://simple.script \
file://dhcp-hostname.patch;patch=1 \
file://hwclock.sh \
file://ifupdown-spurious-environ.patch;patch=1 \
@@ -120,7 +120,7 @@ do_install () {
if grep "CONFIG_APP_UDHCPC=y" ${WORKDIR}/defconfig; then
install -d ${D}${sysconfdir}/udhcpc.d
install -d ${D}${datadir}/udhcpc
- install -m 0755 ${S}/examples/udhcp/simple.script ${D}${sysconfdir}/udhcpc.d/50default
+ install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
fi
if grep "CONFIG_FEATURE_MOUNT_FSTAB=y" ${WORKDIR}/defconfig; then
diff --git a/recipes/busybox/files/simple.script b/recipes/busybox/files/simple.script
new file mode 100644
index 0000000000..5cc21b9de2
--- /dev/null
+++ b/recipes/busybox/files/simple.script
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# udhcpc script edited by Tim Riker <Tim@Rikers.org>
+
+[ -z "$1" ] && echo "Error: should be called from udhcpc" && exit 1
+
+RESOLV_CONF="/etc/resolv.conf"
+[ -n "$broadcast" ] && BROADCAST="broadcast $broadcast"
+[ -n "$subnet" ] && NETMASK="netmask $subnet"
+
+# return 0 if root is mounted on a network filesystem
+root_is_nfs() {
+ grep -qe '^/dev/root.*\(nfs\|smbfs\|ncp\|coda\) .*' /proc/mounts
+}
+
+have_bin_ip=0
+if [ -x /bin/ip ]; then
+ have_bin_ip=1
+fi
+
+case "$1" in
+ deconfig)
+ if ! root_is_nfs ; then
+ if [ $have_bin_ip -eq 1 ]; then
+ ip addr flush dev $interface
+ ip link set dev $interface up
+ else
+ /sbin/ifconfig $interface 0.0.0.0
+ fi
+ fi
+ ;;
+
+ renew|bound)
+ if [ $have_bin_ip -eq 1 ]; then
+ ip addr add dev $interface local $ip/$mask $BROADCAST
+ else
+ /sbin/ifconfig $interface $ip $BROADCAST $NETMASK
+ fi
+
+ if [ -n "$router" ] ; then
+ if ! root_is_nfs ; then
+ if [ $have_bin_ip -eq 1 ]; then
+ while ip route del default 2>/dev/null ; do
+ :
+ done
+ else
+ while route del default gw 0.0.0.0 dev $interface 2>/dev/null ; do
+ :
+ done
+ fi
+ fi
+
+ metric=0
+ for i in $router ; do
+ if [ $have_bin_ip -eq 1 ]; then
+ ip route add default via $i metric $((metric++))
+ else
+ route add default gw $i dev $interface metric $((metric++)) 2>/dev/null
+ fi
+ done
+ fi
+
+ echo -n > $RESOLV_CONF
+ [ -n "$domain" ] && echo search $domain >> $RESOLV_CONF
+ for i in $dns ; do
+ echo adding dns $i
+ echo nameserver $i >> $RESOLV_CONF
+ done
+ ;;
+esac
+
+exit 0
diff --git a/recipes/fbprogress/fbprogress_1.1.bb b/recipes/fbprogress/fbprogress_1.1.bb
index 8d603b8a3e..855d1ca3d4 100644
--- a/recipes/fbprogress/fbprogress_1.1.bb
+++ b/recipes/fbprogress/fbprogress_1.1.bb
@@ -3,8 +3,8 @@ AUTHOR = "Angel Roman"
HOMEPAGE = "http://www.buglabs.net/"
LICENSE = "GPL"
DEPENDS = "freetype zlib virtual/kernel"
-SRCREV = "9118"
-PR = "r1"
+SRCREV = "9405"
+PR = "r2"
SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
file://fbprogress-init"
@@ -13,14 +13,17 @@ S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
inherit update-rc.d
-EXTRA_OEMAKE = "BUG_LINUX_SRC=${STAGING_KERNEL_DIR}"
+TARGET_CXXFLAGS += "-I${STAGING_INCDIR}/freetype2 -I${STAGING_KERNEL_DIR}/include"
+TARGET_LDFLAGS += "-L${STAGING_LIBDIR} -lfreetype -lz"
do_install() {
- install -d ${D}/${sysconfdir}/fbprogress
- install -m 0644 ${S}/images/* ${D}/${sysconfdir}/fbprogress/
- install -d ${D}${layout_bindir}
- install -m 0755 fbprogress ${D}${layout_bindir}
- install -m 0755 fbprogress.sh ${D}${layout_bindir}
+ install -d ${D}/${datadir}/fbprogress
+ install -m 0644 ${S}/images/* ${D}/${datadir}/fbprogress/
+
+ install -d ${D}${bindir}
+ install -m 0755 fbprogress ${D}${bindir}
+ install -m 0755 fbprogress.sh ${D}${bindir}
+
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
}
diff --git a/recipes/kakasi/kakasi-native_2.3.4.bb b/recipes/kakasi/kakasi-native_2.3.4.bb
index 86a4c81b44..18f0061cfe 100644
--- a/recipes/kakasi/kakasi-native_2.3.4.bb
+++ b/recipes/kakasi/kakasi-native_2.3.4.bb
@@ -2,8 +2,6 @@ require kakasi.inc
inherit native
-S = "${WORKDIR}/kakasi-${PV}"
-
do_stage() {
install src/mkkanwa ${STAGING_BINDIR}
}
diff --git a/recipes/sysvinit/sysvinit/rcS b/recipes/sysvinit/sysvinit/rcS
index e1c8b57ea1..15b90f79c5 100755
--- a/recipes/sysvinit/sysvinit/rcS
+++ b/recipes/sysvinit/sysvinit/rcS
@@ -16,6 +16,9 @@ export PATH runlevel prevlevel
#
[ -d "/proc/1" ] || mount proc /proc -t proc
+# Make sure sys is mounted
+[ -d "/sys/kernel" ] || mount sysfs /sys -t sysfs
+
#
# See if system needs to be setup. This is ONLY meant to
# be used for the initial setup after a fresh installation!
diff --git a/recipes/sysvinit/sysvinit_2.86.bb b/recipes/sysvinit/sysvinit_2.86.bb
index b62a4087bc..e546726ab9 100644
--- a/recipes/sysvinit/sysvinit_2.86.bb
+++ b/recipes/sysvinit/sysvinit_2.86.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
SECTION = "base"
LICENSE = "GPL"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r56"
+PR = "r57"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index 44e6b4db96..3f4256470f 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -6,10 +6,10 @@ LICENSE = "GPL"
# Untested
DEFAULT_PREFERENCE = "-1"
-PR = "r10"
+PR = "r11"
# needed for init.d script
-RDEPENDS_udev += "udev-utils"
+RDEPENDS_${PN} += "udev-utils"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://mount.blacklist \
diff --git a/recipes/uim/uim-native_1.3.1.bb b/recipes/uim/uim-native_1.3.1.bb
index f23f6bd945..3404a36ab5 100644
--- a/recipes/uim/uim-native_1.3.1.bb
+++ b/recipes/uim/uim-native_1.3.1.bb
@@ -3,6 +3,4 @@ DEPENDS = "gtk+ anthy intltool-native"
inherit native autotools pkgconfig
PR = "r2"
-S = "${WORKDIR}/uim-${PV}"
-
EXTRA_OECONF += "--disable-xim"