aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-26 12:02:50 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-26 12:02:50 +0000
commita0f489917f06bf417eb4bf7be9f221d28a79e6c8 (patch)
tree71aa003df62ef645bd0aa35c2e8ba7f4947cb7b1 /recipes
parentb1caa21ab2590689f3b6ff68483803701c12d721 (diff)
parente9344af0f0ead4ff7a926e84b08f819b23cc3d64 (diff)
downloadopenembedded-a0f489917f06bf417eb4bf7be9f221d28a79e6c8.tar.gz
Merge branch 'org.openembedded.dev' of git+ssh://git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-2.6.30/mx27ads/defconfig16
-rwxr-xr-xrecipes/linux/linux-rp-2.6.23/hx2750-make.patch77
-rw-r--r--recipes/linux/linux-rp_2.6.23.bb1
3 files changed, 92 insertions, 2 deletions
diff --git a/recipes/linux/linux-2.6.30/mx27ads/defconfig b/recipes/linux/linux-2.6.30/mx27ads/defconfig
index 600655a683..9a6607edb7 100644
--- a/recipes/linux/linux-2.6.30/mx27ads/defconfig
+++ b/recipes/linux/linux-2.6.30/mx27ads/defconfig
@@ -394,7 +394,10 @@ CONFIG_MTD=y
# CONFIG_MTD_CONCAT is not set
CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_TESTS is not set
-# CONFIG_MTD_REDBOOT_PARTS is not set
+CONFIG_MTD_REDBOOT_PARTS=y
+CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
+# CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED is not set
+# CONFIG_MTD_REDBOOT_PARTS_READONLY is not set
CONFIG_MTD_CMDLINE_PARTS=y
# CONFIG_MTD_AFS_PARTS is not set
# CONFIG_MTD_AR7_PARTS is not set
@@ -460,7 +463,16 @@ CONFIG_MTD_PHYSMAP=y
# CONFIG_MTD_DOC2000 is not set
# CONFIG_MTD_DOC2001 is not set
# CONFIG_MTD_DOC2001PLUS is not set
-# CONFIG_MTD_NAND is not set
+CONFIG_MTD_NAND=y
+# CONFIG_MTD_NAND_VERIFY_WRITE is not set
+# CONFIG_MTD_NAND_ECC_SMC is not set
+# CONFIG_MTD_NAND_MUSEUM_IDS is not set
+# CONFIG_MTD_NAND_GPIO is not set
+CONFIG_MTD_NAND_IDS=y
+# CONFIG_MTD_NAND_DISKONCHIP is not set
+# CONFIG_MTD_NAND_NANDSIM is not set
+# CONFIG_MTD_NAND_PLATFORM is not set
+CONFIG_MTD_NAND_MXC=y
# CONFIG_MTD_ONENAND is not set
#
diff --git a/recipes/linux/linux-rp-2.6.23/hx2750-make.patch b/recipes/linux/linux-rp-2.6.23/hx2750-make.patch
new file mode 100755
index 0000000000..c40d725a4e
--- /dev/null
+++ b/recipes/linux/linux-rp-2.6.23/hx2750-make.patch
@@ -0,0 +1,77 @@
+Index: linux-2.6.23/arch/arm/mach-pxa/hx2750.c
+===================================================================
+--- linux-2.6.23.orig/arch/arm/mach-pxa/hx2750.c 2009-08-12 10:37:26.000000000 -0400
++++ linux-2.6.23/arch/arm/mach-pxa/hx2750.c 2009-08-12 10:38:53.000000000 -0400
+@@ -443,7 +443,7 @@
+ .io_pg_offst = (io_p2v(0x40000000) >> 18) & 0xfffc,
+ .boot_params = 0xa0000100,
+ .map_io = pxa_map_io,
+- .init_irq = pxa_init_irq,
++ .init_irq = pxa27x_init_irq,
+ .timer = &pxa_timer,
+ .init_machine = hx2750_init,
+ MACHINE_END
+Index: linux-2.6.23/arch/arm/mach-pxa/hx2750_test.c
+===================================================================
+--- linux-2.6.23.orig/arch/arm/mach-pxa/hx2750_test.c 2009-08-12 10:37:26.000000000 -0400
++++ linux-2.6.23/arch/arm/mach-pxa/hx2750_test.c 2009-08-12 10:40:35.000000000 -0400
+@@ -203,14 +203,15 @@
+
+ static DEVICE_ATTR(ssp2write, 0200, NULL, ssp2write_store);
+
+-+static ssize_t sspr_store(struct device *dev, struct device_attribute *attr, const char *buf, size_t count)
++static ssize_t sspr_store(struct device *dev, struct device_attribute *attr, const char *buf, size_t count)
+ {
+- unsigned long val,ret;
++ unsigned long val;
++ int ret;
+ val = simple_strtoul(buf, NULL, 0);
+
+ hx2750_tsc2101_send(1<<15,val,&ret,1);
+
+- printk("Response: %lx\n",ret);
++ printk("Response: %x\n",ret);
+
+ return count;
+ }
+@@ -219,8 +220,9 @@
+
+ static ssize_t sspw_store(struct device *dev, struct device_attribute *attr, const char *buf, size_t count)
+ {
+- unsigned long val,ret;
+- sscanf(buf, "%lx %lx", &val, &ret);
++ unsigned long val;
++ int ret;
++ sscanf(buf, "%lx %x", &val, &ret);
+
+ hx2750_tsc2101_send(0,val,&ret,1);
+
+@@ -336,10 +338,10 @@
+ }
+
+ static struct pm_ops hx2750_pm_ops = {
+- .pm_disk_mode = PM_DISK_FIRMWARE,
+- .prepare = pxa_pm_prepare,
++ /* .pm_disk_mode = PM_DISK_FIRMWARE, ** not sure why this element doesn't exist anymore and what replaced it ** */
++ /* .prepare = pxa_pm_prepare, */
+ .enter = hx2750_pxa_pm_enter,
+- .finish = pxa_pm_finish,
++ /* .finish = pxa_pm_finish, */
+ };
+
+
+Index: linux-2.6.23/include/asm/arch/hx2750.h
+===================================================================
+--- linux-2.6.23.orig/include/asm/arch/hx2750.h 2009-08-12 10:42:15.000000000 -0400
++++ linux-2.6.23/include/asm/arch/hx2750.h 2009-08-12 10:42:24.000000000 -0400
+@@ -85,6 +85,10 @@
+ void hx2750_set_egpio(unsigned int gpio);
+ void hx2750_clear_egpio(unsigned int gpio);
+
++/* for _test.c */
++void hx2750_ssp_init2(void);
++void hx2750_tsc2101_send(int read, int command, int *values, int numval);
++
+
+ #endif /* __ASM_ARCH_HX2750_H */
+
diff --git a/recipes/linux/linux-rp_2.6.23.bb b/recipes/linux/linux-rp_2.6.23.bb
index 460ac53012..e45006a938 100644
--- a/recipes/linux/linux-rp_2.6.23.bb
+++ b/recipes/linux/linux-rp_2.6.23.bb
@@ -28,6 +28,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
${RPSRC}/hx2750_base-r29.patch;patch=1 \
${RPSRC}/hx2750_bl-r9.patch;patch=1 \
${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
+ ${RPSRC}/hx2750_make.patch;patch=1 \
${RPSRC}/pxa_keys-r7.patch;patch=1 \
${RPSRC}/tsc2101-r16.patch;patch=1 \
${RPSRC}/hx2750_test1-r7.patch;patch=1 \