aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-27 15:04:18 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-27 15:04:18 +0000
commit9d4b913b6d0941cc12ed8853915d40ca2dd6be69 (patch)
treece475b3421ca1e231f7a5d50f57834418ea63d34 /recipes
parent6b7b58d2a25169ab2e1ff80266a15bc7543ebe15 (diff)
parent680d0be4e8e9363e8186f1a0efe79c02bc0aefc9 (diff)
downloadopenembedded-9d4b913b6d0941cc12ed8853915d40ca2dd6be69.tar.gz
Merge branch 'org.openembedded.dev' of git+ssh://git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/boost/boost-36.inc3
-rw-r--r--recipes/gstreamer/gst-plugins-good_0.10.17.bb4
-rw-r--r--recipes/obexpush/obexpush_1.0.0.bb4
-rw-r--r--recipes/powertop/files/omap-svn.patch242
-rw-r--r--recipes/powertop/powertop_svn.bb18
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch95
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb/omapfb-neon.diff146
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb_git.bb5
8 files changed, 268 insertions, 249 deletions
diff --git a/recipes/boost/boost-36.inc b/recipes/boost/boost-36.inc
index cac9f91b98..8641193967 100644
--- a/recipes/boost/boost-36.inc
+++ b/recipes/boost/boost-36.inc
@@ -9,7 +9,7 @@ SECTION = "libs"
DEPENDS = "boost-jam-native zlib"
PRIORITY = "optional"
LICENSE = "Boost Software License"
-INC_PR = "r8"
+INC_PR = "r9"
ARM_INSTRUCTION_SET = "arm"
BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
@@ -70,6 +70,7 @@ FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
# "boost" is a metapackage which pulls in all boost librabries
PACKAGES += "${PN}"
RRECOMMENDS_${PN} += "${BOOST_PACKAGES}"
+ALLOW_EMPTY = "1"
# to avoid GNU_HASH QA errors added LDFLAGS to ARCH; a little bit dirty but at least it works
TARGET_CC_ARCH += " ${LDFLAGS}"
diff --git a/recipes/gstreamer/gst-plugins-good_0.10.17.bb b/recipes/gstreamer/gst-plugins-good_0.10.17.bb
index 78191f9715..1bcb05556e 100644
--- a/recipes/gstreamer/gst-plugins-good_0.10.17.bb
+++ b/recipes/gstreamer/gst-plugins-good_0.10.17.bb
@@ -3,11 +3,11 @@ require gst-plugins.inc
SRC_URI += "file://flvdemux-ecma.diff;patch=1 \
"
-PR = "r1"
+PR = "r2"
inherit gconf
-DEPENDS += "libsoup-2.4 flac gst-plugins-base openssl popt esound"
+DEPENDS += "hal pulseaudio speex libsoup-2.4 flac gst-plugins-base openssl popt esound"
PACKAGES =+ "gst-plugin-gconfelements"
FILES_gst-plugin-gconfelements += "${sysconfdir}/gconf"
diff --git a/recipes/obexpush/obexpush_1.0.0.bb b/recipes/obexpush/obexpush_1.0.0.bb
index 4de4cbe98f..59ec835d6d 100644
--- a/recipes/obexpush/obexpush_1.0.0.bb
+++ b/recipes/obexpush/obexpush_1.0.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.caside.lancs.ac.uk/java_bt.php"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "glib-2.0 openobex bluez-libs"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
file://add-obextool.patch;patch=1 \
@@ -16,7 +16,7 @@ inherit update-rc.d
INITSCRIPT_NAME = "opd"
INITSCRIPT_PARAMS = "defaults 33 9"
-export GLIBINC = "-I${STAGING_INCDIR}/glib-2.0"
+export GLIBINC = "-I${STAGING_INCDIR}/glib-2.0 -I${STAGING_LIBDIR}/glib-2.0/include"
export GLIBLIB = "-I${STAGING_LIBDIR} -lglib-2.0"
export OBEXINC = "-I${STAGING_INCDIR}"
export OBEXLIB = "${LDFLAGS} -lopenobex"
diff --git a/recipes/powertop/files/omap-svn.patch b/recipes/powertop/files/omap-svn.patch
new file mode 100644
index 0000000000..1b961617bf
--- /dev/null
+++ b/recipes/powertop/files/omap-svn.patch
@@ -0,0 +1,242 @@
+From 8000c07da38b5d0a5571542fa04abd63939e698c Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 27 Jan 2010 08:58:42 +0100
+Subject: [PATCH] powertop: add support for TI OMAP cstates
+
+* based on a TI patch found in a wiki, rediffed against svn
+---
+ Makefile | 2 +-
+ cpufreqstats.c | 2 +-
+ display.c | 17 ++++++++------
+ omapcstates.c | 65 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ powertop.c | 12 +++++++--
+ powertop.h | 18 +++++++++++++-
+ 6 files changed, 102 insertions(+), 14 deletions(-)
+ create mode 100644 omapcstates.c
+
+diff --git a/Makefile b/Makefile
+index 68a0cb7..05f73aa 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,7 +16,7 @@ CC?=gcc
+ #
+
+ OBJS = powertop.o config.o process.o misctips.o bluetooth.o display.o suggestions.o wireless.o cpufreq.o \
+- sata.o xrandr.o ethernet.o cpufreqstats.o usb.o urbnum.o intelcstates.o wifi-new.o
++ sata.o xrandr.o ethernet.o cpufreqstats.o usb.o urbnum.o intelcstates.o omapcstates.o wifi-new.o
+
+
+ powertop: $(OBJS) Makefile powertop.h
+diff --git a/cpufreqstats.c b/cpufreqstats.c
+index 7529037..a101362 100644
+--- a/cpufreqstats.c
++++ b/cpufreqstats.c
+@@ -42,7 +42,7 @@ struct cpufreqdata oldfreqs[16];
+
+ struct cpufreqdata delta[16];
+
+-char cpufreqstrings[6][80];
++char cpufreqstrings[MAX_NUM_PSTATES][80];
+ int topfreq = -1;
+
+ static void zap(void)
+diff --git a/display.c b/display.c
+index 3ae27d6..3547ad1 100644
+--- a/display.c
++++ b/display.c
+@@ -91,15 +91,18 @@ int maxwidth = 200;
+
+ void setup_windows(void)
+ {
++ int yline = MAX_NUM_CSTATES;
++
+ getmaxyx(stdscr, maxy, maxx);
+
+ zap_windows();
+
+ title_bar_window = subwin(stdscr, 1, maxx, 0, 0);
+- cstate_window = subwin(stdscr, 7, maxx, 2, 0);
+- wakeup_window = subwin(stdscr, 1, maxx, 9, 0);
+- battery_power_window = subwin(stdscr, 2, maxx, 10, 0);
+- timerstat_window = subwin(stdscr, maxy-16, maxx, 12, 0);
++
++ cstate_window = subwin(stdscr, (yline + 2), maxx, 2, 0);
++ wakeup_window = subwin(stdscr, 1, maxx, (yline + 5), 0);
++ battery_power_window = subwin(stdscr, 2, maxx, (yline + 6), 0);
++ timerstat_window = subwin(stdscr, maxy-16, maxx, (yline + 8), 0);
+ maxtimerstats = maxy-16 -2;
+ maxwidth = maxx - 18;
+ suggestion_window = subwin(stdscr, 3, maxx, maxy-4, 0);
+@@ -166,18 +169,18 @@ void show_cstates(void)
+ int i, count = 0;
+ werase(cstate_window);
+
+- for (i=0; i < 10; i++) {
++ for (i=0; i < MAX_CSTATE_LINES; i++) {
+ if (i == topcstate+1)
+ wattron(cstate_window, A_BOLD);
+ else
+ wattroff(cstate_window, A_BOLD);
+- if (strlen(cstate_lines[i]) && count <= 6) {
++ if (strlen(cstate_lines[i]) && count <= MAX_CSTATE_LINES) {
+ print(cstate_window, count, 0, "%s", cstate_lines[i]);
+ count++;
+ }
+ }
+
+- for (i=0; i<6; i++) {
++ for (i=0; i<MAX_NUM_PSTATES; i++) {
+ if (i == topfreq+1)
+ wattron(cstate_window, A_BOLD);
+ else
+diff --git a/omapcstates.c b/omapcstates.c
+new file mode 100644
+index 0000000..b062449
+--- /dev/null
++++ b/omapcstates.c
+@@ -0,0 +1,65 @@
++/*
++ * * Copyright 2008, Texas Instruments Incorporated.
++ * *
++ * * This file prints the C states supported by the OMAP processor.
++ * * (Based on intelcstates.c)
++ * *
++ * * This program file is free software; you can redistribute it and/or modify it
++ * * under the terms of the GNU General Public License as published by the
++ * * Free Software Foundation; version 2 of the License.
++ * *
++ * * This program is distributed in the hope that it will be useful, but WITHOUT
++ * * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
++ * * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
++ * * for more details.
++ * *
++ * * You should have received a copy of the GNU General Public License
++ * * along with this program in a file named COPYING; if not, write to the
++ * * Free Software Foundation, Inc.,
++ * * 51 Franklin Street, Fifth Floor,
++ * * Boston, MA 02110-1301 USA
++ * */
++
++#include <unistd.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <stdint.h>
++#include <sys/types.h>
++#include <dirent.h>
++#include <ctype.h>
++
++#include "powertop.h"
++
++
++#if defined(OMAP3)
++/**
++ * * print_omap3_cstates() - Prints the list of supported C-states.
++ * *
++ * * This functions uses standard sysfs interface of the cpuidle framework
++ * * to extract the information of the C-states supported by the Linux
++ * * kernel.
++ * **/
++void print_omap3_cstates(void)
++{
++ DIR *dir;
++ struct dirent *entry;
++
++ dir = opendir("/sys/devices/system/cpu/cpu0/cpuidle");
++
++ if (dir) {
++ printf(_("Supported C-states : "));
++
++ while ((entry = readdir(dir))) {
++ if (strlen(entry->d_name) < 3)
++ continue;
++
++ printf("C%s ", entry->d_name);
++ }
++ printf("\n");
++
++ closedir(dir);
++ }
++}
++#endif
++
+diff --git a/powertop.c b/powertop.c
+index 1a81cb4..92b6157 100644
+--- a/powertop.c
++++ b/powertop.c
+@@ -813,7 +813,7 @@ void print_battery_sysfs(void)
+ show_acpi_power_line(rate, cap, prev_bat_cap - cap, time(NULL) - prev_bat_time);
+ }
+
+-char cstate_lines[12][200];
++char cstate_lines[MAX_CSTATE_LINES][200];
+
+ void usage()
+ {
+@@ -955,7 +955,7 @@ int main(int argc, char **argv)
+ }
+
+ memset(&cstate_lines, 0, sizeof(cstate_lines));
+- topcstate = -4;
++ topcstate = -(MAX_NUM_CSTATES);
+ if (totalevents == 0 && maxcstate <= 1) {
+ sprintf(cstate_lines[5],_("< Detailed C-state information is not available.>\n"));
+ } else {
+@@ -969,7 +969,7 @@ int main(int argc, char **argv)
+ sprintf(cstate_lines[1], _("C0 (cpu running) (%4.1f%%)\n"), percentage);
+ if (percentage > 50)
+ topcstate = 0;
+- for (i = 0; i < 8; i++)
++ for (i = 0; i < MAX_NUM_CSTATES; i++)
+ if (cur_usage[i]) {
+ sleept = (cur_duration[i] - last_duration[i]) / (cur_usage[i] - last_usage[i]
+ + 0.1) / FREQ;
+@@ -1236,3 +1236,9 @@ int main(int argc, char **argv)
+
+ return 0;
+ }
++
++#if defined (__I386__)
++ print_intel_cstates();
++#elif defined (OMAP3)
++ print_omap3_cstates();
++#endif
+diff --git a/powertop.h b/powertop.h
+index 8732ce9..a281183 100644
+--- a/powertop.h
++++ b/powertop.h
+@@ -30,6 +30,20 @@
+
+ #define VERSION "1.12"
+
++#if defined(__I386__)
++#define MAX_NUM_CSTATES 4
++#define MAX_NUM_PSTATES 5
++
++#elif defined(OMAP3)
++#define MAX_NUM_CSTATES 7
++#define MAX_NUM_PSTATES 5
++
++#else
++#error "No valid architecture is defined."
++#endif
++
++#define MAX_CSTATE_LINES (MAX_NUM_CSTATES + 3)
++
+ struct line {
+ char *string;
+ int count;
+@@ -67,8 +81,8 @@ void usb_activity_hint(void);
+
+
+
+-extern char cstate_lines[12][200];
+-extern char cpufreqstrings[6][80];
++extern char cstate_lines[MAX_CSTATE_LINES][200];
++extern char cpufreqstrings[MAX_NUM_PSTATES][80];
+
+ extern int topcstate;
+ extern int topfreq;
+--
+1.6.5
+
diff --git a/recipes/powertop/powertop_svn.bb b/recipes/powertop/powertop_svn.bb
new file mode 100644
index 0000000000..793035baa1
--- /dev/null
+++ b/recipes/powertop/powertop_svn.bb
@@ -0,0 +1,18 @@
+require powertop.inc
+
+SRCREV = "332"
+PV = "1.12+svnr${SRCPV}"
+PR = "${INC_PR}.0"
+
+SRC_URI = "svn://powertop.googlecode.com/svn;module=trunk;proto=http"
+SRC_URI_append_omap3 = " file://omap-svn.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+CFLAGS_append_omap3 = " -DOMAP3"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
diff --git a/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch b/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch
deleted file mode 100644
index 0786539061..0000000000
--- a/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 8dba6751950f65292c5f8a562e282045e9fe0803 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Tue, 22 Dec 2009 21:35:00 +0100
-Subject: [PATCH 1/2] omapfb-driver: hack out dpms for xorg 1.7.x
-
----
- src/omapfb-driver.c | 41 -----------------------------------------
- 1 files changed, 0 insertions(+), 41 deletions(-)
-
-diff --git a/src/omapfb-driver.c b/src/omapfb-driver.c
-index a9d5fbc..ffa0df4 100644
---- a/src/omapfb-driver.c
-+++ b/src/omapfb-driver.c
-@@ -41,9 +41,6 @@
-
- #include "exa.h"
-
--#define DPMS_SERVER
--#include <X11/extensions/dpms.h>
--
- #include <linux/fb.h>
-
- /* TODO: we'd like this to come from kernel headers, but that's not a good
-@@ -502,7 +499,6 @@ OMAPFBScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
-
- /* Load the fallback module */
- xf86LoadSubModule(pScrn, "fb");
-- xf86LoaderReqSymLists(fbSymbols, NULL);
-
- /* Initialize fallbacks for the screen */
- if (!fbScreenInit(pScreen, ofb->fb, pScrn->virtualX,
-@@ -580,13 +576,9 @@ OMAPFBScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
- /* NO-OP currently */
- pScreen->SaveScreen = OMAPFBSaveScreen;
-
-- /* Setup DPMS support */
-- xf86DPMSInit(pScreen, OMAPFBDPMSSet, 0);
--
- #ifdef USE_EXA
- /* EXA init */
- xf86LoadSubModule(pScrn, "exa");
-- xf86LoaderReqSymLists(exaSymbols, NULL);
-
- /* TODO: This should depend on the AccelMethod option */
- ofb->exa = exaDriverAlloc();
-@@ -723,38 +715,6 @@ static Bool OMAPFBSwitchMode(int scrnIndex, DisplayModePtr mode, int flags)
- return TRUE;
- }
-
--static void
--OMAPFBDPMSSet(ScrnInfoPtr pScrn, int mode, int flags)
--{
-- OMAPFBPtr ofb = OMAPFB(pScrn);
--
-- switch (mode) {
-- case DPMSModeOn:
-- if (ioctl(ofb->fd, FBIOBLANK, (void *)VESA_NO_BLANKING)) {
-- xf86DrvMsg(pScrn->scrnIndex, X_ERROR,
-- "FBIOBLANK: %s\n", strerror(errno));
-- }
-- break;
-- case DPMSModeStandby:
-- case DPMSModeSuspend:
-- /* TODO: Maybe we would want to use the above modes for
-- * dimming the LCD? That'd match the functionality
-- * (save power)
-- */
-- case DPMSModeOff:
-- /* OMAPFB only supports on and off */
-- if (ioctl(ofb->fd, FBIOBLANK, (void *)VESA_POWERDOWN)) {
-- xf86DrvMsg(pScrn->scrnIndex, X_ERROR,
-- "FBIOBLANK: %s\n", strerror(errno));
-- }
-- break;
-- break;
-- default:
-- return;
-- }
--
--}
--
- void
- OMAPFBPrintCapabilities(ScrnInfoPtr pScrn,
- struct omapfb_caps *caps,
-@@ -879,7 +839,6 @@ OMAPFBSetup(pointer module, pointer opts, int *errmaj, int *errmin)
- if (!setupDone) {
- setupDone = TRUE;
- xf86AddDriver(&OMAPFB, module, HaveDriverFuncs);
-- LoaderRefSymLists(fbSymbols, NULL);
- return (pointer)1;
- } else {
- if (errmaj) *errmaj = LDR_ONCEONLY;
---
-1.6.5
-
diff --git a/recipes/xorg-driver/xf86-video-omapfb/omapfb-neon.diff b/recipes/xorg-driver/xf86-video-omapfb/omapfb-neon.diff
deleted file mode 100644
index 325ca66f0c..0000000000
--- a/recipes/xorg-driver/xf86-video-omapfb/omapfb-neon.diff
+++ /dev/null
@@ -1,146 +0,0 @@
---- /tmp/image-format-conversions.h 2009-02-03 10:18:04.000000000 +0100
-+++ git/src/image-format-conversions.h 2009-02-03 10:19:18.000000000 +0100
-@@ -30,6 +30,8 @@
- /* Basic C implementation of YV12/I420 to UYVY conversion */
- void uv12_to_uyvy(int w, int h, int y_pitch, int uv_pitch, uint8_t *y_p, uint8_t *u_p, uint8_t *v_p, uint8_t *dest);
-
-+/* NEON implementation of YV12/I420 to UYVY conversion */
-+void uv12_to_uyvy_neon(int w, int h, int y_pitch, int uv_pitch, uint8_t *y_p, uint8_t *u_p, uint8_t *v_p, uint8_t *dest);
-
- #endif /* __IMAGE_FORMAT_CONVERSIONS_H__ */
-
---- /tmp/image-format-conversions.c 2009-02-03 10:18:04.000000000 +0100
-+++ git/src/image-format-conversions.c 2009-02-03 10:16:47.000000000 +0100
-@@ -2,6 +2,7 @@
- * Copyright 2008 Kalle Vahlman, <zuh@iki.fi>
- * Ilpo Ruotsalainen, <lonewolf@iki.fi>
- * Tuomas Kulve, <tuomas.kulve@movial.com>
-+ * Ian Rickards, <ian.rickards@arm.com>
- *
- *
- * Permission to use, copy, modify, distribute and sell this software and its
-@@ -89,3 +90,104 @@
- }
- }
-
-+void uv12_to_uyvy_neon(int w, int h, int y_pitch, int uv_pitch, uint8_t *y_p, uint8_t *u_p, uint8_t *v_p, uint8_t *dest)
-+{
-+ int x, y;
-+ uint8_t *dest_even = dest;
-+ uint8_t *dest_odd = dest + w * 2;
-+ uint8_t *y_p_even = y_p;
-+ uint8_t *y_p_odd = y_p + y_pitch;
-+
-+ /*ErrorF("in uv12_to_uyvy, w: %d, pitch: %d\n", w, pitch);*/
-+ if (w<16)
-+ {
-+ for (y=0; y<h; y+=2)
-+ {
-+ for (x=0; x<w; x+=2)
-+ {
-+ /* Output two 2x1 macroblocks to form a 2x2 block from input */
-+ uint8_t u_val = *u_p++;
-+ uint8_t v_val = *v_p++;
-+
-+ /* Even row, first pixel */
-+ *dest_even++ = u_val;
-+ *dest_even++ = *y_p_even++;
-+
-+ /* Even row, second pixel */
-+ *dest_even++ = v_val;
-+ *dest_even++ = *y_p_even++;
-+
-+ /* Odd row, first pixel */
-+ *dest_odd++ = u_val;
-+ *dest_odd++ = *y_p_odd++;
-+
-+ /* Odd row, second pixel */
-+ *dest_odd++ = v_val;
-+ *dest_odd++ = *y_p_odd++;
-+ }
-+
-+ dest_even += w * 2;
-+ dest_odd += w * 2;
-+
-+ u_p += ((uv_pitch << 1) - w) >> 1;
-+ v_p += ((uv_pitch << 1) - w) >> 1;
-+
-+ y_p_even += (y_pitch - w) + y_pitch;
-+ y_p_odd += (y_pitch - w) + y_pitch;
-+ }
-+ }
-+ else
-+ {
-+ for (y=0; y<h; y+=2)
-+ {
-+ x=w;
-+ do {
-+ // avoid using d8-d15 (q4-q7) aapcs callee-save registers
-+ asm volatile (
-+ "1:\n\t"
-+ "vld1.u8 {d0}, [%[u_p]]!\n\t"
-+ "sub %[x],%[x],#16\n\t"
-+ "cmp %[x],#16\n\t"
-+ "vld1.u8 {d1}, [%[v_p]]!\n\t"
-+ "vld1.u8 {q1}, [%[y_p_even]]!\n\t"
-+ "vzip.u8 d0, d1\n\t"
-+ "vld1.u8 {q2}, [%[y_p_odd]]!\n\t"
-+ // use 2-element struct stores to zip up y with y&v
-+ "vst2.u8 {q0,q1}, [%[dest_even]]!\n\t"
-+ "vmov.u8 q1, q2\n\t"
-+ "vst2.u8 {q0,q1}, [%[dest_odd]]!\n\t"
-+ "bhs 1b\n\t"
-+ : [u_p] "+r" (u_p), [v_p] "+r" (v_p), [y_p_even] "+r" (y_p_even), [y_p_odd] "+r" (y_p_odd),
-+ [dest_even] "+r" (dest_even), [dest_odd] "+r" (dest_odd),
-+ [x] "+r" (x)
-+ :
-+ : "cc", "memory", "d0","d1","d2","d3","d4","d5"
-+ );
-+ if (x!=0)
-+ {
-+ // overlap final 16-pixel block to process requested width exactly
-+ x = 16-x;
-+ u_p -= x/2;
-+ v_p -= x/2;
-+ y_p_even -= x;
-+ y_p_odd -= x;
-+ dest_even -= x*2;
-+ dest_odd -= x*2;
-+ x = 16;
-+ // do another 16-pixel block
-+ }
-+ }
-+ while (x!=0);
-+
-+ dest_even += w * 2;
-+ dest_odd += w * 2;
-+
-+ u_p += ((uv_pitch << 1) - w) >> 1;
-+ v_p += ((uv_pitch << 1) - w) >> 1;
-+
-+ y_p_even += (y_pitch - w) + y_pitch;
-+ y_p_odd += (y_pitch - w) + y_pitch;
-+ }
-+ }
-+}
-+
---- /tmp/omapfb-xv-generic.c 2009-02-03 10:52:18.000000000 +0100
-+++ git/src/omapfb-xv-generic.c 2009-02-03 10:52:24.000000000 +0100
-@@ -240,7 +240,7 @@
- uint8_t *yb = buf;
- uint8_t *ub = yb + (src_y_pitch * src_h);
- uint8_t *vb = ub + (src_uv_pitch * (src_h / 2));
-- uv12_to_uyvy(src_w & ~15,
-+ uv12_to_uyvy_neon(src_w & ~15,
- src_h & ~15,
- src_y_pitch,
- src_uv_pitch,
-@@ -256,7 +256,7 @@
- uint8_t *yb = buf;
- uint8_t *vb = yb + (src_y_pitch * src_h);
- uint8_t *ub = vb + (src_uv_pitch * (src_h / 2));
-- uv12_to_uyvy(src_w & ~15,
-+ uv12_to_uyvy_neon(src_w & ~15,
- src_h & ~15,
- src_y_pitch,
- src_uv_pitch,
diff --git a/recipes/xorg-driver/xf86-video-omapfb_git.bb b/recipes/xorg-driver/xf86-video-omapfb_git.bb
index 609693a77e..53301042bd 100644
--- a/recipes/xorg-driver/xf86-video-omapfb_git.bb
+++ b/recipes/xorg-driver/xf86-video-omapfb_git.bb
@@ -2,14 +2,13 @@ require xorg-driver-video.inc
DESCRIPTION = "X.Org X server -- OMAP display driver"
-PR_append = "c"
+PR_append = "d"
-SRCREV = "5317aae587a2bf48f07a8c06bfaf7bcbfd23bafc"
+SRCREV = "2ae9a57ebc3236cd0aec6534067b91a5c6916a3a"
PV = "0.1.1+${PR}+gitr${SRCREV}"
PE = "1"
SRC_URI = "git://git.pingu.fi/xf86-video-omapfb.git;protocol=http \
-file://0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch;patch=1 \
"
S = "${WORKDIR}/git"