aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2010-03-22 22:25:05 +0300
committerSergey Lapin <slapin@ossfans.org>2010-03-22 22:25:05 +0300
commit2a04d3897d8c9f6410914d6d95331543d1061830 (patch)
treeeefc623a11cae9f0fa96326f776e826a70f56a8a /recipes
parent12784ca2ec5786be5303773874431f2464187a16 (diff)
parent9e35f0c735a1c680d16ef20a9ccdf876ccaad69e (diff)
downloadopenembedded-2a04d3897d8c9f6410914d6d95331543d1061830.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/arptables/arptables-0.0.3-4/arptables-compile-install.patch61
-rw-r--r--recipes/arptables/arptables-0.0.3-4/arptables-init-busybox.patch77
-rw-r--r--recipes/arptables/arptables_0.0.3-4.bb22
-rw-r--r--recipes/bridge-utils/bridge-utils.inc8
-rw-r--r--recipes/bridge-utils/files/ifupdown.sh245
-rw-r--r--recipes/conntrack-tools/conntrack-tools_0.9.14.bb24
-rw-r--r--recipes/conntrack-tools/files/conntrack-failover77
-rw-r--r--recipes/conntrack-tools/files/init77
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.6.bb2
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.8.bb2
-rw-r--r--recipes/gdb/gdb-cross-sdk_7.0.bb2
-rw-r--r--recipes/gdb/gdb-cross.inc2
-rw-r--r--recipes/gdb/gdb.inc2
-rw-r--r--recipes/libnetfilter/libnetfilter-conntrack_0.0.101.bb11
-rw-r--r--recipes/libnetfilter/libnetfilter-queue.inc (renamed from recipes/libnetfilter-queue/libnetfilter-queue.inc)0
-rw-r--r--recipes/libnetfilter/libnetfilter-queue_0.0.13.bb (renamed from recipes/libnetfilter-queue/libnetfilter-queue_0.0.13.bb)0
-rw-r--r--recipes/libnetfilter/libnetfilter-queue_0.0.16.bb (renamed from recipes/libnetfilter-queue/libnetfilter-queue_0.0.16.bb)0
-rw-r--r--recipes/libnfnetlink/libnfnetlink.inc15
-rw-r--r--recipes/libnfnetlink/libnfnetlink_0.0.30.bb22
-rw-r--r--recipes/libnfnetlink/libnfnetlink_0.0.39.bb26
-rw-r--r--recipes/libnfnetlink/libnfnetlink_1.0.0.bb6
-rw-r--r--recipes/u-boot/u-boot-mkimage-native_1.3.2.bb2
-rw-r--r--recipes/u-boot/u-boot.inc2
-rw-r--r--recipes/u-boot/u-boot_git.bb21
-rw-r--r--recipes/vim/vim.inc4
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/omapzoom36x/xorg.conf29
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
27 files changed, 686 insertions, 55 deletions
diff --git a/recipes/arptables/arptables-0.0.3-4/arptables-compile-install.patch b/recipes/arptables/arptables-0.0.3-4/arptables-compile-install.patch
new file mode 100644
index 0000000000..80e9804724
--- /dev/null
+++ b/recipes/arptables/arptables-0.0.3-4/arptables-compile-install.patch
@@ -0,0 +1,61 @@
+Index: arptables-v0.0.3-4/Makefile
+===================================================================
+--- arptables-v0.0.3-4.orig/Makefile 2010-03-08 18:49:28.000000000 +0300
++++ arptables-v0.0.3-4/Makefile 2010-03-22 15:52:56.000000000 +0300
+@@ -6,12 +6,11 @@
+ LIBDIR:=$(PREFIX)/lib
+ BINDIR:=$(PREFIX)/sbin
+ MANDIR:=$(PREFIX)/man
+-INITDIR:=/etc/rc.d/init.d
++INITDIR:=/etc/init.d
+ SYSCONFIGDIR:=/etc/sysconfig
+ DESTDIR:=
+
+-COPT_FLAGS:=-O2
+-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\" #-g -DDEBUG #-pg # -DARPTC_DEBUG
++ARPCFLAGS:=-Wall -Wunused -I$(KERNEL_DIR)/include/ -Iinclude/ -DARPTABLES_VERSION=\"$(ARPTABLES_VERSION)\"
+
+ ifndef ARPT_LIBDIR
+ ARPT_LIBDIR:=$(LIBDIR)/arptables
+@@ -22,16 +21,16 @@
+ all: arptables
+
+ arptables.o: arptables.c
+- $(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
+
+ arptables-standalone.o: arptables-standalone.c
+- $(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
+
+ libarptc/libarptc.o: libarptc/libarptc.c libarptc/libarptc_incl.c
+- $(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(ARPCFLAGS) -c -o $@ $<
+
+ arptables: arptables-standalone.o arptables.o libarptc/libarptc.o $(EXT_OBJS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) $(CFLAGS) $(ARPCFLAGS) -o $@ $^
+
+ $(DESTDIR)$(MANDIR)/man8/arptables.8: arptables.8
+ mkdir -p $(@D)
+@@ -50,6 +49,7 @@
+ cat arptables-restore | sed 's/__EXEC_PATH__/$(tmp1)/g' > arptables-restore_
+ install -m 0755 -o root -g root arptables-restore_ $(DESTDIR)$(BINDIR)/arptables-restore
+ cat arptables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > arptables.sysv_
++ install -d $(DESTDIR)$(INITDIR)
+ if test -d $(DESTDIR)$(INITDIR); then install -m 0755 -o root -g root arptables.sysv_ $(DESTDIR)$(INITDIR)/arptables; fi
+ rm -f arptables-save_ arptables-restore_ arptables.sysv_
+
+Index: arptables-v0.0.3-4/extensions/Makefile
+===================================================================
+--- arptables-v0.0.3-4.orig/extensions/Makefile 2010-03-08 18:49:28.000000000 +0300
++++ arptables-v0.0.3-4/extensions/Makefile 2010-03-22 15:52:38.000000000 +0300
+@@ -4,4 +4,7 @@
+ EXT_OBJS+=$(foreach T,$(EXT_FUNC), extensions/arpt_$(T).o)
+
+ extensions/ebt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
+- $(CC) $(CFLAGS) $(PROGSPECS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
++
++extensions/arpt_%.o: extensions/arpt_%.c include/arptables.h include/arptables_common.h
++ $(CC) $(CFLAGS) $(ARPCFLAGS) $(PROGSPECS) -c -o $@ $<
diff --git a/recipes/arptables/arptables-0.0.3-4/arptables-init-busybox.patch b/recipes/arptables/arptables-0.0.3-4/arptables-init-busybox.patch
new file mode 100644
index 0000000000..24956c4ca9
--- /dev/null
+++ b/recipes/arptables/arptables-0.0.3-4/arptables-init-busybox.patch
@@ -0,0 +1,77 @@
+Index: arptables-v0.0.3-4/arptables.sysv
+===================================================================
+--- arptables-v0.0.3-4.orig/arptables.sysv 2010-03-22 16:28:03.000000000 +0300
++++ arptables-v0.0.3-4/arptables.sysv 2010-03-22 16:27:51.000000000 +0300
+@@ -12,10 +12,10 @@
+ # config: __SYSCONFIG__/arptables
+
+ source /etc/init.d/functions
+-source /etc/sysconfig/network
++# source /etc/sysconfig/network
+
+ # Check that networking is up.
+-[ ${NETWORKING} = "no" ] && exit 0
++# [ ${NETWORKING} = "no" ] && exit 0
+
+ [ -x __EXEC_PATH__/arptables ] || exit 1
+ [ -x __EXEC_PATH__/arptables-save ] || exit 1
+@@ -28,32 +28,30 @@
+ desc="Arp filtering"
+
+ start() {
+- echo -n $"Starting $desc ($prog): "
++ echo -n "Starting $desc ($prog): "
+ __EXEC_PATH__/arptables-restore < __SYSCONFIG__/arptables || RETVAL=1
+
+ if [ $RETVAL -eq 0 ]; then
+- success "$prog startup"
+- rm -f /var/lock/subsys/$prog
++ echo "$prog ok"
++ touch /var/lock/subsys/$prog
+ else
+- failure "$prog startup"
++ echo "$prog failed"
+ fi
+
+- echo
+ return $RETVAL
+ }
+
+ stop() {
+- echo -n $"Stopping $desc ($prog): "
++ echo -n "Stopping $desc ($prog): "
+ __EXEC_PATH__/arptables-restore < /dev/null || RETVAL=1
+
+ if [ $RETVAL -eq 0 ]; then
+- success "$prog shutdown"
+- rm -f %{_localstatedir}/lock/subsys/$prog
++ echo "$prog stopped"
++ rm -f /var/lock/subsys/$prog
+ else
+- failure "$prog shutdown"
++ echo "$prog failed to stop"
+ fi
+
+- echo
+ return $RETVAL
+ }
+
+@@ -63,15 +61,14 @@
+ }
+
+ save() {
+- echo -n $"Saving $desc ($prog): "
++ echo -n "Saving $desc ($prog): "
+ __EXEC_PATH__/arptables-save > __SYSCONFIG__/arptables || RETVAL=1
+
+ if [ $RETVAL -eq 0 ]; then
+- success "$prog saved"
++ echo "$prog saved"
+ else
+- failure "$prog saved"
++ echo "$prog is not saved"
+ fi
+- echo
+ }
+
+ case "$1" in
diff --git a/recipes/arptables/arptables_0.0.3-4.bb b/recipes/arptables/arptables_0.0.3-4.bb
new file mode 100644
index 0000000000..ccf3e6d39d
--- /dev/null
+++ b/recipes/arptables/arptables_0.0.3-4.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Administration tool for arp packet filtering"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SECTION = "console/network"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \
+ file://arptables-compile-install.patch;patch=1 \
+ file://arptables-init-busybox.patch;patch=1 \
+ "
+SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
+SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
+
+S = "${WORKDIR}/arptables-v${PV}"
+
+do_compile () {
+ oe_runmake
+}
+
+fakeroot do_install () {
+ oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
+}
diff --git a/recipes/bridge-utils/bridge-utils.inc b/recipes/bridge-utils/bridge-utils.inc
index ba4d5827d8..a4ccf07558 100644
--- a/recipes/bridge-utils/bridge-utils.inc
+++ b/recipes/bridge-utils/bridge-utils.inc
@@ -5,7 +5,7 @@ LICENSE = "GPL"
DEPENDS = "sysfsutils"
RRECOMMENDS = "kernel-module-bridge"
-SRC_URI = "${SOURCEFORGE_MIRROR}/bridge/bridge-utils-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/bridge/bridge-utils-${PV}.tar.gz file://ifupdown.sh"
inherit autotools
@@ -13,6 +13,12 @@ EXTRA_OECONF = "--with-linux-headers=${STAGING_INCDIR}"
do_install_append () {
mv ${D}${sbindir}/brctl ${D}${sbindir}/brctl.${PN}
+ install -d ${D}/${datadir}/bridge-utils
+ install -d ${D}/${sysconfdir}/network/if-pre-up.d
+ install -d ${D}/${sysconfdir}/network/if-post-down.d
+ install -m 0755 ${WORKDIR}/ifupdown.sh ${D}/${datadir}/bridge-utils/
+ ln -s ${datadir}/bridge-utils/ifupdown.sh ${D}/${sysconfdir}/network/if-pre-up.d/bridge
+ ln -s ${datadir}/bridge-utils/ifupdown.sh ${D}/${sysconfdir}/network/if-post-down.d/bridge
}
pkg_postinst_${PN} () {
diff --git a/recipes/bridge-utils/files/ifupdown.sh b/recipes/bridge-utils/files/ifupdown.sh
new file mode 100644
index 0000000000..a67ffcc1e3
--- /dev/null
+++ b/recipes/bridge-utils/files/ifupdown.sh
@@ -0,0 +1,245 @@
+#!/bin/sh
+
+# You don't usually need to touch this file at all, the full configuration
+# of the bridge can be done in a standard way on /etc/network/interfaces.
+
+# Have a look at /usr/share/doc/bridge-utils/README.Debian if you want
+# more info about the way on wich a bridge is set up on Debian.
+
+if [ ! -x /usr/sbin/brctl ]
+then
+ exit 0
+fi
+
+case "$IF_BRIDGE_PORTS" in
+ "")
+ exit 0
+ ;;
+ none)
+ INTERFACES=""
+ ;;
+ *)
+ INTERFACES="$IF_BRIDGE_PORTS"
+ ;;
+esac
+
+# Previous work (create the interface)
+if [ "$MODE" = "start" ] ; then
+ brctl addbr $IFACE || exit 1
+# Wait for the ports to become available
+ if [ "$IF_BRIDGE_WAITPORT" ]
+ then
+ set x $IF_BRIDGE_WAITPORT &&
+ shift &&
+ WAIT="$1" &&
+ shift &&
+ WAITPORT="$@" &&
+ if [ -z "$WAITPORT" ];then WAITPORT="$IF_BRIDGE_PORTS";fi &&
+ STARTTIME=$(date +%s) &&
+ NOTFOUND="true" &&
+ /bin/echo -e "\nWaiting for a max of $WAIT seconds for $WAITPORT to become available." &&
+ while [ "$(($(date +%s)-$STARTTIME))" -le "$WAIT" ] && [ -n "$NOTFOUND" ]
+ do
+ NOTFOUND=""
+ for i in $WAITPORT
+ do
+ if ! grep -q "^[\ ]*$i:.*$" /proc/net/dev;then NOTFOUND="true";fi
+ done
+ if [ -n "$NOTFOUND" ];then sleep 1;fi
+ done
+ fi
+# Previous work (stop the interface)
+elif [ "$MODE" = "stop" ]; then
+ ifconfig $IFACE down || exit 1
+fi
+
+all_interfaces= &&
+unset all_interfaces &&
+set x $INTERFACES &&
+shift &&
+while [ x"${1+set}" = xset ]
+do
+ # For compatibility: the `all' option.
+ case $1 in
+ all)
+ shift &&
+ set regex eth.\* noregex "$@"
+ ;;
+ esac
+
+ # Primitive state machine...
+ case $1-`uname -s` in
+ regex-Linux)
+ all_interfaces=`sed -n 's%^[\ ]*\([^:]*\):.*$%\1%p' < /proc/net/dev`
+ shift
+ ;;
+ regex-*)
+ echo -n "$0 needs to be ported for your `uname -s` system. " >&2
+ echo "Trying to continue nevertheless." >&2
+ shift
+ ;;
+ noregex-*)
+ all_interfaces=
+ unset all_interfaces
+ shift
+ ;;
+ esac
+
+ case ${all_interfaces+regex}-${1+set} in
+ regex-set)
+ # The following interface specification are to be parsed as regular
+ # expressions against all interfaces the system provides.
+ i=`egrep "^$1$" << EOAI
+$all_interfaces
+EOAI
+`
+ shift
+ ;;
+ *-set)
+ # Literal interfaces.
+ i=$1
+ shift
+ ;;
+ *)
+ # No interface specification is following.
+ i=
+ ;;
+ esac
+
+ for port in $i
+ do
+ # We attach and configure each port of the bridge
+ if [ "$MODE" = "start" ] ; then
+ if [ -x /etc/network/if-pre-up.d/vlan ]; then
+ env IFACE=$port /etc/network/if-pre-up.d/vlan
+ fi
+ if [ "$IF_BRIDGE_HW" ]
+ then
+ ifconfig $port down; ifconfig $port hw ether $IF_BRIDGE_HW
+ fi
+ brctl addif $IFACE $port && ifconfig $port 0.0.0.0 up
+ # We detach each port of the bridge
+ elif [ "$MODE" = "stop" ]; then
+ ifconfig $port down && brctl delif $IFACE $port && \
+ if [ -x /etc/network/if-post-down.d/vlan ]; then
+ env IFACE=$port /etc/network/if-post-down.d/vlan
+ fi
+ fi
+ done
+done
+
+# We finish setting up the bridge
+if [ "$MODE" = "start" ] ; then
+
+ if [ "$IF_BRIDGE_AGEING" ]
+ then
+ brctl setageing $IFACE $IF_BRIDGE_AGEING
+ fi
+
+ if [ "$IF_BRIDGE_BRIDGEPRIO" ]
+ then
+ brctl setbridgeprio $IFACE $IF_BRIDGE_BRIDGEPRIO
+ fi
+
+ if [ "$IF_BRIDGE_FD" ]
+ then
+ brctl setfd $IFACE $IF_BRIDGE_FD
+ fi
+
+ if [ "$IF_BRIDGE_GCINT" ]
+ then
+ brctl setgcint $IFACE $IF_BRIDGE_GCINT
+ fi
+
+ if [ "$IF_BRIDGE_HELLO" ]
+ then
+ brctl sethello $IFACE $IF_BRIDGE_HELLO
+ fi
+
+ if [ "$IF_BRIDGE_MAXAGE" ]
+ then
+ brctl setmaxage $IFACE $IF_BRIDGE_MAXAGE
+ fi
+
+ if [ "$IF_BRIDGE_PATHCOST" ]
+ then
+ brctl setpathcost $IFACE $IF_BRIDGE_PATHCOST
+ fi
+
+ if [ "$IF_BRIDGE_PORTPRIO" ]
+ then
+ brctl setportprio $IFACE $IF_BRIDGE_PORTPRIO
+ fi
+
+ if [ "$IF_BRIDGE_STP" ]
+ then
+ brctl stp $IFACE $IF_BRIDGE_STP
+ fi
+
+
+ # We activate the bridge
+ ifconfig $IFACE 0.0.0.0 up
+
+
+ # Calculate the maximum time to wait for the bridge to be ready
+ if [ "$IF_BRIDGE_MAXWAIT" ]
+ then
+ MAXWAIT=$IF_BRIDGE_MAXWAIT
+ else
+ MAXWAIT=$(brctl showstp $IFACE|sed -n 's/^.*forward delay[ \t]*\(.*\)\..*bridge forward delay[ \t]*\(.*\)\..*$/\1 \2/p')
+ if [ "$MAXWAIT" ]
+ then
+ if [ ${MAXWAIT% *} -gt ${MAXWAIT#* } ]
+ then
+ MAXWAIT=$((2*(${MAXWAIT% *}+1)))
+ else
+ MAXWAIT=$((2*(${MAXWAIT#* }+1)))
+ fi
+ else
+ if [ "$IF_BRIDGE_FD" ]
+ then
+ MAXWAIT=$((2*(${IF_BRIDGE_FD%.*}+1)))
+ else
+ MAXWAIT=32
+ fi
+ /bin/echo -e "\nWaiting $MAXWAIT seconds for $IFACE to get ready."
+ sleep $MAXWAIT
+ MAXWAIT=0
+ fi
+ fi
+
+ # Wait for the bridge to be ready
+ if [ "$MAXWAIT" != 0 ]
+ then
+ /bin/echo -e "\nWaiting for $IFACE to get ready (MAXWAIT is $MAXWAIT seconds)."
+
+ unset BREADY
+ unset TRANSITIONED
+ COUNT=0
+
+ while [ ! "$BREADY" -a $COUNT -lt $MAXWAIT ]
+ do
+ sleep 1
+ COUNT=$(($COUNT+1))
+ BREADY=true
+ for i in $(brctl showstp $IFACE|sed -n 's/^.*port id.*state[ \t]*\(.*\)$/\1/p')
+ do
+ if [ "$i" = "listening" -o "$i" = "learning" -o "$i" = "forwarding" -o "$i" = "blocking" ]
+ then
+ TRANSITIONED=true
+ fi
+ if [ "$i" != "forwarding" -a "$i" != "blocking" ] && [ ! "$TRANSITIONED" -o "$i" != "disabled" ]
+ then
+ unset BREADY
+ fi
+ done
+ done
+
+ fi
+
+# Finally we destroy the interface
+elif [ "$MODE" = "stop" ]; then
+
+ brctl delbr $IFACE
+
+fi
diff --git a/recipes/conntrack-tools/conntrack-tools_0.9.14.bb b/recipes/conntrack-tools/conntrack-tools_0.9.14.bb
new file mode 100644
index 0000000000..c35930d42f
--- /dev/null
+++ b/recipes/conntrack-tools/conntrack-tools_0.9.14.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Connection tracking userspace tools for Linux"
+LICENSE = "GPL"
+DEPENDS = "libnfnetlink libnetfilter-conntrack"
+
+SRC_URI = " \
+ http://www.netfilter.org/projects/conntrack-tools/files/conntrack-tools-${PV}.tar.bz2;name=tar \
+ file://conntrack-failover \
+ file://init \
+ "
+SRC_URI[tar.md5sum] = "7e9344fe85bb68bcf65c35034add6655"
+SRC_URI[tar.sha256sum] = ""
+
+inherit autotools
+inherit update-rc.d
+
+INITSCRIPT_NAME = "conntrackd"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/conntrackd
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0644 doc/sync/ftfw/conntrackd.conf ${D}/${sysconfdir}/conntrackd/conntrackd.conf.sample
+ install -m 0755 ${WORKDIR}/conntrack-failover ${D}/${sysconfdir}/init.d/conntrack-failover
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/conntrackd
+} \ No newline at end of file
diff --git a/recipes/conntrack-tools/files/conntrack-failover b/recipes/conntrack-tools/files/conntrack-failover
new file mode 100644
index 0000000000..6d92e637ff
--- /dev/null
+++ b/recipes/conntrack-tools/files/conntrack-failover
@@ -0,0 +1,77 @@
+#!/bin/sh
+#
+# (C) 2008 by Pablo Neira Ayuso <pablo@netfilter.org>
+# (C) 2009 Roman I Khimov <khimov@altell.ru>
+#
+# This software may be used and distributed according to the terms
+# of the GNU General Public License, incorporated herein by reference.
+#
+# Description:
+#
+# This is the script for primary-backup setups for keepalived
+# (http://www.keepalived.org). You may adapt it to make it work with other
+# high-availability managers.
+#
+# Do not forget to include the required modifications to your keepalived.conf
+# file to invoke this script during keepalived's state transitions.
+#
+# Contributions to improve this script are welcome :).
+#
+## Modified to work as init.d script under pacemaker control
+
+CONNTRACKD_BIN=/usr/sbin/conntrackd
+CONNTRACKD_LOCK=/var/lock/conntrack.lock
+CONNTRACKD_CONFIG=/etc/conntrackd/conntrackd.conf
+
+case "$1" in
+ start)
+ #
+ # commit the external cache into the kernel table
+ #
+ $CONNTRACKD_BIN -C $CONNTRACKD_CONFIG -c
+ if [ $? -eq 1 ]
+ then
+ logger "ERROR: failed to invoke conntrackd -c"
+ fi
+
+ #
+ # flush the internal and the external caches
+ #
+ $CONNTRACKD_BIN -C $CONNTRACKD_CONFIG -f
+ if [ $? -eq 1 ]
+ then
+ logger "ERROR: failed to invoke conntrackd -f"
+ fi
+
+ #
+ # resynchronize my internal cache to the kernel table
+ #
+ $CONNTRACKD_BIN -C $CONNTRACKD_CONFIG -R
+ if [ $? -eq 1 ]
+ then
+ logger "ERROR: failed to invoke conntrackd -R"
+ fi
+
+ #
+ # send a bulk update to backups
+ #
+ $CONNTRACKD_BIN -C $CONNTRACKD_CONFIG -B
+ if [ $? -eq 1 ]
+ then
+ logger "ERROR: failed to invoke conntrackd -B"
+ fi
+ ;;
+ stop)
+ $CONNTRACKD_BIN -t
+ $CONNTRACKD_BIN -n
+ ;;
+ status)
+ ;;
+ *)
+ logger "ERROR: unknown command"
+ echo "Usage: conntrack-failover {start|stop|status}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/conntrack-tools/files/init b/recipes/conntrack-tools/files/init
new file mode 100644
index 0000000000..6e2f442cf0
--- /dev/null
+++ b/recipes/conntrack-tools/files/init
@@ -0,0 +1,77 @@
+#!/bin/sh
+#
+# /etc/init.d/conntrackd
+#
+# Maximilian Wilhelm <max@rfc2324.org>
+# -- Mon, 06 Nov 2006 18:39:07 +0100
+#
+# Roman I Khimov <khimov@altell.ru>
+# -- Tue, 27 Oct 2009 14:34:00 +0300
+
+export PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+
+NAME="conntrackd"
+DAEMON="/usr/sbin/conntrackd"
+CONFIG="/etc/conntrackd/conntrackd.conf"
+PIDFILE="/var/run/${NAME}.pid"
+
+
+# Gracefully exit if there is no daemon (debian way of life)
+if [ ! -x "${DAEMON}" ]; then
+ exit 0
+fi
+
+# Check for config file
+if [ ! -f /etc/conntrackd/conntrackd.conf ]; then
+ echo "Error: There is no config file for $NAME" >&2
+ exit 1;
+fi
+
+case "$1" in
+ start)
+ echo -n "Starting $NAME: "
+ for i in nf_conntrack_netlink nf_conntrack_netbios_ns nf_conntrack_proto_dccp nf_conntrack_tftp \
+ nf_conntrack_sane nf_conntrack_pptp nf_conntrack_irc nf_conntrack_amanda nf_conntrack_h323 \
+ nf_conntrack_proto_udplite nf_conntrack_proto_gre nf_conntrack_proto_sctp nf_conntrack_ftp \
+ nf_conntrack_sip; do
+ modprobe $i >/dev/null 2>/dev/null &
+ done
+ start-stop-daemon --start --quiet --make-pidfile --pidfile "/var/run/${NAME}.pid" --background --exec "${DAEMON}"
+ RET=$?
+ if [ "$?" == "0" ]; then
+ sleep 2
+ # Sync with other server
+ conntrackd -n
+ echo "done."
+ else
+ echo "FAILED!"
+ fi
+ exit $RET
+ ;;
+ stop)
+ echo -n "Stopping $NAME:"
+ start-stop-daemon --stop --quiet --oknodo --pidfile "/var/run/${NAME}.pid" && echo "done." || echo "FAILED!"
+ ;;
+ status)
+ echo -n "conntrackd "
+ start-stop-daemon -q -K -t -x $DAEMON
+ RET=$?
+ if [ "$RET" == "0" ]; then
+ PID=`cat $PIDFILE`
+ echo "($PID) is running"
+ else
+ echo "is not running"
+ exit $RET
+ fi
+ ;;
+ restart)
+ $0 start
+ $0 stop
+ ;;
+
+ *)
+ echo "Usage: /etc/init.d/conntrackd {start|stop|restart}"
+ exit 1
+esac
+
+exit 0
diff --git a/recipes/gdb/gdb-cross-sdk_6.6.bb b/recipes/gdb/gdb-cross-sdk_6.6.bb
index aa6e7563cf..7136d4e650 100644
--- a/recipes/gdb/gdb-cross-sdk_6.6.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.6.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
inherit sdk
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
PR = "r3"
diff --git a/recipes/gdb/gdb-cross-sdk_6.8.bb b/recipes/gdb/gdb-cross-sdk_6.8.bb
index ff4423ec44..77ce5c8b7e 100644
--- a/recipes/gdb/gdb-cross-sdk_6.8.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
inherit sdk
diff --git a/recipes/gdb/gdb-cross-sdk_7.0.bb b/recipes/gdb/gdb-cross-sdk_7.0.bb
index 47b8faddb1..76f3f7540d 100644
--- a/recipes/gdb/gdb-cross-sdk_7.0.bb
+++ b/recipes/gdb/gdb-cross-sdk_7.0.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
inherit sdk
diff --git a/recipes/gdb/gdb-cross.inc b/recipes/gdb/gdb-cross.inc
index 6d4c3d177e..ca89d4fdb0 100644
--- a/recipes/gdb/gdb-cross.inc
+++ b/recipes/gdb/gdb-cross.inc
@@ -1,6 +1,6 @@
require gdb-common.inc
-DEPENDS = "ncurses-native"
+DEPENDS = "ncurses-native zlib-native flex-native"
EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
diff --git a/recipes/gdb/gdb.inc b/recipes/gdb/gdb.inc
index a63fb6159b..a519cef584 100644
--- a/recipes/gdb/gdb.inc
+++ b/recipes/gdb/gdb.inc
@@ -2,7 +2,7 @@ require gdb-common.inc
DEFAULT_PREFERENCE_avr32 = "-99"
-DEPENDS = "ncurses readline"
+DEPENDS = "ncurses readline zlib flex-native"
PACKAGES =+ "gdbserver"
FILES_gdbserver = "${bindir}/gdbserver"
diff --git a/recipes/libnetfilter/libnetfilter-conntrack_0.0.101.bb b/recipes/libnetfilter/libnetfilter-conntrack_0.0.101.bb
new file mode 100644
index 0000000000..4117b00278
--- /dev/null
+++ b/recipes/libnetfilter/libnetfilter-conntrack_0.0.101.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Userspace library providing a programming interface (API) to the in-kernel connection tracking state table"
+LICENSE = "GPL"
+DEPENDS = "libnfnetlink"
+
+SRC_URI = "http://www.netfilter.org/projects/libnetfilter_conntrack/files/libnetfilter_conntrack-${PV}.tar.bz2;name=tar"
+SRC_URI[tar.md5sum] = "3c4b4048c914f2694c3ca6de2bb457dc"
+SRC_URI[tar.sha256sum] = "9d2919df3794e1e8f2311ad31949698103061206379b75094cb2bf7851378ab2"
+
+S = "${WORKDIR}/libnetfilter_conntrack-${PV}"
+
+inherit autotools_stage pkgconfig \ No newline at end of file
diff --git a/recipes/libnetfilter-queue/libnetfilter-queue.inc b/recipes/libnetfilter/libnetfilter-queue.inc
index 96ec16c330..96ec16c330 100644
--- a/recipes/libnetfilter-queue/libnetfilter-queue.inc
+++ b/recipes/libnetfilter/libnetfilter-queue.inc
diff --git a/recipes/libnetfilter-queue/libnetfilter-queue_0.0.13.bb b/recipes/libnetfilter/libnetfilter-queue_0.0.13.bb
index 044777c0ce..044777c0ce 100644
--- a/recipes/libnetfilter-queue/libnetfilter-queue_0.0.13.bb
+++ b/recipes/libnetfilter/libnetfilter-queue_0.0.13.bb
diff --git a/recipes/libnetfilter-queue/libnetfilter-queue_0.0.16.bb b/recipes/libnetfilter/libnetfilter-queue_0.0.16.bb
index 044777c0ce..044777c0ce 100644
--- a/recipes/libnetfilter-queue/libnetfilter-queue_0.0.16.bb
+++ b/recipes/libnetfilter/libnetfilter-queue_0.0.16.bb
diff --git a/recipes/libnfnetlink/libnfnetlink.inc b/recipes/libnfnetlink/libnfnetlink.inc
new file mode 100644
index 0000000000..035f1fe5f5
--- /dev/null
+++ b/recipes/libnfnetlink/libnfnetlink.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
+kernel/userspace communication. It provides a generic messaging \
+infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
+nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
+management tools in userspace."
+
+SECTION = "devel/libs"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
+INC_PR = "r0"
+
+SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2;name=libnfnetlink-${PV}"
+
+inherit autotools_stage pkgconfig
+
diff --git a/recipes/libnfnetlink/libnfnetlink_0.0.30.bb b/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
index d3e3cabdc7..400d48de91 100644
--- a/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
+++ b/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
@@ -1,25 +1,7 @@
-DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
-kernel/userspace communication. It provides a generic messaging \
-infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
-nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
-management tools in userspace."
+include libnfnetlink.inc
-SECTION = "devel/libs"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
-PR = "r0"
-
-SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2"
-
-inherit autotools pkgconfig
+PR = "${INC_PR}.1"
do_configure() {
- gnu-configize
- libtoolize --force
oe_runconf
}
-
-do_stage() {
- autotools_stage_all
-}
-
diff --git a/recipes/libnfnetlink/libnfnetlink_0.0.39.bb b/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
index a17a198961..23cbea904c 100644
--- a/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
+++ b/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
@@ -1,25 +1,3 @@
-DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
-kernel/userspace communication. It provides a generic messaging \
-infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
-nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
-management tools in userspace."
-
-SECTION = "devel/libs"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
-PR = "r0"
-
-SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2"
-
-inherit autotools pkgconfig
-
-#do_configure() {
-# gnu-configize
-# libtoolize --force
-# oe_runconf
-#}
-
-do_stage() {
- autotools_stage_all
-}
+include libnfnetlink.inc
+PR = "${INC_PR}.0" \ No newline at end of file
diff --git a/recipes/libnfnetlink/libnfnetlink_1.0.0.bb b/recipes/libnfnetlink/libnfnetlink_1.0.0.bb
new file mode 100644
index 0000000000..b0eac2adf1
--- /dev/null
+++ b/recipes/libnfnetlink/libnfnetlink_1.0.0.bb
@@ -0,0 +1,6 @@
+include libnfnetlink.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[libnfnetlink-1.0.0.md5sum] = "016fdec8389242615024c529acc1adb8"
+SRC_URI[libnfnetlink-1.0.0.sha256sum] = "3752b03a4c09821ee9a2528d69289423a01e7171f1a22dfdd11d5459e03972fb" \ No newline at end of file
diff --git a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb b/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
index 3c210a099b..946f48569e 100644
--- a/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
+++ b/recipes/u-boot/u-boot-mkimage-native_1.3.2.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "U-boot bootloader mkimage tool"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
SECTION = "bootloader"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 6fdbaac87f..24dcb2b966 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "U-Boot - the Universal Boot Loader"
HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
SECTION = "bootloaders"
PRIORITY = "optional"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
PROVIDES = "virtual/bootloader"
DEPENDS = "mtd-utils"
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index fb81caf183..928642dbbb 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r42"
+PR ="r43"
FILESPATHPKG =. "u-boot-git:"
@@ -207,6 +207,9 @@ SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
SRC_URI_sheevaplug = "git://git.denx.de/u-boot-marvell.git;protocol=git;branch=testing"
SRCREV_sheevaplug = "119b9942da2e450d4e525fc004208dd7f7d062e0"
+SRC_URI_xilinx-ml507 = "git://git.xilinx.com/u-boot-xlnx.git;protocol=git"
+SRCREV_xilinx-ml507 = "26e999650cf77c16f33c580abaadab2532f5e8b2"
+
S = "${WORKDIR}/git"
@@ -237,3 +240,19 @@ do_deploy_prepend_mini2440() {
do_deploy_prepend_micro2440() {
cp ${S}/u-boot-nand16k.bin ${S}/u-boot.bin
}
+
+do_configure_prepend_xilinx-ml507() {
+if [ -e "${XILINX_BSP_PATH}/ppc440_0/include/xparameters.h" ]; then
+ cp ${XILINX_BSP_PATH}/ppc440_0/include/xparameters.h \
+ ${S}/board/xilinx/ml507
+ echo "#define XPAR_PLB_CLOCK_FREQ_HZ XPAR_CPU_PPC440_MPLB_FREQ_HZ
+#define XPAR_CORE_CLOCK_FREQ_HZ XPAR_CPU_PPC440_CORE_CLOCK_FREQ_HZ
+#define XPAR_PCI_0_CLOCK_FREQ_HZ 0" >> ${S}/board/xilinx/ml507/xparameters.h
+fi
+}
+
+do_deploy_prepend_xilinx-ml507() {
+if [ -d "${XILINX_BSP_PATH}" ]; then
+ install ${S}/u-boot ${XILINX_BSP_PATH}
+fi
+}
diff --git a/recipes/vim/vim.inc b/recipes/vim/vim.inc
index c160448a5e..9eb0b80c0e 100644
--- a/recipes/vim/vim.inc
+++ b/recipes/vim/vim.inc
@@ -1,9 +1,11 @@
DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
SECTION = "console/utils"
DEPENDS = "ncurses"
+# vimdiff doesn't like busybox diff
+RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-INC_PR = "r3"
+INC_PR = "r4"
SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
file://configure.patch;patch=1"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/omapzoom36x/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/omapzoom36x/xorg.conf
new file mode 100644
index 0000000000..983bb0823a
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/omapzoom36x/xorg.conf
@@ -0,0 +1,29 @@
+Section "Module"
+ Load "extmod"
+ Load "dbe"
+ Load "glx"
+ Load "freetype"
+ Load "type1"
+ Load "record"
+ Load "dri"
+EndSection
+
+Section "Monitor"
+ Identifier "Builtin Default Monitor"
+EndSection
+
+Section "Device"
+ Identifier "Builtin Default fbdev Device 0"
+ Driver "omapfb"
+EndSection
+
+Section "Screen"
+ Identifier "Builtin Default fbdev Screen 0"
+ Device "Builtin Default fbdev Device 0"
+ Monitor "Builtin Default Monitor"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Builtin Default Layout"
+ Screen "Builtin Default fbdev Screen 0"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index 92cd17302d..b7655b8d81 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r22"
+PR = "r23"
SRC_URI = "file://xorg.conf"