aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-07-15 14:46:24 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2009-07-15 14:46:24 +0200
commitbae2b0fd78e786d8fffc255c7fa5f98ceed2e860 (patch)
treea9032d6b6b57fd933d19db5f294ad67f8d5968b9 /recipes
parent5bffb9fee621df4e97360fdb186d5d18a3e8c6b3 (diff)
downloadopenembedded-bae2b0fd78e786d8fffc255c7fa5f98ceed2e860.tar.gz
linux.inc: Check if Makefile.fwinst actually exist.
This fixes the linux-openmoko-2.6.24 build.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes/linux/linux.inc b/recipes/linux/linux.inc
index 5e714e1b7e..581b33ac76 100644
--- a/recipes/linux/linux.inc
+++ b/recipes/linux/linux.inc
@@ -132,7 +132,9 @@ do_configure_append_avr32() {
}
do_configure_append() {
+ if [ -e scripts/Makefile.fwinst ]; then
sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
+ fi
}
do_compile_append() {