aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-08-12 00:30:24 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-08-12 00:30:24 +0200
commite71f85f6b4f015c172fdf570d831ef826d4df8c7 (patch)
treeae237259d5b06159d4d03d5d5404c87e6abce36f /recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
parent5a7e0f0eb265c98248ffd23d4801d1e0c1af031b (diff)
downloadopenembedded-e71f85f6b4f015c172fdf570d831ef826d4df8c7.tar.gz
nandlogical: move to zaurus-utils
Diffstat (limited to 'recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb')
-rw-r--r--recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
new file mode 100644
index 0000000000..8c3ca9da79
--- /dev/null
+++ b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
@@ -0,0 +1,23 @@
+require nandlogical_${PV}.bb
+
+SRC_URI_append = " file://nandlogical.c \
+ file://mtd-user.h \
+ file://mtd-abi.h \
+ "
+DEPENDS += "klibc"
+
+export CC = ${TARGET_PREFIX}klcc
+
+# standard oe cflags don't work with klcc
+export CFLAGS = ""
+export CPPFLAGS = ""
+export LDFLAGS = ""
+
+do_configure_prepend() {
+ sed -i 's:<mtd/mtd-user.h>:"mtd-user.h":g' '${S}/nandlogical.c'
+ sed -i 's:<mtd/mtd-abi.h>:"mtd-abi.h":g' '${S}/mtd-user.h'
+}
+
+do_compile() {
+ ${CC} nandlogical.c -o nandlogical ${CFLAGS} ${LDFLAGS} -static
+}