aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-23 12:48:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-24 11:10:42 +0200
commitce26c079f206116b456163a17e123db66033e6bc (patch)
tree7e3380b4a4c3adec9f51623d83e7e8ca8f4a47a2 /recipes/xorg-lib
parent487b101b42fac7642f42f80883d7a714a3b264b2 (diff)
downloadopenembedded-ce26c079f206116b456163a17e123db66033e6bc.tar.gz
libx11: add -fforward-propagate also to newer 1.3.[34] versions
* PR will be bumped later with INC_PR conversion Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/libx11_1.3.3.bb6
-rw-r--r--recipes/xorg-lib/libx11_1.3.4.bb6
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11_1.3.3.bb b/recipes/xorg-lib/libx11_1.3.3.bb
index 37ef559011..b4c2477ea4 100644
--- a/recipes/xorg-lib/libx11_1.3.3.bb
+++ b/recipes/xorg-lib/libx11_1.3.3.bb
@@ -17,6 +17,12 @@ SRC_URI += "file://x11_disable_makekeys.patch \
# --with-keysymdef has intentionally no effect in native build without without keysymdef_include.patch
EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+# Below option is added to overcome the GCC bug on ARM
+# see http://gcc.gnu.org/PR42981 for further details.
+# We could potentially take it off when its fixed in gcc 4.5
+
+CFLAGS_append_arm = " -fforward-propagate "
+
do_compile() {
(
unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
diff --git a/recipes/xorg-lib/libx11_1.3.4.bb b/recipes/xorg-lib/libx11_1.3.4.bb
index 1a7432caa6..be1702a64f 100644
--- a/recipes/xorg-lib/libx11_1.3.4.bb
+++ b/recipes/xorg-lib/libx11_1.3.4.bb
@@ -17,6 +17,12 @@ SRC_URI += "file://x11_disable_makekeys.patch \
# --with-keysymdef has intentionally no effect in native build without without keysymdef_include.patch
EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+# Below option is added to overcome the GCC bug on ARM
+# see http://gcc.gnu.org/PR42981 for further details.
+# We could potentially take it off when its fixed in gcc 4.5
+
+CFLAGS_append_arm = " -fforward-propagate "
+
do_compile() {
(
unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS