summaryrefslogtreecommitdiffstats
path: root/recipes/xml-commons/jdom_1.1.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
commit2e7c334a4f6b0882ee90c8be91f81d24e4d82496 (patch)
tree11c29c8c61eb8679015869fea7aab5e51cd8eec7 /recipes/xml-commons/jdom_1.1.bb
parent04800cfdf823ea3003eb1164c4d5dfd7e1db5679 (diff)
downloadopenembedded-2e7c334a4f6b0882ee90c8be91f81d24e4d82496.tar.gz
dom4j 1.6.1: New recipe (for Jalimo SVN).
dom4j-native 1.6.1: Dito. jaxen 1.1.1: Dito. xom 1.1: Dito. xpp2 2.1.10: Dito. xpp3 1.1.3.4.0: Dito.
Diffstat (limited to 'recipes/xml-commons/jdom_1.1.bb')
-rw-r--r--recipes/xml-commons/jdom_1.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/xml-commons/jdom_1.1.bb b/recipes/xml-commons/jdom_1.1.bb
new file mode 100644
index 0000000000..e4be922b9e
--- /dev/null
+++ b/recipes/xml-commons/jdom_1.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs"
+LICENSE = "BSD"
+
+HOMEPAGE = "http://jdom.org/
+
+DEPENDS = "fastjar-native jaxen"
+
+SRC_URI = "\
+ http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \
+ "
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s jaxen
+
+ javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+